Gadgets not working with IE-11 Win7 Pro SP-1 (NOT Win8.1 Preview) RRS feed

  • Question

  • Just downloaded IE-11 developer preview. (Windows 7 pro sp1 IE-10)
    After reboot all of my gadgets disappeared.
    Still there on rt. click dialog box on desktop but when I click nothing happens.
    Also clicked in control panel same result.
    Ran sfc /scannow and did not fix.
    Rebooted and still not there.
    I am running Shortcut Manager (Frameworkx\FxVisor) to remove arrows on shortcuts and I think this program might not let my gadgets launch?
    I downloaded IE-10 as soon as it was available for Win7 and never had any problems.
    Had to do a system restore to get my gadgets back.
    Are gadgets not supported in IE-11?
    I know Microsoft does not support gadgets anymore, could this be why?
    Anyone else have this happen?
    Monday, August 5, 2013 10:25 AM

All replies

  • Similar issues here. The Gadgets are corrupted including the one for AVG. Weather Gadgets show black background and purple text. CPU / Memory Gadget shows text on white background.
    Friday, August 9, 2013 3:03 PM
  • Still No Solution Available on the Internet of from the Microsoft.
    Thursday, October 10, 2013 1:58 AM
  • Hi,

    I can't find the link, but as far as I know users are urged to discontinue use.

    see http://windows.microsoft.com/en-AU/windows-vista/Windows-Sidebar-and-gadgets-overview


    Post consumer questions about IE to http://answers.microsoft.com/ie (Help>Online Support menu from IE)



    Thursday, October 10, 2013 2:38 AM
  • Hello,  same problem in my Win 7 Ultimate CZ. After installing MSIE 11 from web system gadgets (Clock, CPU Usage) not displaying - only CPU bad text. After Win 7 restoring point back to MSIE10 gadgets works OK.

    Please, any suggestions?? Microsoft or admins, please HELP!

    Thank you very much

    Friday, November 8, 2013 4:35 PM
  • Shouldn't something as simply as this get tested before they release the )*&^-ing thing?
    Friday, November 8, 2013 7:07 PM
  • Same here with public IE11 final, Win7 x64. All gadgets appear transparent + purple.


    Uninstalling IE11 and going back to IE10 (http://windows.microsoft.com/en-us/windows-vista/remove-an-update) the gadgets look ok again. Re-installing IE11 causes the problem every time.

    Windows 7 x64 SP1

    • Edited by Hexaae Saturday, November 9, 2013 7:18 PM
    Saturday, November 9, 2013 11:31 AM
  • I've just found the corrupt Gadgets are visible only when I use DPI > 100% Smaller Fonts (default on my full-HD laptop is DPI 125%).

    With IE11 installed if I reset DPI to 100% Smaller Fonts the Gadgets look good again. Must be a bug in DPI settings + Sidebar Gadget, when IE11 is installed. Must be a bug in IE11 and Sidebar gadget.xml <autoscaleDPI>...

    Windows 7 x64 SP1

    • Edited by Hexaae Sunday, November 10, 2013 12:01 AM
    Saturday, November 9, 2013 11:33 PM
  • Yess, I try to set fonts DPI to 100% and gadgets WORKS in my Win 7 Ultimate SP1 x86 with MSIE 11. So, is any possibility, how to modify your gadget.xml or other files to working gadgets with bigger fonts DPI than 100%?? Thank you, Microsoft, and friends-developers to resolve this problem!!!


    • Edited by KukMikuk Tuesday, November 12, 2013 6:55 PM
    Tuesday, November 12, 2013 6:50 PM
  • You are right. Removing the following tag completely:


    from the gadget.xml file resolves the issue even if the DPI is set to 125%. Setting the tag to disallow autoscale, however, did not help for me but it seemed to be working for most of the people.

    Mind that the gadgets in question will look smaller in comparison with the ones that were not affected by the problem.

    Have A Nice Day!

    • Edited by DrDivan55 Friday, November 15, 2013 1:45 PM
    Wednesday, November 13, 2013 5:11 PM
  • I do not personally recommend the alternate work-around I've seen elsewhere of deleting any registry keys and/or reducing any of your internet security zones.  I have consolidated and cleaned up countless snips from many forums all over the place (cited sources of where I could remember I found the concepts), ESPECIALLY from this thread which helped me a lot (thank you!!!!!!);

    Here's my consolidated notes and research; full disclaimers, hold me harmless, and always backup first! :)

    Overview of IE11 BUG:

    This bug in the public release version of Internet Explorer 11 (aka IE 11 aka IE11 RTM gold release) causes Windows 7 Gadgets to bug out.

    Specifically, with IE11 installed on Windows 7, due to a bug in IE11, increasing DPI past 110% triggers SOME of the Gadgets to glitch, bug out, completely disappear, etc.  This bug can be worked-around and "fixed" by modifying its Sidebar gadget.xml <autoscaleDPI>...  described in detail below.

    This bug is irrelevant to Windows 8 / 8.1 because Microsoft removed the beloved Gadgets entirely in Win8 due to so many third-party evilware writers embedding malware into their "free" downloaded Gadgets (note to the best of my current knowledge, using the standard Microsoft Gadgets included with Windows 7 are all perfectly safe).

    To reiterate, notice the following Microsoft article is only talking about potential malware in third-party downloaded Gadgets, and specifically I do NOT see where it mentions any problems using any of the official Microsoft build-in Windows 7 gadgets, cited from:  http://technet.microsoft.com/en-us/security/dn261332

    BUG FIX:

    Option 1: Set DPI back to 100% Smaller Fonts (default) or maximum 110% and the Gadgets come back to life and work fine upon relog.

    Option 2: If you need greater than 110% DPI, and want Gadgets to work, then... For each broken Gadget, modify its protected file:  gadget.xml   (as detailed below).


    Note as a side-effect, after the "fixed" Gadgets in question come back they may look smaller in comparison with the ones that were not affected by the DPI bug (because this fix locks their DPI at default 100% whereas your others are dynamically changed).

    Located in:  C:\Program Files\Windows Sidebar\Gadgets

    Inside that folder, find the glitched Gadget you want to fix, go into its specific folder, and edit its gadget.xml, Remove the following tag completely:


    Deleting that tag from the gadget.xml file resolves the issue even if the DPI is set to 125%. Setting the tag to allow autoscale doesn't help.  BE CAREFUL not to leave a blank line!


    1. Make backup of effected gadget.xml somewhere
    2. Task Manager -> End Process of "sidebar.exe" to unlock all Gadget's files
    3. Take temporary ownership and give yourself RW permission to modify Gadget's files
    4. Put all Gadget file ownership and RW permissions back to "TrustedInstaller" for security
    5. Change DPI and relog to relaunch Gadgets


    From Security Tab in Properties of file you want to change >>Click Advanced >>Select Owner >>Click Edit >>Click Other users or Groups >>Click Advanced >>Click Find Now, make yourself owner, then add write access for yourself.

    Launch NOTEPAD or similar editor as ADMIN, to modify the gadget.xml file (the folder structure itself is still permissions-protected, but I strongly suggest you leave that alone and just use admin for editing this one file this one time)

    Put Ownership and all permissions back to what they were (First, set read-only for everyone EXCEPT leave RW alone for the TrustedInstaller service, and THEN set Owner back to TrustedInstaller).

    NOTE: TrustedInstaller does not exist in the "visible" users and groups as it runs as an NT Service.  Don't panic. To restore its special ownership:

        Right mouse button click on the file and choose Properties
        Click Security tab
        Click Advanced button
        Click Owner tab
        Click Edit button
        Click Other User or Group and type in:  NT SERVICE\TrustedInstaller
        Search and click Ok on all dialogs until all property dialogs are closed etc.

    Cited from http://blogs.msdn.com/irenak/archive/2007/01/30/sysk-277-how-to-bring-back-the-trustedinstaller.aspx

    Double-confirm you set all regular users and groups permissions are reverted defaults back to what they were (read-only), and the *ONLY* Owner/RW is TrustedInstalled, to lock it back down for security reasons! E.G. to avoid future vulnerability!

    To test:

    I fixed my Clock gadget.xml but left the Calendar alone.  Changed DPI to 125% and relog off/on and notice Clock now works, but yes it looks slightly smaller than the working Calendar Gadget which isn't effected by this bug.  Repeat process for Calender if you want it smaller to match, but it works fine bigger. Repeat this process for all of your favorite broken Gadgets using IE11 on Windows 7.


    1.) Personally I view this as a work-around not a true fix, but considering Microsoft officially discontinued Gadgets as mentioned earlier, it's possible this bug may take a very long time, if ever, to be officially fixed.

    2.) IE11 also bugs out a lot of other things such as Outlook 2003 spellcheck, and other general software compatibility issues, especially in Windows 7, so it's probable that some or all of IE11's bugs should be eventually fixed in the future - thereby as a side effect may also officially fix Gadgets some day too.

    I hope my consolidated notes and such help a wider audience.

    Good luck!

    Thursday, November 14, 2013 6:11 PM
  • All good up until you didn't explain "make yourself owner, then add write access for yourself."

    Do I choose Administrator or what??, can you be more detailed please in how to make yourself owner and how to add write access.

    Friday, November 15, 2013 8:16 AM
  • For the MS gadgets, it's a lot easier just to copy them to

    C:\Users\[Your User Name here]\AppData\Local\Microsoft\Windows Sidebar\Gadgets

    (Appdata is a hidden folder)

    Then you can edit the gadget.xml file without worrying about permissions. You will then have two identical gadgets in the gadget control panel so it makes sense to give the copy a new name in the gadget.xml file eg change




    Also it seems to be enough (for me) to change the autoscaleDPI setting to false eg change




    The statement in a previous reply - "Setting the tag to allow autoscale doesn't help" - is strange. The value can only be true or false and the tag is already set to allow autoscaling - that's the problem.

    If you decide to run any of the MS gadgets from the location above, set your dpi back to 100% first and close any of the originals that are running.

    This bug seems to affect the g:background element.
    Friday, November 15, 2013 12:47 PM
  • Well that's my mistake. I corrected it. But setting the value to false  did not work for me so I had to delete the whole tag. Another thing I noticed is that the affected gadgets use similar font. So I think the problem is that IE11 makes that font display incorrectly when a higher DPI setting is used and maybe that causes the problem with Outlook, some Internet sites, etc.

    Have A Nice Day!

    Friday, November 15, 2013 1:42 PM
  • You might find that there are more similarities than just the fonts being used.

    Here are two simple test gadgets. They are identical except for the use of a g:background.

    Gadget A - with no g:background

    <html xmlns="http://www.w3.org/1999/xhtml">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <style type="text/css">
    #divA {width:130px;height:60px;padding:10px;color:#f00;}
    <script type="text/jscript">
    function fx(){
    <div id="divA">

    Gadget B - with g:background

    <html xmlns="http://www.w3.org/1999/xhtml">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <style type="text/css">
    #divA {width:130px;height:60px;padding:10px;color:#f00;}
    <script type="text/jscript">
    function fx(){
    <g:background id="bg" src="bg60.png">
    <div id="divA">

    This is what they look like with dpi set to 100% and/or autoscaleDPI set to false

    This is what they look like with dpi set to 125% and autoscaleDPI set to true

    The g:background reference gives three ways of declaring the src of a g:background. When the src is not declared in the g:background tag itself, this warning is given :

    Important  For Windows 7, when the new <autoscaleDPI> element of the gadget manifest is set to true (for high-DPI support) and the following methods are used, rendering issues can increase significantly.

    I have yet to have the time to try everything, but it looks like that warning now applies to all three methods.

    • Edited by mystifeid Saturday, November 16, 2013 12:24 AM clarification
    Saturday, November 16, 2013 12:15 AM

    Symptoms: Gadgets suddenly disappear. All shortcuts and links to gadgets are unresponsive. IE 11 was recently installed.

    This entails no changes to the registry nor removing IE 11. This is on the Win 7/64 platform.

    Open: Control Panel

    Select Programs and Features

    In the Left Pane select the link: "Turn windows features on or off."

    Look for Windows gadgets Platform it will most likely be checked.

    Uncheck it


    Go back to the Turn Windows features on or off dialog and check the box

    The gadgets should reappear immediately.

    Saturday, December 28, 2013 1:02 AM
  • I read, and tried your suggested FIX for my gadgets not working, after installation of IE-11, and it works, sometimes, but not every time?


    Is there anyway I set a varible, such as "SET AutoDPI=300", or such, perhaps in a file that will execute everytime I boot, and over-ride what ever is preventing my gadgets from working consistantly?


    Old Paul?


    PS: I used a free-ware utility called "Unlocker", to rename the .xml file to .bak, then edited it, and renamed it back to .xml, and it worked well, it that will help anyone else?

    Saturday, July 26, 2014 8:32 PM
  • I just tried your SIMPLE FIX, and it appears to work?

     Will post another Reply, when I have time to see if/how long it works every time I start, or reboot my computer system?


    Old Paul

    Saturday, July 26, 2014 8:52 PM
  • Well, so much for the SIMPLE FIX, as well as editing gadget.xml too.

    The Simple Fix worked for acouple of days, then started working "some times", then not at all.

    I tried repeating the SIMPLE FIX, several times, but only worked for that login time, and not the next time booted up, nor there after?

    Anyone got any better ideas?

    Wednesday, July 30, 2014 12:37 AM
  • Even with dpi set to 100%, (and with IE11 installed) sometimes my gadgets do not appear after booting the computer. Task Manager shows that the sidebar.exe process is running.

    So I saved the simple script provided below as restartSidebar.js and created a convenient shortcut. It has not failed yet.

    function restartSidebar(){
     var wshShell=new ActiveXObject("WScript.Shell");
     wshShell.Run("cmd.exe /q /c taskkill /F /IM sidebar.exe && \"%ProgramFiles%\\Windows Sidebar\\sidebar.exe\"", 0, false);

    Thursday, July 31, 2014 2:03 PM
  • David (blogthis), I know that you got the heart of this from other contributors and I am very grateful to them.  But, I have to give you a very special Thank You for the amazing way you have organized it and made it simple for me to ever take Option 2.  I don't even care if Microsoft ever fixes the bug or not, because I now have my gadgets working just fine.  What's more, thanks to you guys, I have them working on Windows 10 Technical Review Build 9926.  Thanks a bunch!

    Saturday, February 7, 2015 2:36 AM
  • blogthis,

    thanks for your post.  I followed your instructions and I was able to restore my Windows 7-64 Clock gadget.  Although there were a couple of steps missing, I was able to fill in the gaps and restore my clock.  Even though my Clock gadget is now 25% smaller than my Calendar gadget, at least it's still there.

    For anyone who wants to fix the Clock's gadget.xml file, use the Calendar's gadget.xml file as a template to ensure you have restored the Clock's gadget.xml file protections.  Do not alter the Calender's gadget.xml file in any way.

    Friday, March 13, 2015 2:22 PM