none
(500) Internal Server Error.. RRS feed

  • Question

  • Hi,We are getting this error very frequently wehn calling a WCF service (3.5version) which uses sharepoint server object model

    Exception is:-------------------------------

    The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<html>

        <head>

            <title>The handle is invalid. (Exception from HRESULT: 0x80070006 (E_HANDLE))</title>

            <style>

             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}

             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}

             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}

             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }

             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }

             pre {font-family:"Lucida Console";font-size: .9em}

             .marker {font-weight: bold; color: black;text-decoration: none;}

             .version {color: gray;}

             .error {margin-bottom: 10px;}

             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }

            </style>

        </head>

        <body bgcolor="white">

                <span><H1>Server Error in '/Application.<hr width=100% size=1 color'.

    ------------ Inner Exception is............

    The remote server returned an error: (500) Internal Server Error..

    Whenever we get this error, we are browsing the service url , then it starts working fine. But we are getting this problem very frequenctly ( 3 times per day). Please help us to resolve this issue.

    Friday, May 11, 2012 4:32 AM

Answers