none
SHIFT+R improves image quality CTRL+F5........

    Question

  • Hi

    All of a sudden on almost every web page i get poor distortioned images which when my cursor goes above the image i get the message : "SHIFT+R improves image quality CTRL+F5 reloads the whole page"
    I obviously dont want do that everytime a am on the web...Why has it started doing that all of a sudden and how to avoid this problem so my the images display properly??? I am using IE6.

    Any advice is appreciated... Thanks in advance...

    Laila

    Thursday, November 02, 2006 4:49 PM

Answers

  • Apparently, you are experiencing "image recompression" through your service provider. When you connect over a Universal Mobile Telecommunications System (UMTS) such as Sprint or Vodafone Mobile Connect, the images are downgraded to reduce the amount of data that is transmitted. The ISP modifies every HTTP request to inject javascript that produces the tooltip you describe.

    You should be able to turn off compression with the Vodafone Mobile Connect tool.

    Monday, November 13, 2006 10:44 PM

All replies

  • Does anyone have an answer for this?  I have the same problem.  Changed DPI from 120 to 96 bust still the same fuzzy pictures.  Thanks
    Sunday, November 12, 2006 6:16 AM
  • Apparently, you are experiencing "image recompression" through your service provider. When you connect over a Universal Mobile Telecommunications System (UMTS) such as Sprint or Vodafone Mobile Connect, the images are downgraded to reduce the amount of data that is transmitted. The ISP modifies every HTTP request to inject javascript that produces the tooltip you describe.

    You should be able to turn off compression with the Vodafone Mobile Connect tool.

    Monday, November 13, 2006 10:44 PM
  • Thanks John.  I went to Tools -> Options -> programs

    there is not an option called compression

    what shall i do?  many thanks.

    Tuesday, November 14, 2006 9:40 PM
  • Sorry. I see I have created some confusion.

    I didn't mean to imply that you could change this setting in Internet Explorer. I was referring to the Vodafone Mobile Connect tool. (Based on what I've read, you should be able to alter a setting there.) There's quite a number of people affected by this problem, which has the same symptoms no matter which browser you use. You can either disable JavaScript (not really an option), or you can alter the browser identification string (which has side effects).

    READ MORE HERE: http://www.evdoforums.com/thread1053.html

    The best answer is to switch to an ISP that does not force you to use a lossy format to download images.

    Wednesday, November 15, 2006 12:43 AM
  • Try updating to Java version 1.5.0 this will fix this problem
    Tuesday, November 21, 2006 12:03 AM
  • Try going to <start> <control panel><java>[update]tab "update" this will install version 1.5.0 and will solve this problem.
    Tuesday, November 21, 2006 12:08 AM
  • Hi guys.. thanks for your replies.. i updated Java and still has the same problem.

    I think John was probably right about using Vodafone mobile.  I can't seem to find the option that will stop the image repression.   :(

    So I am stuck I guess??  :((

    Tuesday, November 21, 2006 9:21 PM
  • I'm having the same problem, however, I haven't contacted my Verizon Wireless (my ISP) yet. Please let me know when you find a resolution to this issue. Thanks!

    Monday, January 01, 2007 3:35 PM
  • I have found a way round this but it's ugly.

    If you use a proxy server, vpn server or Google Web Accelerator The last option is free but means google get to find out what pages your using, there are free sites with lists of open proxies out there, but they are unreliable.

    Using one of these will:
    1) bypass the image resizing.
    2)bypass any restrictions your ISP has (content - t-mobile require you to pay extra to view adult content - not any more)
    Thursday, March 29, 2007 2:37 PM
  •  

    I'm with vodafone and hate this problem. Installing google web accelerator did not fix it.
    Wednesday, November 14, 2007 9:27 AM
  • hi john you seem like a man who knows his stuff this shift and r thing is driving me crazy i connect to the internet via a wireless thing from t mobile help me please how do i sort it out i have added that google accelerator and up graded java still i fear ii will destroy my computer if i cant sort this out help please

     

    Wednesday, January 23, 2008 5:49 AM
  •  

    Sorry to disappoint you, but I really have no idea. As a moderator, I try to help answer questions that come up in the forums, however this is one area where I rely on others to chime in with their personal experience. Using wireless for Internet access works, but it comes with its downsides. If the experience is less than optimal, you might need to investigate other options.
    Wednesday, January 23, 2008 7:29 PM
  • I found a simple answer and it works for me. I am using Orange, not Vodafone, but I guess it will work in your case too. Once I figured out on forums, there is some javascript injected I went looking for it. I used "View source" option for that and in the first line I had something like this (it probably depends on your provider):
    <script src="http://1.2.3.4/bmi-int-js/bmi.js" language="javascript"></script>

    If you are able to find it (it will be similar text to the one above, and on the very top of the page source), on a page displaying this annoying hint, try opening it in new tab and find exact text of this ugly tooltip (Ctrl+F might help)
    If it is there you may try the following:

    1. First of all, use a normal browser like firefox, and not the one that lets browsing the internet from your computer, and the other way around.
    2. Download Adblock-Plus add-on
    3. Add a filter that blocks the javascript you have found (in my case it is "http://1.2.3.4/bmi-int-js/bmi.js")


    I think doing such thing in Internet Exploder is way harder if not impossible.
    I havent tested how does it affect my connection speed yet.

    Regards,
    Marek
    • Proposed as answer by inaroundroom Sunday, July 05, 2009 2:31 PM
    Thursday, January 24, 2008 10:01 PM
  •  

    I use Vodafone Mobile Connect Version 9.1.2.5766

     

    Here's how I fixed it:

    In Vodafone Mobile Connect

    Click Settings > Optimisation

    Drag indicator all the way to the left for High-quality images

     

    Then delete temporary internet files so that the images can refresh (simply hitting refresh in the browser won't download a new image)

     

    This worked for me.

     

    If you have an older version, that setting may not be available. If so, install an upgrade

     

    Let me know how you go.

     

    I spent ages on the net looking for a solution until I worked it out myself!

    Tuesday, January 29, 2008 11:08 PM
  • By reading all the answers on this page, I was finally able to figure this out on my machine. This has been driving me crazy for weeks!!  I use a Verizon Wireless card, so I go to the VZAccess program that I use to connect to the internet.  Within that program window, I went to the Tools...Preferences, then switched to the Venturi tab where I have the option to turn image compression on or off and then specify highest or lowest quality image.  I have now fixed it and all images are coming across the way they should.  I imagine that for anyone that connects to the internet using a wireless provider, there should be some sort of Tools...Properties within your own connection window.  Good luck!!

    Sunday, February 10, 2008 7:33 PM
  •  

    Hey all.....I bought a new laptop on Thursday and went for the vodafone mobile broadband...and encounterred this problem. Took it back to PC world and they'd not seen the problem before....so they sent me away to start from scratch again with the laptop to factory settings and to reload the vodafone modem in ..... same thing happened with the pics.

    Went back to the store today....excellent guy tried his best to overcome this....but I came away with a different modem to try after I'd started from scratch AGAIN with my laptop....

    Same problem.....

     

    Just contacted VODAFONE UK to be told its a known problem...they are working on it as its in there to limit usage to 3 gig and reducing the quality of pictures helps stary below the 3 gig limit.....

     

    VODAFONE are going to have software to overcome this problem in about 8 WEEKS....until then as far as they are concerned you can get the internet so thats the deal!!!!

    Saturday, February 23, 2008 1:31 PM
  • This did my head in and I think I got it sorted, try from you browser (Assuming recent MS IE!) go Tools - Internet Options - Connections - Settings - Properties - Select the modem if not already selected in the 'Connect Using' Box - hit Configure and then unselect 'enable modem compression'. Good luck

     

    Monday, February 25, 2008 11:34 PM
  • EDIT:  I've just realised a big source of confusion.  The vodafone mobile connect LITE software does not have the option to disable the compression. Instead you need to download and install the full version from here:

    http://www.business.vodafone.com/site/bus/public/enuk/support/10_productsupport/laptop_connectivity/40_software/software/05_summary/p_summary.jsp
    AND disable the composite device in device manager to prevent it running the 'lite" version every time you plug in the dongle.

    Nick...
    Wednesday, February 27, 2008 2:17 PM
  • I use T-Mobile and I found my way in here to find a fix.

    After not finding the answer here I experimented myself and found the solution to my problem was....

    Update Java
    Clean out cache/cookies on all browsers

    Then from then on one has to do a hard refresh on each and every page that one has viewed prior. The secret is hard refreshing on every page.

    I had updated java and clean out my cookies every day but never thought to do hard refreshes on each and every page after.

    This may not cure everyone on T-Mobile's problem but it's a good place to start.


    Wednesday, April 02, 2008 3:16 AM
  • Just in case there are more users of the dutch KPN network... you need to replace your APN from the default "fastinternet" to the non-compressed "internet". Hope this saves you the hours it costed me to find the cause...

     

    Wednesday, July 30, 2008 2:42 AM
  •  

    I have also  the image compression problem, and use the dutch KPN Mobile, (Internet through a USB stick).

    Where can i find that fastinternet > internet ? APN ??

     

    thnx in advance.

     

     

     

    edit: nevermind, found it.

     

    You have to make a new profile in your KPN settings.

    Sunday, August 03, 2008 5:38 AM
  • When you look in the source of the web page you will see something like this: <script src="http://1.2.3.4/bmi-int-js/bmi.js" language="javascript">. Place the adress 1.2.3.4 in your list with restricted websites of Internet Explorer and the problem is solved.

     

     

    Monday, October 13, 2008 8:45 PM
  • Many thanks Dennis! Works easy and perfect!

     

    Needed a fix, because using an Vodafona UMTS stick in a remote conference location for the launch of a big website... The site would look a bit silly to the press with all the images blurred...  

     

    Monday, October 20, 2008 9:38 PM
  • Hi, I have vodafone mobile connect, running Vodafone Mobile Connect Lite 9.3.3.10523 with a Vodafone Mobile Modem Pro - basically the best one they have available in the UK.

    This worked for me perfectly and the Javascript was identical. You don't even need to create a rule to sort this problem, just open blockable items in adblock pro and for me its the first one.

    Cheers - I've been saving my favourites from explosm and they no longer look like grainy rubbish!

    Oh and my connection speed hasn't been affected at all.

    Yay!!!!

    One very grateful Henry.
    Sunday, November 09, 2008 1:56 AM
  • Thanks Nick, even though I already did the Javascript workaround, this is certainly worth doing.
    Sunday, November 09, 2008 2:01 AM
  • One way to get around the javascript issue, and get perfect quality images in your browers (without installing a client) is to set accept headers of:

    Pragma=no-cache

    Cache-Control=no-cache

    Easy in firefox with "modify headers" add-on, but not sure how to do this in IE. Anyone??

    Basically, when a ctrl+f5 (full refresh) is done, this sets these headers, and you get the original images in the http response. The js "1.2.3.4/bmi etc etc" is not invoked...

     

     

    Sunday, November 09, 2008 11:58 AM
  • hi there,
    i don't have a client software installed as i use internet connection sharing from my windows mobile device to access the internet, therefore can't disable the image compression there.

    blocking the javascript doesn't solve the problem.  it gets rid of the tooltip alright, but javascript doesn't compress your images - it allows for the originals to be reloaded.  therefore disabling the script will only disable the SHIFT+R combinations and the tooltips.

    i have found a partial solution to the problem and i think it is possible to find a full solution with some javascript guru's help.  the trick is to make your browser think that 1.2.3.4 is not your ips's proxy but another machine that you have a control over.  there are many ways to achieve it, this is what i did:

    1.  i assigned static ip addresses to my 2 spare lan adapters.  one is 1.2.3.4 and the other one 1.2.3.5, with mask 255.255.255.0.  i also connected them by a lan cable (crossover recommended, especially with old lans).  if you wonder why i need 2 spare adapters and the cable connection - windows vista will not see the ip address if there is no active connection.  i'm not sure about xp.

    2.  i installed iis, created the appropriate directory structure in wwwroot directory and copied the bmi.js script there.

    3.  now, the script has to be changed.  what i did to it effectively causes reloading all original images after the page fully loads.  i added this bit on the very beginning of the bmi_SafeAddOnload:
    bmi_reDownloadAllImages(); return;

    4.  so why is it a partial solution?  there are websites that use javascript to display images.  these are not reloaded in full quality and if you want to see them, you have to press ctrl+f5 and make the image display (e.g. click a thumbnail or whatever) before the page fully loads.  just to be clear:  you had to do the same with original script as it thought that the picture was already refreshed, even if a source had changed.

    now, i need a brave javascript guru to download this file and change it accordingly:  http://www.emsoft.com.pl/bmi.js  all you need to know is that this line is added at the end of every page browsed:
    <script language="javascript"><!--bmi_SafeAddOnload(bmi_load,"bmi_orig_img",0);//--></script>

    any questions?  just ask...
    Sunday, December 21, 2008 7:31 PM
  •  It's compressing the image so it downloads faster and doesn't use as much bandwidth.

    If you're using Internet Explorer:

    Click on Tools \ Internet Options \ Advanced.

    Scroll down, and check "Show pictures". Uncheck "Smart image dithering".

    Keep browsing and keep smiling :)
    Saturday, March 21, 2009 7:42 PM
  • RE: Internet Explorer images, links, and font suddenly become grainy? Lets make Internet Explorer appear nice and crisp again by the following simple fix:  go to (Control Panel), select (Display Properties), select (Appearance), check your font size and confirm its set to (Normal)  If your system asks for the Windows Installation disk i.e. i386 folder don’t worry about it, just navigate to the windows folder and scroll to fonts folder and select, then click ok.  You will need to reboot. If your fonts are set to normal currently, change to large, click ok, reboot, then change back to normal and click ok and reboot again.

    If this fails then its imminent you will need to reinstall java. (no need to uninstall, just install over the existing) I recommend downloading the full installation file and executing the install. IMPORTANT: close all your browser windows. Also be careful and read each step during the install so you can unselect the toolbar junk these companies try to sneak in. After you have re installed java reboot and test again and you should be good to go.

    Sunday, March 22, 2009 4:43 AM
  • I use 3G connection from Orange since september 2008. It works fine. Yesterday I had the same problem: image recompression. I solve this by dowlnoading an aplication from Orange (mobile-data-accelerator). Now I can control the image compression, increase, decrease it or disable.

     http://www.orange.ro/files/aplicatii/mobile-data-accelerator.zip
    Thursday, April 02, 2009 7:47 AM
  • does anyone have the same solution but for o2?
    Tuesday, April 14, 2009 11:41 PM
  • The social that godlimauz provided above works with o2 in the UK fine and I can imagine other providers also....
    Sunday, July 05, 2009 2:31 PM
  • hi john boy, i know i'm reaaaally behind on this thread and you've probably fixed the issue by now, but just in case anyone is madly searching for a fix....

    there's a simple method of doing this if you're using a t-mobile web stick.

    open your 'web n walk manager'
    click on the 'more' button
    go down to 'speed manager'
    the 'enabled' option will be ticked; click on 'settings'
    pull the option slider down to 'lowest' option. 

    i re-started my laptop after this, re-connected, and the issue is fixed. 

    you will still get a hover message over some images; this is because you have the speed manager enabled.  but your pictures will be clearer. 

    t-mobile compresses these images at a 'medium' level to optimise your page loading speed etc.  i think this is something they're working on, but who knows when they'll sort it out.
    Saturday, September 05, 2009 11:15 AM
  • i have the same problem with my T Mobile broadband...its the USB stick.. i cant seem to get my images to come out properly..any help?? i've tried nearly everything :(
    Friday, September 25, 2009 12:07 PM
  • When you look in the source of the web page you will see something like this: <script src="http://1.2.3.4/bmi-int-js/bmi.js" language="javascript">. Place the adress 1.2.3.4 in your list with restricted websites of Internet Explorer and the problem is solved.

     

     


    Thanks for this solution Dennis, worked like a charm; I just added http://1.2.3.4/ to restricted sites and no more image compression!
    • Proposed as answer by Ka_Ci Saturday, October 16, 2010 1:23 PM
    Friday, December 18, 2009 10:14 AM
  • hey, i actually have the reverse problem where i would like to ENABLE the reduction in image quality! any advice for someone on orange mobile broadband in the uk?

    thanks

     

    • Proposed as answer by Ka_Ci Saturday, October 16, 2010 1:22 PM
    Tuesday, April 06, 2010 8:17 AM
  • excuse me if i'm wrong, but don't be too sure youre not getting the recompressed image. cause in my case i suppose i'm still getting the loQ recompressed image. the restriction procedure simply removes the "Shift+R ....." popup but imege recompression doesn't stop. i found out the original image link is somewhat different like: "website"/image.jpg/bmi_orig_img/image.jpg this is happening with all the browsers i know but download managers are somehow not affected. can you please confirm-- anyone?
    Saturday, October 16, 2010 1:10 PM
  • this worked an absolute dream with T-mobile too.

     

    thank you very much

     

    James

     

    Wednesday, November 03, 2010 12:12 PM
  • I am having this problem with T-Mobile mobile broadband.  What is it that gets the images to load correctly?

    Thank you!

     

     

    Sunday, November 21, 2010 10:36 PM
  • Finally fixed the same problem...i use an at&t mobile "stick" to connect to the internet  and have had these blurry images for a long time...i searched a long time to find the above answers.

    i went to the tools in my att web stick and adjusted compression to minimum, then i updated java at java.com.

    cleared cache and history, etc etc...now i am seeing pics as they should be...very happy :+)

     

    • Proposed as answer by iownme Tuesday, January 25, 2011 11:48 PM
    Tuesday, January 25, 2011 11:47 PM
  • Finally the problem has been solved. I am Orange UK mobile broadband user and having lots of headache with image compression problem. After trying almost everything I found this address: http://accelerator.orange.co.uk JUst go there, turn the bloody accelerator off and enjoy high quality images as you deserve. You're welcome.
    • Proposed as answer by Craig A C Tuesday, April 05, 2011 4:41 PM
    Saturday, March 26, 2011 3:59 AM
  • At last! Thank You! I have had the exact same problem with Orange and this was the answer i've been waiting for!!
    Tuesday, April 05, 2011 4:40 PM
  • Thanks for the post sgeezus.  This has been bugging me for a few weeks.

    T-mobile users, i found this on my travels http://support.t-mobile.co.uk/help-and-support/index?page=support&cat=WEBNWALK_USB&tab=0&id=GP30

    Monday, June 13, 2011 8:30 PM