none
How to create a "VSTO"-setup package in Visual Studio 2019? RRS feed

  • Question

  • All

    I created a VSTO (Outlook Add-In) which works fine on the machine where I have Visual Studio 2019 installed.
    I installed the “Microsoft Visual Studio Installer Projects” and created a setup.exe (and setup.msi) according instructions. I did add the “Primary output” of my project. The setup-project automatically adds some dependencies. I can rebuild the setup-project and the EXE and MSI are created.

    When I use the "setup.exe" (or setup.msi) the setup works as expected and files are copied to the given folder in the setup-project. However, when I launch Outlook the “add in” is not visible in the toolbar whereas it does show up on my own computer. The add-in is neither visible under File - Options - Add-Ins (also not in “disabled items”). I tried to add the Add-in via the Browse button and double-clicked some of the files in the installation folder, but then I get errors it is not a valid plugin.

    So how do I create a setup for a VSTO?

    Thursday, January 9, 2020 8:23 AM

All replies

  • Hi ino_mart,

    Welcome to MSDN forum.

    Not sure if your VSTO could be installed or used in local machine, I think you could get more help from MSDN VSTO forum, so I will help to move this thread to VSTO forum for better help.

    Also, you could refer to these documents: Develop Office Add-ins with Visual Studio and Build your first Outlook add-in.

    Sorry for this inconvenience and hope this could help you.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 10, 2020 5:52 AM
  • Same issue.

    followed the documentation on microsoft.com only gets me to create the MSI and install, but seems like the add-in for outlook needs to be "registered" then it can be recognized by outlook?

    Monday, February 10, 2020 6:08 PM