none
OpenLayers webapplication stopped working in IE 11

    Question

  • A few years ago we developed an OpenLayers webapplication.
    Everything worked fine until a few weeks ago.
    The application stopped working in IE11, became very slow in Edge.
    No problems with other browsers.
    When I try to debug (by pressing F12) IE crashes.

    What I've tried so far:
    - Delete cookies and browser history - no results
    - Reset IE setting - no results
    - Run in 'compability mode' - no results

    The application loads a big WFS-file.
    During 5 to 10 minutes IE "does not respond".
    After that period IE is back and alive, and the application works normally.
    This behaviour started a few weeks ago.

    I think it has to do with a recent IE/Edge update.

    We use:
    Internet Explorer
    Versie 11.674.15063.0
    Update version 11.0.47 (KB4040685)

    Installed KB's since september:
    KB4051613
    KB4049179
    KB4041676
    KB4040724
    KB4038788
    KB4038806

    Any suggestions?
    Monday, November 13, 2017 7:58 AM

All replies

  • Hi,

    If possible include links to problem websites with your questions so that we can visit them to make some tests(debug the page ourselves)

    Also include your settings for

    1. The IE security zone that your company has mapped the domain to. (File>Properties menu in IE).

    2. The Emulation mode in use (if any) and how it was established... eg. Enterprise Mode - Enterprise Site Mode Lists or IE7 - user compatibility view.

    If not already deployed, you should be using Enterprise Site Mode lists to manage the Emulation Mode used by your company's legacy intranet sites.

    Crashing MSIE browsers is usually associated with mis-behaving or out of date browser extensions (toolbars/bhos).

    1. the first step in troubleshooting web browser issues is to test in no-Addons mode. (Start>Run>iexplore.exe -extoff)

    2. Pro and Enterprise editions of windows include event viewer.... which may list the error signature that the browser raises when it crashes. winkey+s>event viewer

    Include the output from event viewer with your questions.

    To troubleshoot website rendering and scripting issues in IE11, first go

    Tools>Internet Options>check "Always record developer console messages". Save changes.

    To debug page loading errors (blocked content, security warnings, xss errors).

    1. Open IE at about:blank, then press f12 to display the dev tool.... PIN it to the blank browser window.

    2. Select the Networking tab and turn on network recording (press the Play button), then

    3. Select the Debug tab and select "Break on ALL exceptions" from the drop-down (looks like a STOP sign)....

    THEN (!important) without closing the dev tool (the dev tool MUST be visible while you are debugging and you must change the default "Break" on exceptions setting from "Never break on exceptions".)

    Navigate to the website you are testing/debugging by typing the address in the address bar.... IE will now break on exceptions and list markup and security and xss errors and will record the response headers of imported content...

    You will find documentation for using the dev tool at docs.microsoft.com.

    If you have not already done so, repost your question to stackoverflow... include the information that is required as above.


    Rob^_^


    Monday, November 13, 2017 8:34 PM
  • Hi Rob,

    Thanks for your extensive reply.
    The application is used by a few hundred users, a lot of them use IE.
    The answers below apply to my own computer.

    Link to website:
    I have made a Q&D testaccount and link: http://62.212.154.154/geluidregister/inloggen?u=test123&w=test123
    As soon as you load the page IE will hang for a few minutes.
    If you press F12 during that period IE will crash.
    After those "few minutes" you can use IE normally.
    This behaviour started a few weeks ago.
    Edge is also 'suffering' but doesn't crash.
    Other browsers have no problems.

    Settings:
    1. IE security zone: Protected Mode enabled (translated from Dutch)
    2. As far as I know there is no Emulation mode (at least I didn't change any settings in that area)

    Tests/checks:
    1. Test in no-Addons mode: no results
    2. Event error after IE crashes (only when I press F12):
        - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
        - <System>
          <Provider Name="Application Error" /> 
          <EventID Qualifiers="0">1000</EventID> 
          <Level>2</Level> 
          <Task>100</Task> 
          <Keywords>0x80000000000000</Keywords> 
          <TimeCreated SystemTime="2017-11-14T08:20:56.300741300Z" /> 
          <EventRecordID>20949</EventRecordID> 
          <Channel>Application</Channel> 
          <Computer>COMPUTER57</Computer> 
          <Security /> 
          </System>
        - <EventData>
          <Data>IEXPLORE.EXE</Data> 
          <Data>11.0.15063.608</Data> 
          <Data>324c3bf4</Data> 
          <Data>MSHTML.dll</Data> 
          <Data>11.0.15063.674</Data> 
          <Data>5d4c0b6f</Data> 
          <Data>c00000fd</Data> 
          <Data>004e9e0f</Data> 
          <Data>37b4</Data> 
          <Data>01d35d210863f55d</Data> 
          <Data>C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE</Data> 
          <Data>C:\WINDOWS\SYSTEM32\MSHTML.dll</Data> 
          <Data>61f7af7b-f2fc-43e6-98d5-7ee291007ec8</Data> 
          <Data /> 
          <Data /> 
          </EventData>
          </Event>

    Debugging:
    I followed your instructions ("Always record developer console messages", "Network recording ON", "Break on ALL exceptions" ), but still IE crashes with the dev tool open

    I will repost this question to stackoverflow.

    Regards,
    Koen
    Tuesday, November 14, 2017 8:59 AM
  • Hi,

    It does not crash when I have turned off ActiveX filtering.... I don't know the current version of the google maps api... all google code uses some form of Flash support feature testing..the page and sub-frames do not have any object or embeds. MSHTML.dll errors in IE are usually associated with Flash controls or Flash feature testing. Advanced tab of INternet Options>check "Use GPU rendering instead of software rendering" is already checked on my machine.

    All IE updates have only been security updates or minor esthetic changes for the past two years. Notably blocking of out-of-date ActiveX controls (eg. Macromedia flash, past versions of Adobe Flash).

    My best guess, is that you need to check with google for the latest version of their map api's. To future proof you applications you should use a version agnostic CDN.

    I have to go now, but I will investigate further... thanks for the link... others will be able to investigate further.

    Regards.


    Rob^_^

    Ok.... here's my console output when debugging the page with ActiveX filtering turned off.

    Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    but there are also unhandled errors for require.js and jspdf.js....

    Adobe issued updates for their PDF reader application in August... PDF document readers are implemented as ActiveX controls in MSIE browsers.

    Name:                   Adobe PDF Reader
    Publisher:              Adobe Systems, Incorporated
    Type:                   ActiveX Control
    Architecture:           32-bit and 64-bit
    Version:                17.12.20093.238000
    File date:              ‎Thursday, ‎24 ‎August ‎2017, ‏‎10:10 PM
    Date last accessed:     ‎Friday, ‎3 ‎November ‎2017, ‏‎11:41 AM
    Class ID:               {CA8A9780-280D-11CF-A24D-444553540000}
    Use count:              208
    Block count:            476
    File:                   AcroPDF64.dll
    Folder:                 C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX

    Here are links to g.maps api documentation.

    https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&uact=8&ved=0ahUKEwim44_Yzb_XAhUEv5QKHa6iAiAQFggzMAE&url=https%3A%2F%2Fdevelopers.google.com%2Fmaps%2Fdocumentation%2Fjavascript%2Freleases&usg=AOvVaw2YZ36k_zR8on7mKQ8vXyEF

    https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&cad=rja&uact=8&ved=0ahUKEwim44_Yzb_XAhUEv5QKHa6iAiAQFgg-MAI&url=https%3A%2F%2Fdevelopers.google.com%2Fmaps%2Fdocumentation%2Fjavascript%2Fv2tov3&usg=AOvVaw0Z3ckU3CRwAQFnvnxFcTC3

    it certainly points to a third-party api or ActiveX issue. If you search your source code from the debug console you will see the new ActiveXControl is called from jquery.js and openlayers.js....

    Regards.

    • Edited by IECustomizer Wednesday, November 15, 2017 3:23 AM
    Tuesday, November 14, 2017 11:01 PM