IE 10 Back Button doesn't work correctly


  • IE 10 RTM

    This is for when I am programming my web pages. When I open a page from my website locally, while I am programming, if I click the back button (top left) it doesn't work unless it is clicked 3 times. This is normal. Sometimes 2 times works, sometimes one. But normally it takes 3 times to take me back to the previous page. I use lots of javascript and CSS. It is irritating. Chrome or Firefox doesn't do this only IE 10. Presently I am using IE10 but it happened with IE 9 as well. What's an address I I can send this to Microsoft? I want them to fix their browser and get up to par with the other browsers. Plus I like using IE better than the others but it has plenty of idiosyncrasies. Oh, this is while programming. While on the Internet no problems with the back button.

    Fill in the username and passwords both of them, like Chrome and Firefox.

    Disqus discussions don't work correctly (FF and Chrome ore OK).

    Problems with Yahoo mail (Firefox works fine).

    More to come as I've started keeping a list. I want IE fixed. Thanks.

    Friday, September 28, 2012 12:41 PM


All replies

  • Hi annotate

    Thanks for your post in our forum.

    you could refer relevant solution in the link below:


    Friday, October 05, 2012 8:15 AM
  • Hi,

    We had a similar issue with our web application when opened in IE. In our case it was due to some iframes in the page. The iframes were in panels with style set to display none. The panels were targets of AJAX modal popup controls. For some reason, the URLs of the external pages referred in the iframes were getting added to the history on page load itself (The modal popup controls were not  triggered). 

    Just check if the previous page as per the browser is the same as the page you were expecting to show up.

    Right click on back button to verify this.

    Once we removed the iframes, the back button started working fine. 

    This issue was not reproducible in other browsers.

    Hope this help someone.


    Friday, November 22, 2013 9:29 AM
  • Hi,

    Internet Options>Advanced tab, check "Display notification about ever script error"

    test the page....

    IE's Tracking Protection or the google toolbar's analytics opt-out BHO, will stop ga creating its iframes collection.



    Saturday, November 23, 2013 12:11 AM