Forum MSBuildDiscuss the Microsoft build engine aka MSBuild. Topics including: usage of MSBuild, build customization, and MSBuild extensibility via tasks, loggers and hosting.© 2009 Microsoft Corporation. Semua hak dilindungi undang-undang.Tue, 27 May 2008 18:54:29 Zd7ac22f9-5d1e-4498-95f5-477daff4fecdhttps://social.msdn.microsoft.com/Forums/id-ID/32a2c4d0-4daa-4e1d-a7d0-ef40c399c216/building-solution-from-command-line?forum=msbuildhttps://social.msdn.microsoft.com/Forums/id-ID/32a2c4d0-4daa-4e1d-a7d0-ef40c399c216/building-solution-from-command-line?forum=msbuildSumit Kadamhttps://social.msdn.microsoft.com:443/profile/sumit%20kadam/?type=forumBuilding Solution From Command Line<p>I have VS2013 Professional edition. I have a setup project(.vdproj) which generates msi and exe file on building the project.</p> <p>When I try to build the project from command line with following command -</p> <p>devenv.exe SolutionName /rebuild Release /project ProjName /projectconfig Release /Out &quot;D:\log.txt&quot;</p> <p><span style="font-size:0.75em; line-height:1.5">It throws following error -</span><br/> </p> <p>ERROR: An error occurred while validating. &nbsp;HRESULT = '8000000A'</p> <p></p> <p>Please suggest.</p>Thu, 11 Feb 2016 07:47:18 Z2016-02-11T07:47:18Zhttps://social.msdn.microsoft.com/Forums/id-ID/5bad4966-d51f-4e62-aade-4d19f8c5b13b/not-able-to-build-csc-task-with-461-net-framework-using-msbuildexe?forum=msbuildhttps://social.msdn.microsoft.com/Forums/id-ID/5bad4966-d51f-4e62-aade-4d19f8c5b13b/not-able-to-build-csc-task-with-461-net-framework-using-msbuildexe?forum=msbuildjagdhamandehttps://social.msdn.microsoft.com:443/profile/jagdhamande/?type=forumNot able to build csc task with 4.6.1 .net framework using msbuild.exe<p>I have created my msbuild xml to build the project . I have used CSC task as it requires different files to be complied and includes previously compiled out put dll. I am trying to build it with latest .net framework 4.6.1 using msbuild.exe . But each time I build and check framework version using de-compiler , it shows 4.0 . Can anybody tell a way to forcefully compile with 4.6.1? p.s: TargetFrameworkVersion also not working. Ant Task used to call msbuild ;</p> <pre class="x_x_default x_x_prettyprint x_x_prettyprinted" style=""><p><code><span class="tag">&lt;Project</span><span class="pln"> </span><span class="atn">xmlns</span><span class="pun">=</span><span class="atv">&quot;http://schemas.microsoft.com/developer/msbuild/2003&quot;</span><span class="pln"> </span><span class="atn">DefaultTargets</span><span class="pun">=</span><span class="atv">&quot;Build&quot;</span><span class="pln"> </span><span class="atn">ToolsVersion</span><span class="pun">=</span><span class="atv">&quot;14.0&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;target</span><span class="pln"> </span><span class="atn">name</span><span class="pun">=</span><span class="atv">&quot;ms-build&quot;</span><span class="pln"> </span><span class="atn">depends</span><span class="pun">=</span><span class="atv">&quot;version&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;echo</span><span class="pln"> </span><span class="atn">message</span><span class="pun">=</span><span class="atv">&quot;Building Proj&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;exec</span><span class="pln"> </span><span class="atn">executable</span><span class="pun">=</span><span class="atv">&quot;C:\Windows\Microsoft.NET\Framework64\v4.0.30319 \MSBuild.exe&quot;</span><span class="pln"> </span><span class="atn">failifexecutionfails</span><span class="pun">=</span><span class="atv">&quot;false&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;arg</span><span class="pln"> </span><span class="atn">line</span><span class="pun">=</span><span class="atv">&quot;${src}/Proj/Proj.build /p:Configuration=Release /p:debug=None /p:TargetFrameworkVersion=v4.6.1 /p:VisualStudioVersion=14.0&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;/exec&gt;</span><span class="pln"> </span><span class="tag">&lt;echo</span><span class="pln"> </span><span class="atn">message</span><span class="pun">=</span><span class="atv">&quot;Completed building Projand DLL&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;/target&gt;</span></code></p><p></p><p><code><span class="tag"></span></code></p></pre> <pre class="x_x_default x_x_prettyprint x_x_prettyprinted" style=""><code><span class="tag">&lt;Project</span><span class="pln"> </span><span class="atn">xmlns</span><span class="pun">=</span><span class="atv">&quot;http://schemas.microsoft.com/developer/msbuild/2003&quot;</span><span class="pln"> </span><span class="atn">DefaultTargets</span><span class="pun">=</span><span class="atv">&quot;Build&quot;</span><span class="pln"> </span><span class="atn">ToolsVersion</span><span class="pun">=</span><span class="atv">&quot;14.0&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;PropertyGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;TargetFrameworkVersion&gt;</span><span class="pln">v4.6.1</span><span class="tag">&lt;/TargetFrameworkVersion&gt;</span><span class="pln"> </span><span class="tag">&lt;output&gt;</span><span class="pln">../../build/out</span><span class="tag">&lt;/output&gt;</span><span class="pln"> </span><span class="tag">&lt;/PropertyGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;Target</span><span class="pln"> </span><span class="atn">Name</span><span class="pun">=</span><span class="atv">&quot;Build&quot;</span><span class="pln"> </span><span class="atn">Label</span><span class="pun">=</span><span class="atv">&quot;Builds Service exe&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;ItemGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;UtilsSource</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;Utils\tools\*.cs&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;UtilsSource</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;Utils\xml\*.cs&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;UtilsSource</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;Utils\objects\*.cs&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;/ItemGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;CSC</span><span class="pln"> </span><span class="atn">Sources</span><span class="pun">=</span><span class="atv">&quot;@(UtilsSource)&quot;</span><span class="pln"> </span><span class="atn">TargetType</span><span class="pun">=</span><span class="atv">&quot;library&quot;</span><span class="pln"> </span><span class="atn">OutputAssembly</span><span class="pun">=</span><span class="atv">&quot;$(output)/Utils.dll&quot;</span><span class="pln"> </span><span class="atn">DebugType</span><span class="pun">=</span><span class="atv">&quot;@(debug)&quot;</span><span class="pln"> </span><span class="atn">Optimize</span><span class="pun">=</span><span class="atv">&quot;false&quot;</span><span class="pln"> </span><span class="atn">NoConfig</span><span class="pun">=</span><span class="atv">&quot;@(noconfig)&quot;</span><span class="pln"> </span><span class="atn">GenerateFullPaths</span><span class="pun">=</span><span class="atv">&quot;true&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;/CSC&gt;</span><span class="pln"> </span><span class="tag">&lt;ItemGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjSource</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;Proj2\*.cs&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjSource</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;Proj2\Test.cs&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjRef</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;$(output)/Utils.dll&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjRef</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;$(output)/Test.dll&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjRef</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;lib\Microsoft.*.dll&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjRef</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;lib\Microsoft.Office.Server.dll&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;ProjRef</span><span class="pln"> </span><span class="atn">Include</span><span class="pun">=</span><span class="atv">&quot;lib\Microsoft.Office.Server.UserProfiles.dll&quot;</span><span class="pln"> </span><span class="tag">/&gt;</span><span class="pln"> </span><span class="tag">&lt;/ItemGroup&gt;</span><span class="pln"> </span><span class="tag">&lt;CSC</span><span class="pln"> </span><span class="atn">TargetType</span><span class="pun">=</span><span class="atv">&quot;library&quot;</span><span class="pln"> </span><span class="atn">OutputAssembly</span><span class="pun">=</span><span class="atv">&quot;$(output)/Proj.dll&quot;</span><span class="pln"> </span><span class="atn">DebugType</span><span class="pun">=</span><span class="atv">&quot;@(debug)&quot;</span><span class="pln"> </span><span class="atn">Optimize</span><span class="pun">=</span><span class="atv">&quot;false&quot;</span><span class="pln"> </span><span class="atn">NoConfig</span><span class="pun">=</span><span class="atv">&quot;@(noconfig)&quot;</span><span class="pln"> </span><span class="atn">References</span><span class="pun">=</span><span class="atv">&quot;@(ProjRef)&quot;</span><span class="pln"> </span><span class="atn">Sources</span><span class="pun">=</span><span class="atv">&quot;@(ProjSource)&quot;</span><span class="tag">&gt;</span><span class="pln"> </span><span class="tag">&lt;/CSC&gt;</span><span class="pln"> </span><span class="tag">&lt;/Target&gt;</span></code></pre> <p></p>Tue, 09 Feb 2016 10:00:19 Z2016-02-09T10:00:19Zhttps://social.msdn.microsoft.com/Forums/id-ID/8a5e7723-816b-4ea9-b233-152b56afa188/no-silverlight-project-specified-for-silverlight-output-error-at-tfs-build?forum=msbuildhttps://social.msdn.microsoft.com/Forums/id-ID/8a5e7723-816b-4ea9-b233-152b56afa188/no-silverlight-project-specified-for-silverlight-output-error-at-tfs-build?forum=msbuildMrki01https://social.msdn.microsoft.com:443/profile/mrki01/?type=forum"No Silverlight project specified for Silverlight output" error at TFS build<p>Hi,</p> <p>I am experiencing a weird Build error only when building manually with MSBuild, but not when building with VS. Already posted this problem in the <a href="https://social.msdn.microsoft.com/Forums/en-US/27404159-5433-42c0-b1cb-5a67d912b9a7/no-silverlight-project-specified-for-silverlight-output-error-at-tfs-build?forum=tfsbuild"> TFS Build Forum</a> and I was redirected by the TFS guys to this forum in order to get better response. I'll copy over the problem description from previous thread: </p> <p>I am experiencing a weird error, but first some description of the solution I have. It is a solution containing WPF and Silverlight projects. The WPF projects are class libraries which are played by a WPF application. Silverlight projects are Silverlight apps referenced by a Web application which is hosting them.<br/> <br/> I get the error (from the title) when starting build over TFS (which starts MSBuild), yet this error does not pop up if building this solution locally with Visual Studio. I should also mention that previously these Silverlight apps were hosted by another Web application (Web forms) and that this error started happening after deciding to host them another Web application (MVC). Locally, everything builds and runs smoothly, but TFS throws build errors..<br/> <br/> Here is a snippet from the MSBuild build Kesalahan Server Internal
Kesalahan Server Internal

Maaf, kami tidak dapat melayani permintaan Anda. Coba lagi nanti.

Untuk berita utama aktual dan mengetahui info terbaru, kunjungi halaman muka MSDN.

Lihat beragam Pusat Pengembang MSDN untuk menemukan informasi produk terbaru, sumber info teknis, dan penawaran komunitas. Kunjungi Perpustakaan MSDN untuk memperoleh artikel teknis terbaru, dokumentasi referensi, download, dan banyak lagi.

Telusuri ke Forum MSDN untuk mendapatkan jawaban atas pertanyaan teknis atau gunakan pilihan pencarian di bawah ini untuk mengetahui sumber info terkait.