Contextual & Refined Searches show no results, but ALL SITES search does


  • Hello

    I am having issues with getting the contextual & refined searches to work.  When I search ALL SITES, I get results; however, when I try to search THIS SITE or THIS LIST, I get no results.

    I am currently using Search Center for my ALL SITES search and was still using the OSSsearchResults for the contextual.  I have tried to switch to using my Search Center enterprise search contextual search and still get no results.

    I do have a AAM.  My URLs are http://NAME1 for the default and http://NAME2 for intranet.  Both names are NetBIOS names…neither are using FQDN

    In my crawl, the content source is setup to crawl http://NAME1.  Most people hit the site via http://NAME2.

    My issue seems to be limited to just this single web app.   I have 2 more content sources that seem to be working fine (a MySite WebApp and an external share drive).

    Also, when I do a search at ALL SITES and get my results spread across all my Content source; when I try to refine my search to just http://NAME1, it say no result…though I could see that there were result in that content before I clip on that refinement.  If I click on the other choices (either the MySite Content or Shared Drive) I see the results.

    I have completed a FULL crawl on the http://NAME1 and don’t get any errors.  I even reset the index and did another full crawl…with the same results.   Not seeing any real errors in the SharePoint log.

    It seems that my crawl is working because I can see all my results in my ALL SITES search.  It is just when I try to do a Contextual or Refined Search on this one content source.

    I’ve looked at other for threads, but most I have found basically just say make sure you are using your default url for content source…which I am.

    Any ideas on how to get refined and contextual searches to work on this environment?

    11 April 2012 16:27


  • Just an update.   I seemed to FIXED it.

    After unassociating the WebApp from the Search Service App and then re-associating it, I temporarily removing the INTRANET name http://NAME2 and reset the index/recrawled.  It seemed to work, but I needed the http://NAMES2.

    I re-added the AAM for http://NAME2 under CUSTOM--not the INTRANET zone.   I reset index/recrawled and all seems to be working.

    Thanks for the comments and suggestions.

    19 April 2012 16:42

Semua Balasan