none
Breakpoints Have Stopped Working RRS feed

  • Question

  • Good afternoon, all -

    I have VS2015 and, for some reason, breakpoints in Script Tasks have stopped working. I've tried to find the Project Property setting to turn off Run64BitRuntime, as suggested in many of the hits I got when researching what's happening, but it's nowhere to be found. I recall setting this on an earlier version, but have, until now, not needed to do so in this one.

    Breakpoints work fine on tasks in general, but not when they're with a script.

    Is there something else I need to do to get these things working?

    Thanx in advance for any assistance!

    Friday, December 6, 2019 9:54 PM

Answers

  • Hi Adam,

    There are some ideas to debug this problem like:

    1. Run the whole package instead of a single task.

    2. Tick the Optimize code option.

    3. Remove the dtsx from the project, recompile, clean and import the copy back in.

    refer to:

    Could not set BreakPoint in SSIS ScriptTask

    breakpoint is enabled but it does not hit

    It's so kind of you to mark helpful replies as answers in order to close this thread. By doing so, it will benefit all community members who are having this similar issue.  Your contribution is highly appreciated.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thanx for your reply, Lily.

    To address your solution points;

    1. Run the whole package instead of a single task.

    Yup, did that. Not so much as a solution, but just as a part of the debugging process.

    2. Tick the Optimize code option.

    Tried that from a suggestion I got elsewhere. No effect.

    3. Remove the dtsx from the project, recompile, clean and import the copy back in.

    I did this, too, a while back trying to see if I had a corrupt copy of the package. Also, the problem happens with more than one package.

    I examined the links you provided and they seem to focus on using an older version of C#. For our purposes, that's not really an option, unfortunately.

    Ah well. I've reconciled myself to the inevitable and that I'll just have to live with this until something new comes along. The actual problem that I was using breakpoints to address has been resolved, so, for the moment, it's a moot point.

    Thanx for your assistance, though, I really appreciate it!

    • Proposed as answer by Lily Lii Monday, January 6, 2020 9:29 AM
    • Marked as answer by Adam Quark Monday, January 6, 2020 2:44 PM
    Friday, January 3, 2020 4:13 PM

All replies

  • Have you also tried setting the project platform to x86 inside Script task? 

    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    Saturday, December 7, 2019 6:21 AM
  • I have VS2015 and, for some reason, breakpoints in Script Tasks have stopped working. I've tried to find the Project Property setting to turn off Run64BitRuntime, as suggested in many of the hits I got when researching what's happening, but it's nowhere to be found. I recall setting this on an earlier version, but have, until now, not needed to do so in this one.

    Hi Adam,

    The Run64BitRuntime property is still there where it was before. The usual mistake is to select a Solution properties instead of Project properties.

    Here is how to get to it:

    1. In the Solution Explorer, right mouse click on Project (its concrete name) and select Properties.
    2. Select Configuration Properties => Debugging on the left.
    3. Set Run64BitRuntime property setting to False.

    Please see below:


    Sunday, December 8, 2019 7:39 PM
  • Hi Adam,

    The SSIS package may ignore the breakpoints in a Script Task when debugging on a 64-bit machine.

    1.Go to the Solution Explorer
    2.Right click your SSIS project > Properties
    3.In Configuration Properties > Debugging > Debug Options > choose Run64BitRunTime to False.


    Best Regards,

    Lily

     

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, December 9, 2019 3:00 AM
  • I have VS2015 and, for some reason, breakpoints in Script Tasks have stopped working. I've tried to find the Project Property setting to turn off Run64BitRuntime, as suggested in many of the hits I got when researching what's happening, but it's nowhere to be found. I recall setting this on an earlier version, but have, until now, not needed to do so in this one.

    Hi Adam,

    The Run64BitRuntime property is still there where it was before. The usual mistake is to select a Solution properties instead of Project properties.

    Here is how to get to it:

    1. In the Solution Explorer, right mouse click on Project (its concrete name) and select Properties.
    2. Select Configuration Properties => Debugging on the left.
    3. Set Run64BitRuntime property setting to False.

    Please see below:


    Thanx, Yitzhak, but no dice.

    I had set this property back on VS2008R2, but when we upgraded, the problem in using Excel went away, so we never had to do the same in VS2015.

    Problem now is that my VS2015 properties screen doesn't show the Debugging tab;

    I'll do some more searching around to see if there's a flag somewhere that needs to be set to display it.

    Thanx!

    Tuesday, December 10, 2019 5:33 PM
  • Hi Adam,

    The SSIS package may ignore the breakpoints in a Script Task when debugging on a 64-bit machine.

    1.Go to the Solution Explorer
    2.Right click your SSIS project > Properties
    3.In Configuration Properties > Debugging > Debug Options > choose Run64BitRunTime to False.


    Best Regards,

    Lily

     

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thanx, Lily, but I don't have the Debugging tab on my Project Properties screen.
    Tuesday, December 10, 2019 5:35 PM
  • OK, finally found Run64BitRuntime setting.

    I found it when I clicked on the project properties in the Project menu tab. All the r-clicking in the world on the Solution Explorer didn't do a thing.

    But, anyway, I set that value to False, but breakpoints are still failing.

    *sigh*

    Tuesday, December 10, 2019 9:32 PM
  • Hi Adam,

    Please launch your VS2015 with 'Run As Administrator' option, and try to debug again.

    Tuesday, December 10, 2019 10:01 PM
  • Try

    Build->Clean

    Build->rebuild

    Run


    I'd rather live with false hope than with false despair.

    Wednesday, December 11, 2019 12:16 AM
  • Hi Adam,

    Did 'Run as administrator' or 'rebuild solution' help you? Please feel free to let us know.

    Debug a Script by Setting Breakpoints in a Script Task and Script Component

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, December 11, 2019 9:29 AM
  • Try

    Build->Clean

    Build->rebuild

    Run


    I'd rather live with false hope than with false despair.

    Yup, did that.
    Wednesday, December 11, 2019 5:18 PM
  • Hi Adam,

    Please launch your VS2015 with 'Run As Administrator' option, and try to debug again.

    Nope, still no debugging tab on the Project properties, unless I go through the menu bar.
    Wednesday, December 11, 2019 5:19 PM
  • Hi Adam,

    Have you solved your issue?

    Please don't forget to edit your Script Task with 'Edit Script' and save it again. This will help your script task code to be compiled as 32bit.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, December 12, 2019 7:31 AM
  • Hi Adam,

    Have you solved your issue?

    Please don't forget to edit your Script Task with 'Edit Script' and save it again. This will help your script task code to be compiled as 32bit.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Unfortunately, no. I can only get the Debugging window when I use the menu bar to get to the Project properties. R-clicking in the Solution Explorer just won't do it, whether I run as administrator or not.

    But, even so, when I do get to the Debugging window and I set the 64bit value to false, the thing still won't break.

    I really don't understand what's happening. Breakpoints in scripts used to work and not that long ago. Only thing I can think of is that we split off from our parent company, joined with another organization and started a new entity. Perhaps, in the process, something was changed by the IT guys to have this unintended consequence. Well, I hope unintended, anyway. At any rate, I can't think of anything else.

    Oh well, I'll keep plugging and update as I learn new things.

    Thanx for your help, Lily!

    Thursday, December 12, 2019 1:10 PM
  • Hi Adam,

    There are some ideas to debug this problem like:

    1. Run the whole package instead of a single task.

    2. Tick the Optimize code option.

    3. Remove the dtsx from the project, recompile, clean and import the copy back in.

    refer to:

    Could not set BreakPoint in SSIS ScriptTask

    breakpoint is enabled but it does not hit

    It's so kind of you to mark helpful replies as answers in order to close this thread. By doing so, it will benefit all community members who are having this similar issue.  Your contribution is highly appreciated.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, December 13, 2019 2:09 AM
  • Hi Adam,

    There are some ideas to debug this problem like:

    1. Run the whole package instead of a single task.

    2. Tick the Optimize code option.

    3. Remove the dtsx from the project, recompile, clean and import the copy back in.

    refer to:

    Could not set BreakPoint in SSIS ScriptTask

    breakpoint is enabled but it does not hit

    It's so kind of you to mark helpful replies as answers in order to close this thread. By doing so, it will benefit all community members who are having this similar issue.  Your contribution is highly appreciated.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thanx for your reply, Lily.

    To address your solution points;

    1. Run the whole package instead of a single task.

    Yup, did that. Not so much as a solution, but just as a part of the debugging process.

    2. Tick the Optimize code option.

    Tried that from a suggestion I got elsewhere. No effect.

    3. Remove the dtsx from the project, recompile, clean and import the copy back in.

    I did this, too, a while back trying to see if I had a corrupt copy of the package. Also, the problem happens with more than one package.

    I examined the links you provided and they seem to focus on using an older version of C#. For our purposes, that's not really an option, unfortunately.

    Ah well. I've reconciled myself to the inevitable and that I'll just have to live with this until something new comes along. The actual problem that I was using breakpoints to address has been resolved, so, for the moment, it's a moot point.

    Thanx for your assistance, though, I really appreciate it!

    • Proposed as answer by Lily Lii Monday, January 6, 2020 9:29 AM
    • Marked as answer by Adam Quark Monday, January 6, 2020 2:44 PM
    Friday, January 3, 2020 4:13 PM
  • Hi Adam,

    Thank you for your updating and patience, it's so kind of you to post here and give the trust to our forum.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, January 6, 2020 9:29 AM
  • Just a note, an FYI, if you will; this problem only happens in SSIS scripting. I have no problems with breakpoints in Excel macros.

    Dunno if that's any help, but just in case...

    Wednesday, January 8, 2020 8:54 PM