none
SSMS slow RRS feed

  • Question

  • Lately, when I start SSMS it takes up to 3 minutes to load.  Any ideas what might be cause?  We are running SQL 2016 Std with 64GB RAM and accessing from RDP.
    Tuesday, December 10, 2019 6:19 PM

Answers

  • SSMS is 32 bit and uses separate memory from what SQL Server is using, if you are opening it on the server. So maybe contention with SQL and the O/S?

    One thing I always do is to add /nosplash to the shortcut property just to bypass the screen that tells me I've opened the thing I intended to open


    22 years of database experience, most with SQL Server. Please 'Mark as answered' those posts that helped you.

    • Marked as answer by David Chase89 Wednesday, December 11, 2019 2:08 PM
    Tuesday, December 10, 2019 9:34 PM
  • Hi David Chase89,

    Please try to go into Internet Explorer: Options/Advance tab. Then scroll to the bottom of the list and uncheck "Check for publisher's certificate revocation". When Microsoft's SQL Server Management Studio (SSMS) starts it tries to connect the Certificate Revocation List (CRL) of Microsoft. The underlying .NET components of SSMS are trying to contact the Certificate Revocation List and SSMS is unable to do so. This slows down the overall loading procedure. Please read this similar thread. 

    Did you try to use the latest version of SSMS? You can get SSMS 18.4 from here.  SSMS can be installed side by side in one machine.

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by David Chase89 Wednesday, December 11, 2019 2:08 PM
    Wednesday, December 11, 2019 3:35 AM

All replies

  • What is the SSMS release number you are using? >= 18.0
    Tuesday, December 10, 2019 6:34 PM
  • 17.9.1
    Tuesday, December 10, 2019 6:38 PM
  • SSMS is 32 bit and uses separate memory from what SQL Server is using, if you are opening it on the server. So maybe contention with SQL and the O/S?

    One thing I always do is to add /nosplash to the shortcut property just to bypass the screen that tells me I've opened the thing I intended to open


    22 years of database experience, most with SQL Server. Please 'Mark as answered' those posts that helped you.

    • Marked as answer by David Chase89 Wednesday, December 11, 2019 2:08 PM
    Tuesday, December 10, 2019 9:34 PM
  • Used your /nosplash argument and seems faster. Will check again when heavier user access.
    Tuesday, December 10, 2019 10:36 PM
  • Used your /nosplash argument and seems faster. Will check again when heavier user access.
    At some point someone is going to say "Don't use SSMS on the server!"  Valid opinion, but we don't always have a choice. Is the server 64GB RAM? How much is allocated to SQL Server (max Memory Setting)?

    22 years of database experience, most with SQL Server. Please 'Mark as answered' those posts that helped you.

    Tuesday, December 10, 2019 10:39 PM
  • max memory setting is 2147483647
    Tuesday, December 10, 2019 11:30 PM
  • That is the installation default and  = 2Petabytes...which means teh SQL Engine is using as much as it needs, potentially starving the O/S and other applications.

    Best practice is to set a max.  What you set it to varies by who you ask, but leave at least 4GB for the O/S. Maybe 6 if its a failover cluster.

    Either way, setting a cap might help your SSMS situation (might also slow down performance, so...due diligence with information from the internet!)


    22 years of database experience, most with SQL Server. Please 'Mark as answered' those posts that helped you.

    Wednesday, December 11, 2019 12:34 AM
  • Hi David Chase89,

    Please try to go into Internet Explorer: Options/Advance tab. Then scroll to the bottom of the list and uncheck "Check for publisher's certificate revocation". When Microsoft's SQL Server Management Studio (SSMS) starts it tries to connect the Certificate Revocation List (CRL) of Microsoft. The underlying .NET components of SSMS are trying to contact the Certificate Revocation List and SSMS is unable to do so. This slows down the overall loading procedure. Please read this similar thread. 

    Did you try to use the latest version of SSMS? You can get SSMS 18.4 from here.  SSMS can be installed side by side in one machine.

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by David Chase89 Wednesday, December 11, 2019 2:08 PM
    Wednesday, December 11, 2019 3:35 AM