Stuck with instance based Model


  • Hi all,

    I have tried to play around with instance based model in SE. My implementation has a constructor, which is also inherited along with all other methods in the model. I just left it empty(as it was done when one chooses instances based model in SE). The problem is that none of my other actions were even explorered once. I get an infinite sequence of the action of the constructor, though some of the actions were valid as well and bounds were hit. I'm using typebinding. Donno what is going wrong.


    יום שלישי 28 פברואר 2012 15:41


  • Hi Vivek.Vishal,

    My guess is that maybe everything is ok, except that your model is infinite.
    Have you already tried to limit the number of instances you allow to create?
    You can do this with a scenario like this (2 instances, similar to SE example machine "SlicedThreadModelProgram"):

    new ComplexThread; new ComplexThread; ( (_;_)* |?| !new ComplexThread)

    You can see now if your other rule methods are active, because you should not hit bounds due to infinite instance creation any more.

    Hope this helps

    • הוצע כתשובה על-ידי Yiming Cao יום שני 05 מרץ 2012 09:07
    • סומן כתשובה על-ידי Vivek.Vishal יום שישי 30 מרץ 2012 07:42
    יום רביעי 29 פברואר 2012 09:24