none
la propriété « Membership.Provider » doit être une instance de « ExtendedMembershipProvider RRS feed

  • Question

  • Bonjour ,

    Je desire installer l'autentification asp.net sur Azure. Pour cela j'ai donc installé le package Nugget suivant

    par la console du gestionnaire de package :

    Install-Package Microsoft.AspNet.Providers

    Celui ci m'a modifie le fichier web config .

    J'ai modifie la connection : DefaultConnection

    add name="DefaultConnection"connectionString="Data Source=|DataDirectory|\aspnet.sdf"providerName="System.Data.SqlServerCe.4.0"/>

    J'ai Regeneré la solution et pu créer et gerer des Utilisateurs avec l'utilitaire Outil Administration de site Web. La base aspnet .sdf est bien crée et mise a jour.

    Mais quand je lance le debogage de mon projet j'ai l'erreur suivante et que je veux connecter un utilisateur enregister :

    Pour appeler cette méthode, la propriété « Membership.Provider » doit être une instance de « ExtendedMembershipProvider » lorque j'arrive sur un Websecurity. 

    Je suis en MVC4 avec Update 2012.

    J'ai trouvé des choses sur internet , mais sans comprendre.

    Merci pour votre aide

    dimanche 28 avril 2013 13:03

Réponses

  •  <!--<membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <roleManager enabled="true" defaultProvider="DefaultRoleProvider">
          <providers>
            <add connectionStringName="DefaultConnection" applicationName="/"
              name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </providers>
        </roleManager>-->

    Merci pour le lien , celui ci ne repond pas a mon probleme . j'ai trouve une reponse :http://forums.asp.net/t/1836411.aspx/1?MVC+4+Web+config+membership+problem

    Le fait d'installer le package : Microsoft.AspNet.Providers   genere dans le web.Config une section menbership et rolemanager : il suffit de les commenter ( ou supprimer ). Voir ci dessus

    Mon probleme est resolu ( en local en esperant de meme sur azure )

    Cordialement 

    • Marqué comme réponse Aurel Bera lundi 29 avril 2013 12:45
    lundi 29 avril 2013 12:07

Toutes les réponses