none
Les UserControls (ascx) RRS feed

  • Question

  • Bonjour,

    Nous sommes passé à Visual Studio 2013 la semaine dernière. Suite à quelques problèmes pour choisir le serveur de développement, j'ai donc décidé de créer un nouveau projet sur la base de 2013 puis j'y ai ajouté les sous-projets et autres pages asp. Seul hic, les contrôles ascx ne sont, semble t-il, pas reconnus sur les pages.

    <%@ Register Src="~/CONTROLS/ucRechercheSecteur.ascx" TagPrefix="uc1" TagName="ucRechercheSecteur" %>


        <uc1:ucRechercheSecteur ID="RechercheSecteur" runat="server" AffichageAnnees="False"
            AffichageDonneesPlanning="False" AffichageOuvrages="True" AffichageSecteurs="True"
            AffichageTypesBoues="True" TousOuvrages="False" TousSecteurs="True" AffichageCampagnes="False" />

    Le message indique que l'élément ucRechercheSecteur n'est pas un élément connu... Quelqu'un saurait-il me dire quelle est la solution ? Pour information, j'ai même reconstruit les contrôles au cas où !

    Merci d'avance ;)


    lundi 18 août 2014 09:01

Toutes les réponses

  • J'ai trouvé une possible raison qui fait que les User Controls ne sont pas reconnus.. J'ai fait un projet d'application Web ASP et non Site Web ASP. Le problème avec les Sites Web ASP c'est que je ne peut pas sélectionner mon IIS Local car je ne veut pas utiliser IIS Express. Quelqu'un sais comment faire dans ce cas ? J'ai tenté une désinstallation de IIS Express mais lorsque je veux charger le projet il refuse car il trouve pas IIS Express -_-"
    lundi 18 août 2014 09:55