none
[ MOSS 2007 ] [ FR ] Problème mapping d’un champ custom publishing image dans les metadata de la recherche RRS feed

  • Question

  • Bonjour,


    Je voudrais savoir comment mapper un champ de type publishing image associé à une page de moss dans les metadata de la recherche afin de pouvoir l’afficher dans le résultat de la recherche via une FullTextSqlQuery.

    Je suis arrivé à mapper des champs de type Publishing HTML ou Look up, mais pas des champs de type publishing image.

     

    Merci pour vos réponses.

    jeudi 23 octobre 2008 08:33

Toutes les réponses

  • On peut bien rechercher dans les différentes méta-données d'une image (titre, description, date, auteur...), mais pas dans son contenu, en tout cas avec MOSS dans son état initial.

    Par contre, vous pouvez disposer de "IFilter" spécifique à un format donné qui sera à même de faire de la reconnaissance dans le contenu.

    Par exemple, pour indexer le contenu des fichiers PDF, il vous faut un "IFilter de PDF". Pour indexer le contenu des fichier ".tif" il vous faut un "IFilter de Tif". (pour JPEG)

    Je vous invite donc à orienter vos recherche dans cette direction.
    Mais les fournisseurs que je vous indique ne sont pas les seuls, d'autres existent, il suffit de faire une recherche sur le net pour cela.

    Merci de m'indiquer si ma réponse répond à votre attente...

    jeudi 23 octobre 2008 14:57
  • Merci pour votre réponse, mais je pense que cela ne correspond pas a mon interrogation.

     

    En effet dans mon cas, le souhaiterais récupérer l’url d’une image stockée dans un champ custom (Publishing Image) de mes pages MOSS, via une requête FullTextSqlQuery, afin d’afficher cette image dans le résultat de ma web part de recherche.

    jeudi 23 octobre 2008 15:14
  • Je vous invite à lire cet article : How to: Use the MOSS Enterprise Search FullTextSqlQuery Class

    Dites-moi si cela vous aura servi.
    mardi 28 octobre 2008 09:22
  • Merci, mais malheureusement je connaissais déjà ce principe, je sais même rajouter des colonnes dans la requête.

    Par contre quand j’ajoute a ma requête une colonne basé sur un PublishingImage, cela ne me remonte vide alors que l’item a bien une image dans ce champs.

     

    Donc ma question est pourquoi cela me remonte vide et que faut il faire pour avoir l’url de l’image du champ.

     

    jeudi 30 octobre 2008 11:19