none
Extraire valeur unique sur plusieurs feuille d'un meme classeur

    Question


  • Bonjour à tous

    on m'a dit de poster là ma question du coup la voilà .Par conbtre pas un grand spécialiste du vba

    je vais essayer d'etre le plus claire possible  , j'ai un classeur excel avec 7 feuilles correspondant à chaque jour de la semaine . Donc on a la feuille LUNDI,MARDI,MERCREDI,JEUDI,VENDREDI,SAMEDI,DIMANCHE

    Dans la feuille de lundi nous avons un ptit tableau à remplir du type

    BOISSON COCA THE vodka coktail  rhum jus d'orange  cafe
    ACHETEUR 3 2 5 6 7 1 2

    le mardi  nous avons de nouveau le meme type de tableau

    BOISSON ORANGINA COCA RHUM CAFE CACOLAC
    ACHETEUR

    Du coup  sur une dernière feuille je fais un bilan du type :

    NOMBRE d'acheteurs   X
    NOMBRE DE  type de BOISSON X

    sachant que je ne veux pas qu'il me compte 2 fois le coca  mais seulement 1 fois ;Pour le moment ma formule est du type :

    *=NB.SI(LUNDI!C2:S2;"**")+NB.SI!(MARDI!C2:S2;"**")+ ETC pour le reste des jours

    Donc du coup j'ai le nombre global sans pour autant me compter seulement une fois un terme qui serait mis dans ces lignes " BOISSON "

    voilà  je ne sais pas si c'est clair, pour avoir chercher un peu ça parlait de formule matriciel du type {=somme(1/NB.SI(.....etc) mais là  ça m'a perdu

    enfin voilà si quelqu'un avez un commencement d'idée

    je vous remercie par avance

    jeudi 21 juin 2018 07:39

Toutes les réponses

  • Bonjour,

    Est-ce que tu peux mettre ton classeur, sans données confidentielles, sur OneDrive, DropBox ou sur un autre site de partage et poster le lien correspondant ?

    Cordialement.

    Daniel

    lundi 2 juillet 2018 13:57