none
Paramétrer la Navigation Site principal et sous site RRS feed

  • Discussion générale

  • Bonjour,

    dans le fichier onet.xml de mon site principal j'ai : 

     	    <Property Key="InheritGlobalNavigation" Value="false" />
                <Property Key="InheritCurrentNavigation" Value="false" />
                <Property Key="ShowSiblings" Value="true" />
                <Property Key="IncludeSubSites" Value="false" />
                <Property Key="CurrentIncludePage" Value="true" />
                <Property Key="GlobalIncludeSubSites" Value="false" />
                <Property Key="GlobalIncludePages" Value="false" />

    dans le fichier onet.xml du sous site j'ai : 

    <Property Key="InheritGlobalNavigation" Value="true" />

    Lorsque je déploies, mon sous-site a toujours la navigation avec les pages qui y sont incluent.
    Sachant que j'aimerai qu'il y ait la même navigation que mon site principal dans le sous site.

    Exemple :
    Sous-site
    - Page 1
    - Page N

    Navigation du sous site :
    Page 1 ... Page N

    Qu'est ce qui n'est pas correct dans ma configuration XML au niveau des properties ?


    En vous remerciant d'avance.


    jeudi 23 octobre 2014 13:58

Toutes les réponses

  • Bonsoir,

    Pour confirmer , tu parles du site racine quand tu dis site "principal" ?

    Tu peux nous faire un copier/coller ton fichier onet.xml complet s'il te plaît?

    Si tu ne veux pas la "navigation des pages" sur ton sous-site , pourquoi ne pas mettre :

    <Property Key="CurrentIncludePage" Value="false" />

    Je voudrais bien comprendre pour pas te raconter de choses de travers alors si tu pouvais bien préciser dans ta description (avec ces termes) lorsque tu parles de pages/navigation/élements si tu fais référence à ton site courant/racine.

    N'hésite pas

    Merci


    Mutandis mutatis

    vendredi 31 octobre 2014 18:47
  • Bonjour Mahori,

    Alors j'ai un site racine et un sous-site.
    C'est dans l'onet.xml du sous-site que j'ai un problème.
    Voici l'onet.xml avec les élèments essentiels je pense :

    <?xml version="1.0" encoding="utf-8"?>
    <Project Title="EspaceRH" Revision="2" ListDir="" xmlns:ows="Microsoft SharePoint" xmlns="http://schemas.microsoft.com/sharepoint/">
      <NavBars>
        <NavBar Name="SharePoint Top Navbar" ID="1002"/>
      </NavBars>
      <Configurations>
        <Configuration ID="0" Name="EspaceRH" >
          <SiteFeatures>
            <!-- Workflow Expiration -->
            <Feature ID="C85E5759-F323-4EFB-B548-443D2216EFB5" />
    
            <!-- DLC Workflows -->
            <Feature ID="0AF5989A-3AEA-4519-8AB0-85D91ABE39FF" />
            <!-- Document Set -->
            <Feature ID="3bae86a2-776d-499d-9db8-fa4cdc7884f8" />
    <Feature ID="A44D2AA3-AFFC-4d58-8DB4-F4A3AF053188" /> <Feature ID="F6924D36-2FA8-4f0b-B16D-06B7250180FA" /> <Feature ID="B21B090C-C796-4b0f-AC0F-7EF1659C20AE"/> <Feature ID="00BFEA71-1C5E-4A24-B310-BA51C3EB7A57" /> <Feature ID="7AC8CC56-D28E-41f5-AD04-D95109EB987A" > <Properties xmlns="http://schemas.microsoft.com/sharepoint/"> <Property Key="SearchCenterUrl" Value="~SiteCollection/searchcenter" /> <Property Key="DocLib" Value="$Resources:osrvcore,List_Pages_UrlName;" /> </Properties> </Feature> <Feature ID="B50E3104-6812-424F-A011-CC90E6327318" /> <Feature ID="{f3697ca5-bd09-4a0a-8215-3b0197f62ac7}"></Feature> </SiteFeatures> <WebFeatures> <!--Publishing Feature--> <Feature ID="{22a9ef51-737b-4ff2-9346-694633fe4416}"> <Properties> <Property Key="ChromeMasterUrl" Value="~SiteCollection/_catalogs/masterpage/Intranet_2/index.master" /> <Property Key="DefaultPageLayout" Value="~SiteCollection/_catalogs/masterpage/IntranetHomePageLayout.aspx" /> <Property Key="WelcomePageUrl" Value="$Resources:osrvcore,List_Pages_UrlName;/Accueil.aspx" /> <Property Key="PagesListUrl" Value="" /> <Property Key="AvailableWebTemplates" Value="*-CMSPUBLISHING#0;*-BLANKINTERNET#2;*-ENTERWIKI#0;*-SRCHCEN#0" /> <Property Key="SimplePublishing" Value="true" /> </Properties> </Feature> <!--NavigationProperties Feature--> <Feature ID="541f5f57-c847-4e16-b59a-b31e90e6f9ea"> <Properties> <Property Key="InheritGlobalNavigation" Value="True"/> <Property Key="InheritCurrentNavigation" Value="True"/> <Property Key="ShowSiblings" Value="False" /> <Property Key="GlobalIncludePages" Value="False" /> <Property Key="GlobalIncludeSubSites" Value="True"/> <Property Key="CurrentIncludePages" Value="True"/> <Property Key="CurrentIncludeSubSites" Value="False"/> </Properties> </Feature> <Feature ID="94C94CA6-B32F-4da9-A9E3-1F3D343D7ECB"> <!-- Office SharePoint Server Publishing --> </Feature> <!--RH Documents Feature--> <Feature ID="{4af9da94-1677-4ba1-ac85-2494f526ff01}"/> <!--RH Pages Feature--> <Feature ID="{23598f60-0e46-473c-80d3-c4f0689e2f43}" /> </WebFeatures> </Configuration> </Configurations> </Project>
    Ce que je cherches à faire est de mettre la même navigation que sur la page d'accueil du site racine.
    J'ai mis également les pages dans l'exemple qui va suivre pour que vous compreniez l'affichage que j'ai actuellement.

    1/ Voilà l'arborescence, avec la description de ce que je veux faire :
    Site racine
    -- Page D'accueil --> Navigation de la page D'accueil
    -- Page 1 à N du sous-site
    + Sous-site
    --- Page d'accueil du sous-site --> Navigation identique à celle de la page d'accueil.
    --- Page 1 à N du sous-site

    2/ Voilà l'arborescence, avec la description de ce que j'ai actuellement :

    Site racine
    -- Page D'accueil --> Navigation de la page D'accueil
    -- Page 1 à N du sous-site
    + Sous-site
    --- Page d'accueil du sous-site --> Navigation avec les pages du sous-site
    --- Page 1 à N du sous-site


    En espérant, que j'ai été plus clair pour que vous compreniez le problème.
    Et en vous remerciant d'avance pour votre intérêt à ce topic.

    vendredi 31 octobre 2014 19:10