none
Indexation et Recherche de documents SharePoint RRS feed

  • Question

  • bonjour tout le monde,

    bon voilà, je suis entrain de faire un site intranet avec WSS 3.0 et MOSS 2007, dans l'une des rubriques du site je fait une bibliothèque d'images. j'ai ajouté des colonnes au images (après le titre, la description, les mots clés et tout...), j'ai ajouté 3 colonnes :

    • Numéro de page (numérique)
    • Thème (texte sur plusieurs lignes, des mots séparés par des virgules "," )
    • Un bouton radio (Couleurs / Noir et Blanc)
    benh ce que je veux faire maintenant, c'est indexer l'ensemble de ces images selon ces 3 colonnes et permettre la recherche sur ces critères.

    exemple : rechercher toutes les images de la page 84.. ou recherche une image en couleur ayant pour thème solidarité, fraternité, entraide...

    est ce que ma question est claire?
    merci pour votre aide, je compte sur vous :)

    jeudi 15 juillet 2010 08:31

Réponses

Toutes les réponses

  • Bonjour,

    L'opération est évoqué dans la littérature officielle http://msdn.microsoft.com/en-us/library/bb608302(office.12).aspx au chapitre

    Creating and Using Managed Properties in the Browser

    Et l'opération est exposée avec un peu plus de détails sur ce blog: http://www.tautic.com/?p=27


    Nicolas Cambot - Blog Nelite
    jeudi 15 juillet 2010 13:54
  • merci nikolas pour les liens. cependant j'ai rencontré un autre problème : 

    j'utilise pour mon application un nom de haute : intranet.societe.org et extranet.societe.org, j'utilise une double authentification, et jusque là ça marche bien, mais quant je veux indexer mon ou mes sites c'est là ou les problèmes commencent : j'obtien ce message d'erreur : 

    sps3://intranet.societe.org
    Accès refusé. Vérifiez que le compte d'accès au contenu par défaut peut accéder à ce référentiel ou ajoutez une règle d'analyse pour analyser ce référentiel. Si le référentiel analysé est un référentiel SharePoint, vérifiez que le compte que vous utilisez dispose des autorisations « Lecture totale » sur l'application Web SharePoint analysée.

    dans la source de contenu je n'ai mis qu'un seul site : intranet juste pour tester.. et rien ne marcha, que des erreurs!!!

     

    esr ce que vous pouvez m'aider?

     

    merci

    vendredi 16 juillet 2010 08:28
  • Bonjour,

    Dans les utilisateurs du site intranet il faut ajouter l'utilisateur qui est utilisé par le moteur d'indexation. Sinon celui ci ne peut pas accéder au site et donc l'indexer.


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    vendredi 16 juillet 2010 09:09
    Auteur de réponse
  • j'utilise deja pour l'indexteur l'adiminitrateur de l'intranet
    vendredi 16 juillet 2010 09:15
  • Bonjour,

    Est ce que t'es application Web sont configuré sur des ports standards (80 ou 443) ou sur d'autres ports?

    Est ce que tu utilise Kerberos ou NTLM ?

     

    Cdt


    J.K
    vendredi 16 juillet 2010 09:47
  • mes applications son tous les 2 sur les ports 80, l'authentification de l'intranet se fait via l'Active directory (auth windows NTLM) et l'extranet sur AspMemberShip (form based auth)

    vous voulez un peu plus de details?? benh voila ce que j'ai dans l'observateur des evennement :

     

    Échec de synchronisation de l'application pour Microsoft.Office.Excel.Server.ExcelServerSharedWebService.
    
    Raison : Les stratégies système doivent disposer du contrôle total.
    
    Détails du support technique :
    Microsoft.SharePoint.SPException: Les stratégies système doivent disposer du contrôle total.
     à Microsoft.SharePoint.Administration.SPPolicy.SPPolicyRoleBindingCollection.AddById(Guid id)
     à Microsoft.SharePoint.Administration.SPPolicy.SPPolicyRoleBindingCollection.Add(SPPolicyRole policyRole)
     à Microsoft.Office.Server.Administration.SharedResourceProvider.EnsureWebApplicationPolicy(SPWebApplication webApplication, String userName)
     à Microsoft.Office.Server.Administration.SharedResourceProvider.SynchronizeWebApplicationPolicies()
     à Microsoft.Office.Excel.Server.ExcelServerSharedWebApplication.Synchronize()
     à Microsoft.Office.Server.Administration.SharedResourceProvider.SynchronizeApplications(SharedComponentSecurity sharedApplicationSecurity)
    
    Pour plus d'informations, consultez le centre Aide et support à l'adresse http://go.microsoft.com/fwlink/events.asp.

     

    vendredi 16 juillet 2010 10:16
  • En utilisant la console d'administration vérifie si un compte est configuré pour opérer en tant que système au niveau de la stratégie de l'application, si c'est le cas  décoche la case à cocher "Le compte opère en tant que système" pour celui ci.

    Console d'administration Centrale ==> Page : Gestion des Application ==> Section : Sécurité des applications ==> Lien : Stratégie de l'application Web  

    Cdt

     


    J.K
    vendredi 16 juillet 2010 10:38
  • j'ai fait ça.. et rien!! le même message d'erreur
    vendredi 16 juillet 2010 11:25
  • T'as redémarrer IIS ou non ?

    Cdt


    J.K
    vendredi 16 juillet 2010 11:31
  • oui biensur
    vendredi 16 juillet 2010 11:37
  • en fait j'ai quelques problèmes à me connecter à l'intranet, et voici ce que j'ai fait pour y remédier : 

     * j'ai décoché la case "Authentification Windows intégrée 

     * j'ai coché la case : authentification de base

     

    c'est la seule configuration qui m'a permis de me connecter à la fois au site intranet et à la SSP

     

    que dois je faire?

    vendredi 16 juillet 2010 12:37
  • Tu parles d'IIS lorsque tu dis que t'as décoché "Authentification Windows Inetegrée" et la suite ?

    Cdt


    J.K
    vendredi 16 juillet 2010 12:59
  • c'est dans la central administration de sharepoint

    Console d'administration Centrale ==> Page : Gestion des Application ==> Section : Sécurité des applications ==> Lien : Fournisseur d'authentification

    et quant je change tout ça et benh même dans l'IIS ça change automatiquement!

    et puis.. c'est la seule configuration qui m'a permis de m'authentifier, car dés l'installation de sharepoint j'ai bien spécifié que cette machine fait bien partie d'un domaine qui a un Active Directory ( OU:Utilisateurs)

    cela fait plus d'une semaine que je suis bloqué la dessus :s

    vendredi 16 juillet 2010 13:10
  • Bonjour

    Question est ce que si tu es en local sur le serveur tu arrives a acceder a SharePoint en integrer ??

    ne serait ce pas cette erreur:

    http://blog.xvanneste.com/Lists/Billets/Post.aspx?ID=2


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    vendredi 16 juillet 2010 13:33
    Auteur de réponse
  • oh oui c'est super ça a résolu MES problèmes, je ne sais vraiment comment vous remercier ^^

    en fait, j'ai remarqué cela il y a des semaines, mais comme j'ai trouvé la bonne configuration pour l'authentification, j'ai continué à travailler sans trop perdre de temps.. et maintenant tout est résolut.. 

     

    merci tout le monde

    vendredi 16 juillet 2010 14:20
  • C'est bien, je suis content que ton problèem est résolu et étant données que c'était simplement le LoppBackCheck  voici une autre alternative :

    Ajouter une valeur Multi-String nommée BackConnectionHostNames  à la clé de registre HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0 et y tapez les noms d’hôtes de tous les sites dont l’authentification est Windows et qui présentent le problème

    Comme ça tu peux ne pas utiliser la clé DisableLoopBackCheck garder le niveau de sécurité de ton serveur.

    voir : http://support.microsoft.com/kb/887993/fr

    Cdt  

     


    J.K
    vendredi 16 juillet 2010 15:14
  • je sais que mon problème est déjà résolut, mais j'en profite pour poser une nouvelle question : 

    je suis entrain de faire une bibliothèque d'images, j'ai créé des colonnes supplémentaires pour les détails des images téléchargées, et il y 2 colonnes qui me dérangent : Les Mots clés et Description.. y a il un moyen de les enlever car ils ne me servent à rien et puis ça encombrent la page de détails ?? 

     

    merci

    lundi 19 juillet 2010 10:19