none
[MOSS 2007] [FR] Dossiers de bibliothèque non accessible en https via isa 2006 RRS feed

  • Question

  • Bonjour,

    Je publie des applications web en suivant les recommandations de ce technet http://technet.microsoft.com/en-us/library/cc261814.aspx.

    Lorsque j'accède au site publié via https uncomportement étrange fait que dansles bibliothèque de document il est impossible de browser les repertoire, d'archiver les documents, d'annuler l'extraction ou encore de visionner les historiques de version. Bref tout ce qui touche au menu des éléments d'une bibliothèque de document.

    En regardant de plus près et après avoir cliqué sur tel ou tel menu (archiver, annuler etc...) l'url passe de https à http. Dès lors en attanquant le site publié en Http il n'y a effectivement pas ce problème.

    Par quel truchement certaines url ne sont pas traduites par ISA server ? est-ce spécifique aux menus des éléments et au dossiers ?

    Quelqu'un as-il déjà connus ces symmptômes ?

    Merci par avance pour vos lumières,


    JunkCoder
    • Modifié jeremie.coste jeudi 27 août 2009 06:32 correction du titre
    mardi 18 août 2009 13:20

Réponses

  • Bonsoir,

    C'est un fait même publié avec https l'accès au dossier (ainsi qu'a certains menu d'éléments) se fait par http uniquement.

    voici une  solution assez éléguante issue du post de "Zuhar Said".

    Typiquement il faut ajouter une IP supplémentaire au serveur ISA pour créer un weblistener sur cette IP qui écoute sur 80 et 443 avec l'option rediriger tout le traffic http vers https.

    Un fois la modification redirection adequat effectuée sur le firewall de la société, il reste à appliquer le nouveau web listener à la règle de publication du site SharePoint voulue.
     
    Et là miracle ça fonctionne ! l'url reste en https que l'on aille dans un dossiers ou que l'on sélectionne un menu d'élément tel que archiver ou annuler l'extraction.

    Pour parfaire le fonctionnement au niveau client et être dispensé des messages d'alertes "Attention contenu Mixte"  il faut  personnaliser le niveau de la zone adequat dans le menu Outils>Option Internet > personnaliser le niveau Sécurité - section Divers-Afficher un contenu mixte, passé à "Activé".

    PS: Si le certificat du site n'est pas reconnu comme valide il faudra donc personnaliser la zone "Sites Sensibles"


    JunkCoder
    mardi 18 août 2009 17:44