none
Impression Rapport en automatique prend le format Letter par défaut au lieu du format A4 du rapport RRS feed

  • Question

  • Bonjour,

    J'ai développé un rapport à l'aide de visual studio 2008 pour report services avec des données sur SQL server 2008 SP2.

    Mon rapport est au format A4. Lorsque j'imprime mon rapport manuellement, le format A4 est bien pris en compte.

    Par contre lorsque j'imprime automatiquement mon rapport à partir d'une application web, mon rapport s'imprime sur 2 pages au lieu d'1 car le format A4 n'est pas pris en compte. Le rapport est au format Letter !

    Pour l'impression automatique, j'utilise un ActiveX : RsClientPrint

    J'ai modifié le fichier Rsreportserver.config sans succès.

    Est-ce que quelqu'un a une idée de la solution (à part refaire mon rapport au format letter) ?

    • Modifié acbdev72 mercredi 17 novembre 2010 13:40
    mardi 16 novembre 2010 10:24

Toutes les réponses

  • Bonjour,

    avez vous essayer de préciser des valeurs aux propriétés PageWidth, PageHeight du control RsClientPrint.

    Pour une liste complète voir ici

    Si vous pouvez utiliser asp.Net vous pouvez utiliser le control ReportViewer à la place.

    Cordialement

     

    mardi 16 novembre 2010 13:08
  • J'utilise le control ReportViewer qui demande l'installation de l'activeX à l'exécution. Mais je ne sais pas comment imposer le format A4.

    Voici mon code :

    <head runat="server">
      <title></title>
      <script type="text/javascript">
        function imprimer() {
          document.getElementById('ReportViewer1').ClientController.LoadPrintControl();
          //setTimeout('fermer()', 10000);
          setTimeout('Transfer()', 20000);
          //location.href = 'LancerImpression.aspx';
        }
        function fermer() {
          window.open('', '_parent', '');
          window.close();
    
        }
        function Transfer() {
          location.href = "Conformite.aspx";
        }
      </script>
    </head>
    <body onload="imprimer()">
      <form id="form1" runat="server">
      <div>
        <rsweb:ReportViewer ID="ReportViewer1" runat="server" Font-Names="Verdana" 
          Font-Size="8pt" Height="760px" ProcessingMode="Remote" Width="100%">
          <ServerReport ReportPath="/monRapport" 
            ReportServerUrl="<%$ appSettings:UrlReportServer %>" />
        </rsweb:ReportViewer>        
      </div>
      </form>
    </body>
    </html>
    
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        Dim nbparam = Request.QueryString.Count - 1
        ReportViewer1.ServerReport.ReportPath = Request.QueryString("Rapport")
    
        If nbparam > 0 Then
          Dim prm(nbparam - 1) As ReportParameter
          For i = 1 To nbparam
            prm(i - 1) = New ReportParameter(Request.QueryString.Keys(i), Request.QueryString(i))
          Next
          ReportViewer1.ServerReport.SetParameters(prm)      
        End If
      End Sub
    
    mercredi 17 novembre 2010 14:41
  • Bonjour,

     

    Essayez de modifier les dimensions de votre rapport en cm et pas en inches. Le problème pourrait venir des différences entre les Regional Settings du serveur et de l’application.

     

    Cordialement,

    Alex

    ________________

    Publiez un article sur MSDN !

     

    Windows Phone 7

     

    Astuces pour Visual Studio 2010

     

    XNA – Développement jeux vidéo

     

    Didacticiels et astuces : VB.NET, C#, ASP.NET, .NET Framework, Silverlight, Workflow Foundation, WPF

    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

     

     


    Suivez MSDN sur Twitter 

    dimanche 21 novembre 2010 16:37
  • Bonjour Alex,

    Merci pour votre réponse. J'ai remis mon rapport en centimètre et j'ai le même problème.

    Cordialement,

    Anne

    • Marqué comme réponse acbdev72 lundi 22 novembre 2010 10:35
    • Non marqué comme réponse Alex Petrescu lundi 22 novembre 2010 14:17
    lundi 22 novembre 2010 10:35