none
[SharePoint 2010 / InfoPath 2013-2007] Erreur d'accès au code behind d'un formulaire InfoPath RRS feed

  • Question

  • Bonjour à tous,

    Je suis actuellement sur une difficulté que je n'arrive pas à résoudre concernant InfoPath et le code behind.

    Pour situer le contexte, je travaille sur un environnement SharePoint 2010 sur lequel sont déployés des formulaires InfoPath dans des librairies. Ces formulaires ont tous été créés pour être compatibles avec InfoPath 2007. En effet historiquement la gestion du code behind se faisait en VBScript dans ces formulaires.

    Il y a quelques semaines, pour une raisons inconnue, certains de ces formulaires n'ont plus voulu s'ouvrir avec 2007. L'erreur signalait que le formulaire en question avait été créé avec InfoPath 2013. Pensant à une mauvaise manipulation d'une personne qui aurait pu mettre à jour le formulaire, j'ai installé l'ensemble des composant requis pour accéder au code behind avec InfoPath 2013 (Visual Studio, Tools for Application). Seulement lorsque j'ouvre le code editor de mon formulaire sur InfoPath 2013, il me crée un projet vide (C# ou VB) sans me donner accès au VBScript déjà présent..

    Je suis donc un peu bloqué comme InfoPath 2007 ne veut plus ouvrir le formulaire alors que tout allait avant et InfoPath 2013 ne me retrouve pas le VBScript pourtant présent...

    Je me tourne donc vers vous pour savoir si vous auriez des pistes de réflexion ou si ce problème vous est déjà arrivé car il m'est impossible de refaire le formulaire de 0.

    En vous remerciant par avance,

    Alexandre

    mercredi 12 octobre 2016 14:59