none
Erreur Approval WorkFlow RRS feed

  • Question

  • Bonjour,

    Je viens vers vous car je ne sais plus où chercher.
    Voici mon soucis :
    J'essaye de créer un WorkFlow d'approbation de type State Machine. Dans ce WorkFlow j’utilise un formulaire InfoPath avec trois boutons Accepter/Rejetée/Modifier. Classique comme interface. Les conditions Acceptée/Rejetée fonctionnent. J'ai bien mon document qui passe à l'état définie par le responsable. Mon souci vient du bouton Modifier. Lorsque le responsable demande une mise à jour du document, je créer une tâche pour l'utilisateur pour lui dire de mette à jour son document et lorsque l'utilisateur indique que la tâche est terminé, je recréer une tâche pour le responsable. Et l'erreur survient ici. En faisant du pas à pas, les définitions de la tâche pour le responsable à l'air de bien se passer (Title, AssignedTo, TaskType, …) mais ensuite un message d'erreur s'affiche dans Historique des flux de travail (Une erreur s'est produite dans + Nom de la tâche) et la tâche ne se créer pas.

    J'ai fait des recherche et quelque testes mais rien de concluant.
    J'utilise Visual studio 2008 pour le développement des WorkFlows.


    Un grand merci d'avance.
    Tracid

    mardi 2 juin 2009 12:46

Réponses

  • Bonjour,

    Instinctivement je regarderais du côté des correlation tokens, mais je crains effectivement que l'on manque d'éléments pour vous répondre.

    Pourriez-vous svp nous fournir les messages d'erreurs du log SharePoint ?


    http://blogs.developpeur.org/anouvel
    • Marqué comme réponse Tracid83 vendredi 5 juin 2009 08:23
    jeudi 4 juin 2009 18:20

Toutes les réponses

  • Je vois que personne n'a de solution  !!! Si vous voulez plus de précision, n'hésitez pas à me le demander car je ne sais pas si j'ai été suffisamment claire.
    jeudi 4 juin 2009 06:14
  • Bonjour,

    Instinctivement je regarderais du côté des correlation tokens, mais je crains effectivement que l'on manque d'éléments pour vous répondre.

    Pourriez-vous svp nous fournir les messages d'erreurs du log SharePoint ?


    http://blogs.developpeur.org/anouvel
    • Marqué comme réponse Tracid83 vendredi 5 juin 2009 08:23
    jeudi 4 juin 2009 18:20
  • Bonjour,

    Un grand merci Arnault Nouvel. Je n'avais pas pensé aller voir les logs. Effectivement j'ai trouvé d'où le problème venait.
    Tu avais raison, c'était la corrélation tokens.
    voici l'erreur :
    System.InvalidOperationException: La valeur de corrélation sur la déclaration "........." est déjà initialisée.

    Il fallait que je modifie la variable "OwnerActivityName" par le bon state. Je laissais le state par défaut  "Worklow 1".

    Merci de m'avoir montré la voie.

    Tracid

    vendredi 5 juin 2009 08:23