none
Problème IIS 5.1 avec pages ASP, ASMX RRS feed

  • Question

  • Bonjour,

    je dois utiliser des pages asmx sur un serveur IIS sur du Windows XP Pro SP2, il s'agit de XP Pro SP2 préinstallé sur le pc à l'origine. Nous disposons de plusieurs pc installés ainsi et je rencontre le même problème sur cette série de pc.

    Une fois le IIS installé en tappant simplement http://localhost/localstart.asp , une erreur 500 est déclenchée, en revanche en tappant http://127.0.0.1/localstart.asp , une authentification m'est demandée (alors que l'authentification est placée en anonyme), et quels que soient les identifiants entrés, je ne peux accéder à la page n'ayant pas l'autorisation. Idem lorsque j'essaie de visualiser le .asmx de mon application

    En revanche, une page en .html ne pose aucun problème.

    Le aspnet_regiis.exe -i a bien été exécuté, et l'utilisateur aspnet a bien les droits sur le dossier en question

    Sur cette version du SP2, aucun cd ne m'est demandé lors de l'installation du IIS (contrairement aux autres versions ne posant pas problème où il fallait insérer le cd de Windows)
    Avec des SP2 installés autrement, je n'ai aucun souci d'utilisation.
    J'ai essayé de mettre à jour vers le SP3, mais il semblerait que l'installation du IIS se fasse avec les mêmes fichiers que pour le SP2 préinstallé.

    J'ai vu sur d'autres forums que d'autres personnes ont déjà eu ce souci, mais aucune solution concrète, nottamment le remplacement du fichier 500-100.asp par un fichier corrigé (correction des sauts de lignes)

    Existe-t-il un correctif? Un moyen autre que celui cité plus haut pour installer le IIS ?(remplacement de la dll qui installe le IIS? Dans ce cas quelle DLL est à remplacer?)

    Merci de votre aide
    lundi 4 août 2008 07:33