none
[MOSS 2007] Authentification par formulaire RRS feed

  • Question

  • Bonjour,

    Je tente de mettre en oeuvre l'authentification par formulaire à l'aide de ce tuto:
    http://www.simple-talk.com/content/article.aspx?article=389

    Cependant j'obtiens des erreurs lors de la modification des web.config de l'administration central et de l'application SharePoint que compte configurer en "authentication forms"

    Lorsque je relance l'admin centrale une fois les modifs effectuées comme indiquées dans le tutos, l'erreur est la suivante:

    Message d'erreur de l'analyseur: Section de configuration non reconnue membership.

    Erreur source:

    Ligne 125 :    <RuntimeFilter Assembly="Microsoft.Office.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Class="Microsoft.Office.Server.Audience.AudienceManager" BuilderURL="audience_chooser.aspx" />
    Ligne 126 :  </SharePoint>
    Ligne 127 :   <membership> <!-- element may already exist -->
    Ligne 128 :         <providers> <!-- element may already exist -->
    Ligne 129 :            <add 




    Et je ne vois pas quoi faire pour que la section membership soient reconnue.

    J'ai regardé dans les commentaires laissés par les lecteurs en bas de l'article et je n'ai rien identifier de particulier.



    connaissez vous un autre tuto ou une autre manière pour mettre en oeuvre l'authentification par formulaire.

    Merci par avance pour vos réponses

    JunkCoder
    mardi 21 juillet 2009 11:45

Réponses

  • Bonjour Jeremie,

    La balise <membership> me semble placée au mauvais endroit, d'où le message d'erreur indiquant qu'elle n'est pas reconnnue.

    Elle est sensée être juste après la balise <authentication mode="Windows" />
    http://blogs.developpeur.org/anouvel
    Merci de valider les réponses à vos questions et de marquer comme telles les réponses utiles
    • Marqué comme réponse jeremie.coste mercredi 22 juillet 2009 07:37
    mercredi 22 juillet 2009 07:28