none
Colonne calculé et Vue de données RRS feed

  • Question

  • Bonjour,

     

    Je vous explique mon problème simplifié que je retrouve un peu partout dans le site que je viens de créé.

     

    Je possède une "Liste Personalisé" appelé "Département". Cette liste possède 3 colonne :

    -Numéro (Le numéro du département)

    -Titre (Le nom du département)

    -Titre Unique (Qui est un colonne calculé ayant comme formule =[Numéro]&'-'&[Titre] )

     

    J'utilise une Vue de données pour afficher la liste des départements.

    Cette liste de département est une liste de liens qui renvois vers une page aspx. Cette page prend en paramètre la valeur de "Titre Unique".

     

    Le code XSL de la colonne :

     

    <td class="ms-vb">

    <a href="/Pages/Departement.aspx?Departement={@Titre_x0020_Unique}"><xsl:value-of select="@Titre_x0020_Unique" /></a>

    </td>

     

    Résultat avec le département Côte d'Armor j'ai :

    22-Côte d&#39;Armor.

     

    Alors je change le code en ajoutant un disable-output-escaping="yes", le problème a disparus visuellement.

     

    Mais l'url généré est :

    /Pages/Departement.aspx?Departement=22-C%C3%B4tes d&#39;Armor

    Et non pas :

    /Pages/Departement.aspx?Departement=22-C%C3%B4tes d'Armor

     

    Sachant que si je fais le même code en remplaçants @Titre_x0020_Unique par @Title. J'ai comme résultat de l'url :

    /Pages/Departement.aspx?Departement=22-C%C3%B4tes d'Armor

     

    Je précise aussi que j'ai fais le même teste avec une colonne calculé qui a comme formule  =[Titre] et j'ai le même problème.

     

    Est-ce un bug ?

     

    Merci par avance de votre aide.

    vendredi 24 août 2007 12:08