none
Déploiement et utilisation d'un ActiveX via Internet RRS feed

  • Question

  • Bonjour,

     

    Pour des raisons d'interface avec un logiel tier, je dois intégrer un contrôle ActiveX (ATL) dans une page HTML.

     

    J'ai développé l'ActiveX (ATL de type DLL), il fonctionne correctement.

    J'ai ensuite signé cet ActiveX avec un certificat Thawte / Verisign (utilisation de signtool.exe)

     

    J'intègre cet ActiveX dans ma page HTML avec une balise object.


    <OBJECT ID="tdTest"
            CLASSID="clsid:23A44244-3B80-4B00-9DEC-BFD3FE2BEB26"
            CODEBASE="
    http://mon.site.internet/MonActiveX.dll"
            WIDTH="1" HEIGHT="1">
    </OBJECT>


    Lorsque je teste cette page (avec IE7), j'ai le message suivant dans la "barre jaune" en haut de l'écran : "Internet Explorer a bloqué l'utilisation non sécurisée d'un ActiveX sur ce site. En conséquence, cette page ne sera peut-être pas affichée correctement."

     

    J'ai essayé le déploiement via un .cab (lui même signé) mais sans plus de succès.

    J'ai passé le site Internet dans les sites de confiance, mais sans succès non plus.

     

    Le seul moyen que j'ai trouvé pour faire fonctionner ma page HTML est d'autorisé l'utilisation d'ActiveX non signé !

     

    Question:

     

    Connaissez vous la démarche exacte à suivre pour déployer correctement un ActiveX signé pour une utilisation via Internet ? J'ai probablement du rater des épisodes sur le sujet (j'ai suivi ce qui est décrit dans http://msdn.microsoft.com/en-us/library/aa751974.aspx#EXAMPLE).

     

    D'avance merci.

    François.

     

    vendredi 17 octobre 2008 12:57