none
SharePoint 2010, Problème de rendu RRS feed

  • Question

  • Bonjour,
    J'ai installé un beau Sharepoint 2010 tout neuf et j'ai commencé à y mettre des données.

    Le problème se situe lorsque dans un affichage, je désire effectuer une somme sur une colonne de valeur monétaire.
    Le séparateur de millier (') ne s'affiche pas mais à la place le code & # 3 9 ; s'affiche dans tous les nombres.

    Je précise que je suis en configuration régionale Français SUISSE et qu'en Français France, cela fonctionne. Toutefois, je préfère avoir mes montant avec SFr. et je ne pense pas être le seul dans ce cas.

    Qui pourrais me filler un coup de main pour corriger ce bug ?

    Merci


    Philippe
    mercredi 5 mai 2010 09:38

Réponses

Toutes les réponses

  • Bonjour,

    La beta ou RTM ?

    Avez-vous vérifier IE (souvent j'ai constaté ce genre de situation)

    Cdlt

     


    Pierre Erol GIRAUDY clubsps2010@gmail.com MVP SHAREPOINT - Pdt du CLUB http://www.clubmoss2007.org
    mercredi 5 mai 2010 12:24
    Modérateur
  • Ah oui pardon, j'ai oublié de mentionner la version. RTM Fr

    Pou

    r ce qui est de IE que vérifier ? J'ai plusieurs postes qui affiche tous le même symptôme.

     

    Salutations,


    Philippe
    mercredi 5 mai 2010 16:43
  • Bonjour,
    J'ai installé un beau Sharepoint 2010 tout neuf et j'ai commencé à y mettre des données.

    Le problème se situe lorsque dans un affichage, je désire effectuer une somme sur une colonne de valeur monétaire.
    Le séparateur de millier (') ne s'affiche pas mais à la place le code & # 3 9 ; s'affiche dans tous les nombres.

    Je précise que je suis en configuration régionale Français SUISSE et qu'en Français France, cela fonctionne. Toutefois, je préfère avoir mes montant avec SFr. et je ne pense pas être le seul dans ce cas.

    Qui pourrais me filler un coup de main pour corriger ce bug ?

    Merci


    Philippe

    Bonjour,

    personne à une petite idée ?? Une Pise, quelque chose ??

    Salutations,

    Philippe


    Philippe
    mercredi 30 juin 2010 05:19
  • Avez vous la version de IE 8 (Les autres sont moins bien supporté par SharePoint, IE 6 ne marche pas du tout)

    Comment est paramètré votre IE ??? Codage Unicode UTF 8 ou autre ??

    Votre base de donnée est elle en latin1_general_CI_AS_KS_WS ???

    cdt,

    Matth-68

    mercredi 30 juin 2010 07:12
  • Bonjour

    sur la master page l'idéal sera de forcer l'encodage du charset:

    http://twistedmatrix.com/pipermail/twisted-web/2004-September/000608.html


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    mercredi 30 juin 2010 07:38
    Modérateur
  • Bonjour,

    IE8 tout ce qu'il y a de plus standard avec un Windows 7.
    Ce problème se produit sur tous les PC que j'ai essayé, je ne pense pas que la configuration IE puissent y faire kkchose.

    Les bases de données sont bien en Latin1_General_CI_AS_KS_WS.

    D'ailleurs le problème d'affichage ne se produit que sur la sommes, les données par ligne sont affichées correctement.

     

    Merci de ces idées.

    Philippe

     


    Philippe
    jeudi 1 juillet 2010 05:26
  • Au dessus des language settings il y a les regional settings, avez vous essayez de mettre en plus les regionals settings francais suisse ??
    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    jeudi 1 juillet 2010 08:56
    Modérateur
  • Dans l'absolue, comment avez vous installé votre pack language sur votre serveur SharePoint. Si vous avez plusieurs Web-Front End, votre pack language est il installé sur ces derniers ??

    Matth-68

    jeudi 1 juillet 2010 09:24
  • Oui, aucun changements.
    Philippe
    jeudi 1 juillet 2010 11:36
  • J'ai installé la version française, donc sans pack langue.

    C'est une installation en ferme, tout ce qu'il y a de plus simple (1 Front-End et 1 SQL)


    Philippe
    jeudi 1 juillet 2010 11:37
  • Je viens de vérifier dans le Technet, et en fait, je ne sais pas s'il y a une prise en charge spécifique du Français Suisse pour SharePoint Foundation.

    Il y a bien le Français ainsi que d'autre langue, mais pas encore de différenciation entre les français qui existe de par le monde. Je pense donc que sur votre serveur, le fichier.cab du Français suisse doit bien exister et qu'il n'y a pas de problèmes pour l'installer mais qu'il entre pour certaine chose en conflit avec le module linguistique français pour SharePoint Foundation 2010.

    Sinon, je ne m'explique pas le problème de caractère et je rejoint Xvanneste pour ce qui est de tenter de modifier le Charset de la master page pour voir ce qui se passe.

    Matth-68

    jeudi 1 juillet 2010 11:56
  • J'ai déposé une copie d'écran sur ici sur SkyDrive

    C'est tout de même étrange que sur la meme page, il y ait l'affichage juste (par ligne) et la somme affichée fausse non ?

    Salutations,

    Philippe 


    Philippe
    jeudi 1 juillet 2010 12:16
  • Quel est le code HTML créé ??

    as tu regardé la source HTML pour voir la différence entre la ligne et la somme et entre le francais standard et le francais suisse ??

    peux tu aussi regarder les meta tag créent en francais standard et en francais suisse ??

    Je sais je demande beaucoup :)


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    jeudi 1 juillet 2010 12:28
    Modérateur
  • J'ai demandé à un web developper de ma boite.

    Verdict, il doit y avoir un problème de double encodage (qui n'a rien à voir avec le langage apparemment)

    Si j'ai bien compris, normalement, votre calcul récupère les informations, effectue le calcul, et ensuite, l'affichage est généré en temps réel.

    C'est pour ce dernier qu'il faut préciser le type d'affichage que l'on souhaite.

    Maintenant, si nous pouvions voir le code source, cela nous aiderais bien. Mais je me demande si votre paramètrage initial, pour l'affichage des nombre en type anglais (avec ' comme séparateur) n'a pas générer un code spécifique pour cela, alors que le français suisse fait directement l'affichage anglais, et que par conséquent, il n'a pas généré une deuxième fois le code de '.

    A voir

    matth-68

    jeudi 1 juillet 2010 12:52
  • Bin pour voir le code source, rien de plus simple  :
    Installer sur Windows 2008 R2 (Fr) environnement FR-Suisse un SharePoint 2010 Français,
    créer un site, créer une liste avec un colone "monnétaire"

    Dans un affichage, définir des totaux (Somme) pour la colone monnétaire et le tours est joué.

    Ce problème d'affichage survient sur une page standard, rien n'a été codé nul part, tout est d'origine.

    En gros, c'est un BUG dans MOSS 2010 qui touche que les Suisse Romand (Français-Suisse) car dans les autres langues (anglais/US, ou Français/France) aucun problème.


    Philippe
    jeudi 1 juillet 2010 13:30
  • Sinon plus simple le code HTML se voit en faisant un clic avec le Bouton droit de la souris sur la page et view source ou afficher la source.

    La on a le code HTML et on peut avoir les informations de coding et voir s'il y a un double encodage genre ' au lieu de ' dans le code html


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    jeudi 1 juillet 2010 13:41
    Modérateur
  • Voici la partie "pertinante" du code source.

    On voit clairement le double encodage pour la sommes.

    Maintenant que le BUGS est défini, comment le remonter à Microsoft pour obtenir un correctif ??

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns:o="urn:schemas-microsoft-com:office:office" lang="fr-fr" dir="ltr">
    <head><meta http-equiv="X-UA-Compatible" content="IE=8" /><meta name="GENERATOR" content="Microsoft SharePoint" /><meta name="progid" content="SharePoint.WebPartPage.Document" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta http-equiv="Expires" content="0" /><title>
     TEST - Tous les éléments
    </title><link rel="stylesheet" type="text/css" href="/_themes/1/search-EE2B6491.css?ctag=2"/>
    <link rel="stylesheet" type="text/css" href="/_themes/1/corev4-AE236408.css?ctag=2"/>
    <link type="text/xml" rel="alternate" href="/_vti_bin/spsdisco.aspx" />
     <link rel="alternate" type="application/rss+xml" title="TEST" href="/_layouts/listfeed.aspx?List=e9c40f20%2D44f1%2D46eb%2Dacec%2D70b6575ae84a" />
     
    <link rel="shortcut icon" href="/_layouts/images/favicon.ico" type="image/vnd.microsoft.icon" />
    </head>
    <body scroll="no" onload="if (typeof(_spBodyOnLoadWrapper) != 'undefined') _spBodyOnLoadWrapper();" class="v4master">

    [...]

    <tr><td>Somme= SFr. 1&amp;#39;345.00</td></tr>
    <tr class="ms-itmhover" iid="0,1,0">
    <td>Pièce 1 [...] <div align="right">SFr. 100.00</div></td></tr><tr class="ms-alternating ms-itmhover" iid="0,2,0">
    <td>Pièce 2 [...] <div align="right">SFr. 1&#39;245.00</div></td></tr>
    [...] 
     
    </body>
    </html>


    Philippe
    vendredi 2 juillet 2010 05:54
  • Ah oui en effet le &amp;#39; fait un double encodage, il est donc normal que l'affichage ne fonctionne pas :( en changeant les regionnal settings en plus du langage on a aussi ce double encodage ?
    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    vendredi 2 juillet 2010 06:53
    Modérateur
  • Sinon il faut voir pour modifier le code de la page directement en utilisant Designer 2010 (intallation de designer pour les faignants 'Site Actions' --> 'Edit with SharePoint Designer' s'il n'est pas installé il propose de la faire) . Pour ce qui est de remonter le bug,

    Essayez cette adresse mail msnhst@microsoft.com dans le pire des cas, il vous donnerons la bonne adresse mail pour la remonter d'info.

    MAtth-68

    vendredi 2 juillet 2010 07:32
  • Voici la réponse que m'a faite notre web developer

    je cite : "

    Pour l’utf8 tu n’est pas obliger de ré-encoder les caractères spéciaux.

    &amp ; c’est l’encodage du & commercial d’où le problème à l’affichage."

    Matth-68

    vendredi 2 juillet 2010 08:13
  • Je suis bien d'accord, mais je vais tenter le mail de MS pour obtenir un Fix.


    Philippe
    vendredi 2 juillet 2010 08:20
  • Bonjour,

     

    Je suis confronté au même problème avec un client. Avez--vous trouvé une solution??? Avez-vous écrit à Microsoft?

     

    Merci

    • Marqué comme réponse Bobobull lundi 7 février 2011 12:33
    • Non marqué comme réponse Bobobull lundi 7 février 2011 12:34
    mardi 16 novembre 2010 16:05
  • Le SP1 à résolu le problème
    Philippe
    • Marqué comme réponse Bobobull lundi 7 février 2011 12:34
    lundi 7 février 2011 12:34
  • OK.

    Bon à savoir. J'ai moi-même résolu le problème depuis SharePoint Designer. J'ai repéré les balises xsl qui contenaient ces info (group by) et ai ajouté disable -output -escaping ="yes" dans chcune d'entre elles. Ceci marche à merveille. toutefois, il faut bien penser à le faire dans tous les cas (toutes les vues pour moi...).

    Donc, ceci a été corrigé par le SP1 de SPS2010?

     

    lundi 7 février 2011 13:51