none
Filtrer sur plusieurs colonnes - Excel 2003 RRS feed

  • Question

  • Bonjour,

     

    Je recherche un moyen d'appliquer un filtre sur 2 colonnes différentes. Les colonnes contiennent des dates, et je souhaite filtrer pour ne garder visible que les lignes dont une des 2 colonnes contient une date compris dans l'écart demandé.

    Quelqu'un aurait une idée s'il vous plait ?

     

    Merci

    samedi 5 juin 2010 15:24

Réponses

  • Comment juge-t-on que quelqu'un est pro ou pas ? Moi personnellement je ne le suis pas.

    J'ai réfléchi un peu, et j'ai trouvé une solution a mon problème, je la poste au cas où cela puisse servir à quelqu'un :

    J'ai créé une colone supplémentaire avec la formule : =SI(OU(ET(F6>=$S$5;F6<$T$5);ET(H6>=$S$5;H6<$T$5));1;0)

    où S5 contient la plus petite date de mon interval

        T5 contient la plus grande date de mon interval

    J'ai ajouté cette nouvelle colonne dans les filtres automatiques. Je n'ai plus qu'à remplir dynamiquement le contenu de S5 et T5 et d'appliquer le filtre automatiquement

            Cells(5, 18).AutoFilter Field:=18, Criteria1:="1"

    où cells(5,18) est la cellule contenant le filtre

        18 est la colonne contenant la formule

        1 est le résultat dans cette colonne quand la date dans les colonnes F ou H est dans l'interval

     

    Merci

    dimanche 6 juin 2010 21:45

Toutes les réponses

  • Bonjour,

    Ici tu es dans VBA, or ta question semble relever d'Excel, non... ce serait là

    http://social.answers.microsoft.com/Forums/fr-FR/officeexcelfr?filter=answered,mf:07c6b359-295f-49a4-9ced-e40aa1a9e3f6&prof=required

    Cordialement. 


    Joseph Attila PUSZTAY
    EhJoe       Logiciels       Romans       Ecrire
    dimanche 6 juin 2010 08:33
  • Bonjour,

     

    Merci d'avoir porté de l'intérêt à mon problème. Ici, on est dans VBA, et ma question relève bien d'Excel. Si je l'ai mis là, c'est que je cherche à faire ceci en VBA.

     

    Cordialement

     

    dimanche 6 juin 2010 17:33
  • Bonsoir

    Vous avez raison si on s'arrête à l'intitulé de ce forum, mais le VBA a été isolé dans un forum qui fait partie des forums "pro".

    Allez savoir pourquoi ?

    En fait les utilisateurs d'Excel vont sur le forum Excel, que ce soit du vba ou pas.

    D'ailleurs la plupart du temps un utilisateur cherche une solution à un problème, si on doit le renvoyer sur un autre forum parce qu'on lui propose une macro il va se demander où il est tombé.

     

    dimanche 6 juin 2010 21:19
  • Comment juge-t-on que quelqu'un est pro ou pas ? Moi personnellement je ne le suis pas.

    J'ai réfléchi un peu, et j'ai trouvé une solution a mon problème, je la poste au cas où cela puisse servir à quelqu'un :

    J'ai créé une colone supplémentaire avec la formule : =SI(OU(ET(F6>=$S$5;F6<$T$5);ET(H6>=$S$5;H6<$T$5));1;0)

    où S5 contient la plus petite date de mon interval

        T5 contient la plus grande date de mon interval

    J'ai ajouté cette nouvelle colonne dans les filtres automatiques. Je n'ai plus qu'à remplir dynamiquement le contenu de S5 et T5 et d'appliquer le filtre automatiquement

            Cells(5, 18).AutoFilter Field:=18, Criteria1:="1"

    où cells(5,18) est la cellule contenant le filtre

        18 est la colonne contenant la formule

        1 est le résultat dans cette colonne quand la date dans les colonnes F ou H est dans l'interval

     

    Merci

    dimanche 6 juin 2010 21:45
  • Bonjour GeoF37,

    Si ce n'est pas posté au bon endroit il va se faire déplacer, mais dans l'absolu, c'est vrai que ce genre de question peut être traité en formule manuelle ou en VBA...

    Cordialement.

     


    Joseph Attila PUSZTAY
    EhJoe       Logiciels       Romans       Ecrire
    lundi 7 juin 2010 06:05
  • Bonjour gupz,

    La distinction "pro" et "non pro" on va dire, est plus celle de l'utilisation du produit que de l'utilisateur. Moi par exemple, je fais du VB, et maintenant un peu de vbNet, ben c'est dans les forums "pro", parce que ce sont principalement des professionnels qui utilisent ces langages, mais me concernant, mes principaux revenus ne sont pas ceux de la programmation (accessoires et associatifs), donc je ne suis pas un professionnel, bien que... depuis 25 ans... mais j'utilise des langage avec lesquels écrivent des "pro"... hum...

    Cordialement.

     


    Joseph Attila PUSZTAY
    EhJoe       Logiciels       Romans       Ecrire
    lundi 7 juin 2010 06:13
  • Comment juge-t-on que quelqu'un est pro ou pas ? Moi personnellement je ne le suis pas.


    Si ça continue, on ne va trouver aucun pro sur ce forum et pourtant MS l'a mis dans les pros.

    C'est une vision de technocrate, surtout que le vba n'a pas de vie propre et est étroitement lié à son application.

    D'ici quelques années, ça changera peut-être.

     

    lundi 7 juin 2010 21:06
  • Bonjour Géo & Cie
     
    Depuis la "refonte" des newsgroup de "M$", on a a droit à un (des) bridge qui nous fait découvrir des groupes comme Msdn.fr-FR.*
     
    <GeoF37 [MVP]> a écrit dans le message de news: 41cf38ea-355f-479a-a2a2-6b1256f7412a@communitybridge.codep lex.com...
    >> Comment juge-t-on que quelqu'un est pro ou pas ? Moi personnellement je ne le suis pas.
    >
    >
    > Si ça continue, on ne va trouver aucun pro sur ce forum et pourtant MS l'a mis dans les pros.
    >
     
    Il est vrai que définir un "pro" d'un "non pro" est une chose difficile.
    Moi-même je programme depuis TRS-80 M3.  Je me souviens d'une BD-Gestion d'inventaire (en "Profile" si j'ai bonne mémoire) répartie sur 4 (quatre) disquettes (= 4 lecteurs en même temps) !
    Mais puis-je être pro en, par exemple Access 2007, alors que je dois coder depuis +sieurs années en XP ?
     

    > C'est une vision de technocrate, surtout que le vba n'a pas de vie propre et est étroitement lié à son application.
    >
    Que dire à cela ? Que c'est normal que vbA soit attaché à son Application.
     
    > D'ici quelques années, ça changera peut-être.
    >

    Un langage universel ?  J'y crois pas.
     
    Cdt Blaise

    Cdt, Blaise. Le patriotisme, c'est la solidarité. Le nationalisme, c'est la haine de l'autre. (Ph. Geluck)
    mardi 15 juin 2010 18:46