none
Le champ audience ciblée ne s'affiche pas dans les propriétés des webparts !!! RRS feed

  • Question

  • Bonjour.

    J'ai utilisé la fonctionnalité de ciblage d'audience pour masquer certaines informations à certains utilisateurs. Or depuis ce matin, tous les webparts sont affichés, et dans les propriétés des composants (TOUS), le champ audience ciblée n'apparaît plus.

    Je précise que la fonctionnalité de ciblage d'audience est bien activée sur les listes que je manipule. la plateforme est sharepoint 2013 serveur.

    Avez-vous une solution à ce problème ? des suggestions ?

    Merci.

    Jules-Hervé.

    lundi 22 juillet 2013 16:51

Réponses

  • Bonjour une fois de plus.

    Le problème a été résolu. En effet, un service au nom kilométrique (3936f254385348608af8001159f264b1...) qui gère cette fonctionnalité (audience ciblée) avait besoin d'être configuré pour fonctionner avec mon compte AD de service.

    Pour le paramétrer, j'ai procédé comme suit :

    - Gestionnaire des services IIS  > Pools d'applications > Clic droit sur le service (3936f254385348608af8001159f264b1...).

    - Dans la rubrique identité, j'ai défini mon compte avec le mot de passe correspondant.

    J'ai ensuite démarré ce service et par la suite, l'option Audiences ciblées est réapparue dans les propriétés des webparts.

    La vidéo disponible à cette adresse (http://www.youtube.com/watch?v=sAF1q0GwKmM) décrit visuellement le processus d'activation d'un service tel que celui que j'ai évoqué.

    La plus grande difficulté aura été de savoir que c'était ce service qui pilotait cette fonctionnalité.

    Merci à ceux qui ont donné leurs conseils, j'ai pu par leurs indications, découvrir de nouveaux paramètres de configuration de l'environnement SharePoint.

    A bientôt.

    jeudi 25 juillet 2013 12:47

Toutes les réponses

  • Bonjour Jules-Hervé,

    Il met arrivé la même chose, mais un simple IISReset m'a fait revenir le champ...

    En espérant que ca aide

    Bonne journée.

    Julien

    lundi 22 juillet 2013 18:46
  • Bonjour,

    Si jamais le IISreset ne résout pas le problème, merci de vérifier que votre fichier web.config contient l'entrée suivante

     <RuntimeFilter Assembly="Microsoft.Office.Server, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Class="Microsoft.Office.Server.Audience.AudienceManager" BuilderURL="audience_chooser.aspx" />

    mardi 23 juillet 2013 09:24
  • Bonjour à vous et merci pour vos réponses.

    Cependant, le problème est toujours présent, et malgré IIReset et plusieurs redémarrages, je n'ai toujours pas cette option dans les propriétés des webparts.

    C'est très handicapant, car toute la logique de l'application s'appuyait là dessus.

    @amine Sassi : mon fichier web.config contient bien la ligne indiquée.

    Si vous avez d'autres suggestions, je suis preneur.

    Jules-Hervé.

    • Marqué comme réponse Jules-Hervé jeudi 25 juillet 2013 12:49
    • Non marqué comme réponse Jules-Hervé jeudi 25 juillet 2013 12:49
    mardi 23 juillet 2013 14:47
  • Bonjour une fois de plus.

    Le problème a été résolu. En effet, un service au nom kilométrique (3936f254385348608af8001159f264b1...) qui gère cette fonctionnalité (audience ciblée) avait besoin d'être configuré pour fonctionner avec mon compte AD de service.

    Pour le paramétrer, j'ai procédé comme suit :

    - Gestionnaire des services IIS  > Pools d'applications > Clic droit sur le service (3936f254385348608af8001159f264b1...).

    - Dans la rubrique identité, j'ai défini mon compte avec le mot de passe correspondant.

    J'ai ensuite démarré ce service et par la suite, l'option Audiences ciblées est réapparue dans les propriétés des webparts.

    La vidéo disponible à cette adresse (http://www.youtube.com/watch?v=sAF1q0GwKmM) décrit visuellement le processus d'activation d'un service tel que celui que j'ai évoqué.

    La plus grande difficulté aura été de savoir que c'était ce service qui pilotait cette fonctionnalité.

    Merci à ceux qui ont donné leurs conseils, j'ai pu par leurs indications, découvrir de nouveaux paramètres de configuration de l'environnement SharePoint.

    A bientôt.

    jeudi 25 juillet 2013 12:47
  • Merci Jules-Hervé pour ta réponse!

    Gokan - Modérateur


    My Technical Blog on Wordpress

    vendredi 26 juillet 2013 08:37