none
Probleme de publication d'un Projet Asp.net/ C# avec visual studio. RRS feed

  • Question

  • Bonjour a tous,

    J'ai un problème assez curieux avec la publication d'un projet WEB avec visual studio:

    L'application s'execute dans un environement Windows 2003/ IIS 5. Je publie mon application en pré prod, jusqu'ici tous vas bien. Mes mises a jour de l'application est bien pris en compte.

    Dès que j'envoie en FTP les fichiers compilé en prod, celui ci ne prends pas en compte mes mises à jour.

    est ce que vous avez une idée?

    Merci d'avance!

    mercredi 26 septembre 2007 08:33

Toutes les réponses

  • Bonjour,

     

    Quelle méthode de déploiement avez-vous choisi ?

    Xcopy, Setup d'install, ou autre ?

    Et d'autre part, faites vous une précompilation du site web?

     

     

     

    mercredi 26 septembre 2007 11:22
  • Bonjour,

     

    Je déploie mon projet sur un serveur de préprod avec l'outil intégrer à visual studio.

    Une fois publié, le site fontionne très bien. Dès que j'envoie les fichiers compilés sur la prod qui à la même config que la préprod, celui ci execute l'ancienne version.

    Etrange comportement. Je ne comprends pas ou est la source de ce problème. Je me demande si ce n'est pas un souci de cache IIS 6.0.

    Merci pour votre intervention.

     

    mercredi 26 septembre 2007 12:05
  • Bonjour,

     

    Avez-vous essayé de publier votre site dans un répertoire local de votre ordinateur de développement et ensuite copier le tout via un logiciel FTP classique ?

     

    Cordialement

     

    mercredi 26 septembre 2007 16:35
    Modérateur
  • Bonjour,

    Oui. J'ai éfféctué cette manipulation.Et rien n'y fais.J'ai l'impression que IIS possede un "cache" qui ne prends pas en compte mes modifications.
    Lorsque je suis sur le serveur de "production", j'arrive à visualiser mes fichiers modifiés par contre IIS génère tjrs la version anterieur.
    Merci par avance de votre aide .
    Très cordialement.
    mercredi 26 septembre 2007 20:03
  •  

    vire tout les fichiers se trouvant dans :

    C:\Documents and Settings\ton_utilisateur\Local Settings\Apps\2.0\

     

    j'ai galérer aussi avant de le trouver ou il les sotcker !

    mardi 9 octobre 2007 14:00
  •  

    Salut,

    J'ai regarder dans ce chemin.Ca ne change rien.

     

    Il y aurrai t il une autre piste?

     

    Merci d'avance. 

    vendredi 12 octobre 2007 10:32
  • Avez-vous essayé de supprimer tous les fichiers présents dans :

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET
    Files

     

    Un arrêt temporaire de IIS sera sans doute nécessaire...

     

    Cordialement

    samedi 13 octobre 2007 09:37
    Modérateur