Why VS11 Help Viewer 2.0 has ugly mono font?

Toutes les réponses

  • Here's what you should be seeing for this topic (Walkthrough: Your First F# Program):

    Are you seeing your font issue in all of your code examples or in a subset of them?


    Jeff Braaten, Library Experience Team

    samedi 3 mars 2012 19:39
  • Yes, for all examples with no exception.

    samedi 3 mars 2012 22:03
  • I've done some reverse engineering and found this piece of code responsible for setting my font:

        font-family:Courier, "Courier New", Consolas, Monospace;
        overflow: hidden;

    So, I gather, you should place Consolas first, next Courier New, new Courier and finally Monospace!

    lundi 5 mars 2012 13:23
  • Hi Andrew,

    Thank you for making us aware of this.  A fix is in the works.  I will post back here once I have an ETA for placing
    the fix on the package service endpoint.


    lundi 5 mars 2012 17:22
  • Hi Andrew,

    Would like to be able to reproduce what you are seeing.  Can you please post the OS and browser you
    are running.  Also, please verify you are
    running Visual Studio 11 Beta.

    Thank you


    mardi 6 mars 2012 15:44
  • Hi, Malcolm! I haven't installed VS11 before (I mean DP), here is my info:

    Microsoft Visual Studio 11
    Version 11.0.50214.1 BETAREL
    Microsoft .NET Framework
    Version 4.5.50131 BETAREL

    Installed Version: Ultimate

    Architecture and Modeling Tools   04166-115-2600346-58418
    Architecture and Modeling Tools
    Web Tooling Extensions Beta   1.0
    Page Inspector: Tool that offers an efficient way to decompose Web Applications and diagnose front-end issues.
    Web Publishing: Extensions required for Web Publishing for both hosted servers as well as on premise.
    Web Form Templates: Includes the default templates for Web Form Applications.
    Editor Extensions: Includes HTML, CSS, and JS editor extensions that greatly enhance the development experience.

    OS Name Microsoft Windows 7 Professional
    Version 6.1.7601 Service Pack 1 Build 7601
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name ANDREW-PC
    System Manufacturer System manufacturer
    System Model System Product Name
    System Type x64-based PC
    Processor Intel(R) Core(TM) i5 CPU         760  @ 2.80GHz, 2801 Mhz, 4 Core(s), 4 Logical Processor(s)
    BIOS Version/Date American Megatrends Inc. 1504, 14.12.2010
    SMBIOS Version 2.6
    Windows Directory C:\Windows
    System Directory C:\Windows\system32
    Boot Device \Device\HarddiskVolume1
    Locale Russia
    Hardware Abstraction Layer Version = "6.1.7601.17514"
    User Name andrew-PC\andrew
    Time Zone FLE Standard Time
    Installed Physical Memory (RAM) 4,00 GB

    I mainly use Chrome, but you meant IE version?

    mercredi 7 mars 2012 05:59
  • Hi Andrew,

    I think that the Forum "Forum Issues (No product support)" is for any bug reports regarding the forum. So if you cannot edit a post with a browser, you could go to the forum at http://social.microsoft.com/Forums/en-US/reportabug/threads. (It also includes a sticky "Purpose of this forum").

    Just as a small note from my side - I will directly leave the thread again so Malcom2 can further try to support you on your main topic (where I cannot help at all).

    With kind regards,


    mercredi 7 mars 2012 13:49
  • thank you.  will reply as soon as we have more information.

    mercredi 7 mars 2012 19:03
  • Hi Andrew,

    Please look in the IE Options menu, on “General” Tab on internet options, and select the Accessibility setting button. Is the setting for ignore font styles specified on webpages selected?

    jeudi 8 mars 2012 21:31
  • No, I've issued this bug (may I call it so?) on both my PC and laptop, both running Win7(x64 and x32 respectfully). Both of them hadn't changed (or close to) IE settings. Actually, I've used this setting with font ignore and fonts (Segoe UI; Consolas) as a workaround to this problem. When I remove that tick, VS Help falls back to ugly fonts.

    Thanks a lot!

    samedi 10 mars 2012 07:22
  • Today I've done a clean install of Win8 Consumer Preview with VS11 Beta and I'm issuing similar inconvenience:

    samedi 10 mars 2012 10:22
  • Hi Andrew,

    Thank you for the update.  We are drilling into the effect of the RU locale on the ENU Branding Package.  Will let you know the results.

    Thank you,


    lundi 12 mars 2012 19:40
  • Please check on this setting.

    Control Panel -> [search on fonts] ->Change fonts settings->uncheck the box about Hide fonts based on language based

    Please let me know if this affects your font rendering.

    Thank you

    jeudi 5 avril 2012 19:03
  • Thanks for advice, Malcolm, but it seems to have no visible effect.

    vendredi 20 avril 2012 20:52
  • OK, thank you.  We will keep working at it and reply back.
    vendredi 20 avril 2012 20:59
  • I've reported a suggestion regarding this in Connect: https://connect.microsoft.com/VisualStudio/feedback/details/729858/help-viewer-2-0-beta-allow-consolas-to-be-used-as-the-default-font-in-code-section. They marked it as deferred/postponed. Perhaps, it would be fixed in a later public release.

    Additionaly, it doesn't seem torespect IE font settings (plain text font), as it were in Help Viewer 1.0, which make it more annoying as well.

    mardi 24 avril 2012 19:45
  • Thanks for such a suggestion, however, I never use any Visual Studio locale except ENU, as well as my Windows. But due to vague encoding inside some programs, I set non-Unicode locale to Cyrillic.

    Next, you can actually see (upper post) that MS dev team actually provides CSS code to style PRE tag.

    And finally, if you force font ignore, you'll be able to define fonts of VS Help. Proof (PT Sans, Consolas):

    mardi 24 avril 2012 20:37
  • Me neither, I always use English version of Windows and VS. Not sure why you're saying so... :D

    As with my suggestion, I initially thought that Help Viewer would use different HTML renderer other than IE as it doesn't seem to respect IE plain text font settings (which I set to Consolas). And thus, I'm suggesting MS to have Fonts settings on its own so that font in <pre /> could be configured to whatever user choose, just the same as Code Editor in VS. And it means more flexibility for the users.

    But it turns out, after reading this thread, MS (diligently?) overrides <pre /> font and makes Courier/Courier New in the first list instead of Consolas. Also, I think that's why IE plain text font settings is being overriden without user consent.

    Anyway, how to force Help Viewer to use Consolas (or whatever font), as you've shown above?

    mardi 24 avril 2012 21:00
  • I told about my ENU preference as your Connect topic received reply Paul O'Rear who stated that the problem will be solved with language pack. My intention was to say that I won't be satisfied by this solution.

    To enforce font preference: IE > Internet  options > Accessibility > 

    mardi 24 avril 2012 21:05
  • Ah, IC... It seems to me that he misunderstood what I said.

    Thanks, I'll give it a try!

    mardi 24 avril 2012 21:32
  • Hello, Malcolm. I'm very sad to report this issue is still active in VS2012RC@WIN8RP. I did a clean install, Windows is ENU, VS is ENU, non-Unicode locale is Russian, "Hide fonts based on language" is shut down. Now I've switched from F# to JavaScript, so it'd a bit more fun:)

    So, I took my file manager and began digging. After few minutes, I had a folder in my documents, containing two files: index.html and branding.css. First is a Ctrl+S of the page source code and the css comes from C:\ProgramData\Microsoft\HelpLibrary2\Catalogs\VisualStudio11\ContentStore\en-US\VISUALSTUDIO_2011_BRANDING_EN-US.1.mshc

    Let's run IE10:

    Let's change the font:

    Thanks for attention!

    P.S. There also is an issue with VS2012 PRO ENU WEB install involving partial selection. It failed with some error message (yes, I know: they are the most important ones, but I have 246 log files totalling 200MB - 8MB compressed): the VS launched, but help was missing, then ISO recover was unable to resolve, so I've uninstalled VS and did a new installation.

    Also, I was unable to log into my Microsoft Live account during new account setup after Windows installation despite both LAN and wireless connection were established. Gracefully, I was proposed to create a local account. Where should I report that?

    vendredi 1 juin 2012 23:09
  • It's not relevant here, but I'm constantly experiencing bugs like this one after custom chrome was introduced:

    vendredi 1 juin 2012 23:09
  • Dear Andrew! I have exactly the same trouble. In Microsoft Help Viewer 2.0 the "Copy to Clipboard" section suddenly uses Times New Roman. But when I look at the page at  http://msdn.microsoft.com/EN-US/library in my IE the "Copy to Clipboard" section there uses nice default Consolas font. I suspect that html content in Microsoft Help Viewer has several bugs :( Did you find where it could be fixed?
    lundi 11 juin 2012 09:33
  • In my previous post, I've mentioned some workaround (but it works if you don't use IE9 for day to day browsing):

    IE settings. Actually, I've used this setting with font ignore and fonts (Segoe UI; Consolas) as a workaround to this problem. When I remove that tick, VS Help falls back to ugly fonts.

    To enforce font preference: IE > Internet  options > Accessibility > 

    samedi 7 juillet 2012 13:32
  • I still notice this in RC. Will this be fixed in RTM? Is it that hard for VS Help team to change the default font from Courier New to Consolas? Dude, I just can't believe this!
    mercredi 18 juillet 2012 22:24
  • Though it seems to be unimportant but MHV shows text with Times New Roman, not with Courier New. I think Courier could be more appropriate.
    lundi 23 juillet 2012 16:44
  • Have the same issue in Visual Studio 2012 RTM, Microsoft Help Viewer 2.0. Is a fix ready?
    mercredi 19 septembre 2012 14:05
  • Thank you very much. I finally find a way to work around this without affecting my IE experience.

    I wrote a .css file "ie.css" like below:(without this my body font will be "Times New Roman")

    BODY { FONT-FAMILY: "Segoe UI", Verdana, Arial; }
    .codeSnippetContainerCode PRE { FONT-FAMILY: Consolas, Courier, monospace; }
    SPAN.code { FONT-FAMILY: Monospace, Courier New, Courier; }

    Then in "IE > Internet  options > Accessibility ", I checked "Ignore font styles", "Format documents using my style sheet"
    and specified my file ie.css by clicking "browsing" button.

    Now the ugly courier regular will never be seen again in the "Help Viewer 2.0".

    • Modifié sand_cat vendredi 5 octobre 2012 09:37
    vendredi 5 octobre 2012 09:35
  • Thank you very much. I finally find a way to work around this without affecting my IE experience.

    I wrote a .css file "ie.css" like below:(without this my body font will be "Times New Roman")

    Whoa, that is very helpful! The most making sense workaround I've ever found; never thought before it could be possible.

    Excellent! And thank you! :D

    vendredi 5 octobre 2012 10:39