none
(Visual Studio 2008) Application non trouvée dans une action personnalisée UNINSTAL RRS feed

  • Question

  • Bonjour,

    J'ai une action personnalisée la désinstallation qui appel une page Web

     

    Imports System.Net
    Public Class OpenWeb
        Public Sub New()
            MyBase.New()
            'Cet appel est requis par le Concepteur de composants.
            InitializeComponent()
            'Ajoutez le code d'initialisation après l'appel de InitializeComponent
        End Sub
        Public Overrides Sub Uninstall(ByVal savedState As System.Collections.IDictionary)
            Try
                MyBase.Uninstall(savedState)
                Dim wFicProduct As String = My.Application.Info.DirectoryPath & "/FicProduit.txt"  '   Fichier contenant le nom du logiciel
                Dim wProduit As String
                'Microsoft.VisualBasic.MsgBox("Aprés désintallation  RepFic " & wFicProduct)
                Try
                    Using Reader As New Microsoft.VisualBasic.FileIO.TextFieldParser(wFicProduct, System.Text.Encoding.UTF7) ' System.Text.Encoding.UTF7 ?
                        Reader.TextFieldType = Microsoft.VisualBasic.FileIO.FieldType.FixedWidth
                        wProduit = Reader.ReadLine
                        wProduit = Trim(wProduit)
                    End Using
                Catch erreur As Exception
                    'Microsoft.VisualBasic.MsgBox("Non trouvé " & wFicProduct)
                    wProduit = ""
                End Try
                System.Diagnostics.Process.Start("http://www.asorco.fr/pagedesinstal.php?Produit=" & wProduit)
            Catch erreur As Exception
                ''Microsoft.VisualBasic.MsgBox("Uninstall- erreur " & erreur.Message)
            End Try
        End Sub
    End Class

    Elle s'exécute bien, mais si le fichier est retrouvé, (voir le code), la page n'est pas lancée.

    J'ai l'erreur "Application non retrouvée"

    Est-ce le fait d'avoir supprimé Internet Explorer ?

    Je n'ai que Microsoft EDGE comme navigateur.

    Pourtant, quand j'utilise cette instruction dans mes FORM, je n'ais pas d'incident

    Comment faire ?

    Cordialement

    SC


    Cordialement SC

    mercredi 28 septembre 2016 08:02

Réponses

  • Bonjour,

    Je ne vais pas approfondir plus, puisque dés qu'il y a un navigateur autre que Microsoft Edge, la page demandée est bien visualisée

    Les PC avec unique EDGE ne sont pas légion. A Microsoft d'assurer le bon fonctionnement de ses produits

    Cordialement

    SC


    Cordialement SC

    mardi 4 octobre 2016 07:30
  • Bonjour,
    Il semble que cela peut être à cause du navigateur. Vous pouvez tester encore avec un autre navigateur différent d'IE et si le problème persiste vous pouvez le rapporter ici:  EdgeHTML issue tracker.

    Cordialement,
    Nina


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mardi 4 octobre 2016 07:06
    Modérateur

Toutes les réponses

  • Bonjour SC,
    Testez l'application avec un autre navigateur. Merci de partager le résultat.

    Cordialement,
    Nina

    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    jeudi 29 septembre 2016 06:33
    Modérateur
  • Bonjour,

    J'ai installé puis désinstallé sur un PC avec IE

    A ce moment, la page WEB à été retrouvée sous IE

    De mémoire, quand il y avait deux navigateur, une fenêtre vous demandez de choisir

    Il n'y a plus de réaction avec EDGE comme seul navigateur C'est un comble !! 

    Cordialement

    SC


    Cordialement SC

    vendredi 30 septembre 2016 06:11
  • Bonjour,
    Il semble que cela peut être à cause du navigateur. Vous pouvez tester encore avec un autre navigateur différent d'IE et si le problème persiste vous pouvez le rapporter ici:  EdgeHTML issue tracker.

    Cordialement,
    Nina


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mardi 4 octobre 2016 07:06
    Modérateur
  • Bonjour,

    Je ne vais pas approfondir plus, puisque dés qu'il y a un navigateur autre que Microsoft Edge, la page demandée est bien visualisée

    Les PC avec unique EDGE ne sont pas légion. A Microsoft d'assurer le bon fonctionnement de ses produits

    Cordialement

    SC


    Cordialement SC

    mardi 4 octobre 2016 07:30
  • Bonjour SC,

    Merci pour cette information utile. Je marque les deux dernières réponses comme réponses pour fermer la question par rapport à ce qui concerne ce forum. Si vous avez envie vous pouvez signaler le souci auprès des services Microsoft comme j'ai déjà dit.

    Cordialement,
    Nina


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mardi 4 octobre 2016 10:15
    Modérateur