none
active directory et groupe sharepoint RRS feed

  • Question

  • bonsoir
    je viens de m'apercevoirt que j'avais eu la médaille de l'utilisateur .... elle va se transformer en medaille de l'em...... si ça continue mais je vous promets, ...  je cherche vraiment avant de venir vous solliciter   .. ;-))

    Je voudrais , sur la page d'acceuil de mon site sharepoint, afficher OU ne pas afficher un lien en fonction des droits de l'utilisateur connecté. Pour commencer Avec l'admin reseau, nous avons créé un ensemble de groupes dans l'Active Directory.
    J'ai ensuite créé des groupes sharepoint dans lesquels j'ai ajouté ces groupes AD
    ex : le groupe AD "Aquitaine" a été ajouté en tant que groupe, dans le groupe sharepoint "CDG_Aquitaine"
    Dans ce groupe il ya "n" utilisateurs ...
    Cette manip répétée une quinzaine de fois pour les différents secteurs à traiter.

    Partant de là, je voudrais , en arrivant sur la page d'acceuil, dans la barre de navigation rapide (menu gauche) ne voir apparaitre le menu "Ctrl de Gestion", que si le user connecté appartient à l'un des groupes sus cités.
    Pour ça je vais dans "navigation, je créé mon lien "ctrl de gestion" et à audience ciblée, je mets le nom du groupe sharepoint (pas celui de lAD car il n'est pas reconnu) qui contient le groupe AD.
    ex audience ciblée : CDG_Aquitaine.

    Et en fait, sharepoint s'en fout. On dirait qu'il ignore le groupe AD contenu dans le groupe Sharepoint , et mon lien ne s'affiche pas , meme si je reconnecte avec une nouvelle session d'un utilisateur du groupe Aquitaine .
    Par contre si je rajoute, dans le groupe, le nom d'un utilisateur, la ça fonctionne mais alors dans ce cas, je ne vois pas à quoi servirait de travailler par groupe AD s'il faut rajouter "à la main " chaque nouvel utilisateur (et bonjourla maintenance !!!)

    Auriez vous une idée de comment faire pour que les groupes AD soient reellement reconnus ??
    Merci
    Bonne journée à tous
    Alain

    lundi 7 décembre 2009 15:15

Toutes les réponses

  • Ne serait-il pas plus judicieux de redéfinir la sécurité sur la page cible plutôt que de passer par les audiences ? Cela dépend de l'importance des informations contenues dans cette page, mais d'après son nom je pense que ce serait plus adapté. La navigation serait impactée automatiquement.

    Concernant les audiences, en principe votre paramétrage devrait fonctionner. Ce problème semble être connu par Microsoft qui propose un hotfix : http://support.microsoft.com/kb/942819/en-us


    http://blogs.developpeur.org/anouvel
    Merci de valider les réponses qui correspondent à votre problème afin qu'il apparaisse comme résolu.
    lundi 7 décembre 2009 15:51
  • Bonsoir,

    Quelle configuration avez-vous
    SP n° ?

    Cdlt

    EROL
    Pierre Erol GIRAUDY MVP MOSS http://clubmoss2007.org
    lundi 7 décembre 2009 19:43
  • Bonjour à vous

    Arnault, j'ai effectivement adapté la sécurité sur la page cible (le pb c'était l'arborescence car il y a une succesion de reprtoire et sous repertoire donc , passer tous les groupes en lecture seule jusqu'au dernier niveau, qui lui passe en conception / approbation .... en fonction de chaque secteur ... mais ça c'est ok .
    Simplement, mon chef  voudrait ne pas voir apparaitre ce satané lien sur la page d'acceuil si l'utilsisateur connecté ne fait pas partie d'un des secteurs ...

    Pour répondre à votre question Monsieur Erol Giraudy, la configuration est la suivante :
    moss 2007 - framework v3.5 / sur station server 2003 R x64 edition service Pack 2

    Bonne journée à vous et merci
    Alain
    mardi 8 décembre 2009 07:58
  • Si le lien du menu n'est pas autogénéré par SharePoint, on ne peut pas bénéficier du sécurity-trimming.
    Il faudra passer par les audiences pour jouer sur la visibilité des éléments de menu ajoutés manuellement.

    A moins qu'utiliser les éléments de menu autogénérés par SharePoint ne soit envisageable (paramètres du sites, navigation, premières cases à cocher), on en revient donc au problème initial :p

    Je pense qu'Erol voulait savoir quelle version de SharePoint vous avez, pour en déduire le besoin d'appliquer le hotfix des audiences ou non.
    Si vous etes en SP1, le hotfix pourrait corriger le problème.
    Si vous etes en SP2, en principe il est déjà installé (fait partie du SP2).
    http://blogs.developpeur.org/anouvel
    Merci de valider les réponses qui correspondent à votre problème afin qu'il apparaisse comme résolu.
    mardi 8 décembre 2009 13:08
  • oui Arnault, c'est effectivement ce que je pensais concernant le SP2.
    quant aux audiences, je vous confirme que Sharepoint ne reconnait pas le groupe AD à l'interieur du groupe sharepoint. Par contre si je rajoute dans mon groupe sharepoint, un utilisateur qui fait partie du groupe AD (pas necessairemetn d'ailleurs, ça peut être un autre) là, je peux jouer sur cette audience et le lien s'active ou se désactive en fonction.
    Ce que je ne comprend pas bien c'est pourquoi dans l'administration centrale, quand je veux creer une regle pour une audience créée, le systeme ne reconnait pas les groupes qu'on a cree dans l'AD ... cahque fois, je me retrouve avec un 'concordance exacte introuvable"  voir même  " No exact match was found"  ;-)    ... pourtant je fais un copier coller soit du nom du groupe ad , soit du groupe sharepoint mais ça ne passe pas ... Sinon, je pense que je pourrais m'en sortir en utilisant cette voie ...

    Merci
    Alain
    mardi 8 décembre 2009 14:42