none
L'acces au fichier base de données n'est pas autorisé. RRS feed

  • Question

  • Bonjour,

    Je ne suis pas tout à fait sur le bon forum ( personne sur visualbasic 6 ).
    Je viens de me mettre sur vb6 apres qqes années sur vba, j'ai instalé visual basic express 2008 au travail ( xp ) pour l'instant tout va bien, par contre à la maison ( vista ) j'essayes d accéder à la base de données fourni par vb6 ( pour les excercices ) ( C:\Program Files\Microsoft SQL Server Compact Edition\v3.5\Samples\Northwind.sdf ) et un message d'ereur apparait :

    L'acces au fichier base de données n'est pas autorisé.

    Si qq'un à une solution pour que je puisse avancer merci d'avance !!!

    damien
    • Déplacé Gilles TOURREAUModerator samedi 20 juin 2009 08:30 Concerne VB .NET ([Loc]From:Visual Studio - Commentaires et suggestions)
    samedi 8 novembre 2008 13:59

Réponses

  • Bonjour,

     

    2 possibilités :

    - problème d'UAC typique de vista ou de droits d'accès ( voir le précedent post )

    - si vous avez copié votre fichier à partir d'un CD/DVD , il est obligatoirement copié en lecture seule

    retrouvez votre fichier par le poste de travail ou l'explorateur de fichiers

    clic droit sur ce fichier

    dans le menu contextuel, clic sur Propriétés

    decochez la checkbox lecture seulement

     

    Bonne journée

     

    samedi 22 novembre 2008 22:37

Toutes les réponses

  • Bonjour,

     

    Il s'agit peut être d'un problème de droits sur le fichier en question. Essayez de donner tous les droits à votre compte utilisateur sur ce fichier.

     

    Etienne.

    dimanche 9 novembre 2008 15:06
  • Bonjour,

     

    2 possibilités :

    - problème d'UAC typique de vista ou de droits d'accès ( voir le précedent post )

    - si vous avez copié votre fichier à partir d'un CD/DVD , il est obligatoirement copié en lecture seule

    retrouvez votre fichier par le poste de travail ou l'explorateur de fichiers

    clic droit sur ce fichier

    dans le menu contextuel, clic sur Propriétés

    decochez la checkbox lecture seulement

     

    Bonne journée

     

    samedi 22 novembre 2008 22:37
  • Bonjour, je suis désolé de déterrer ce post mais j'ai un problème similaire alors autant ne pas en recréer un.

    J'ai mis mon appli sur un DVD avec un launcher, tout semble marcher mais j'ai le problème pour la base de données : "L'accès au fichier de base de données n'est pas autorisé [1914,File name = ...]"

    J'étais donc bien content de tomber sur votre réponse Papy Normand, je suis allé décochez la checkbox 'lecture seule' mais lorsque j'applique ces paramètres j'ai le message d'erreur suivant: 

    "Une erreur s'est produite en appliquant des attributes au fichier :

    D:\DVD\Database.sdf

    Accès refusé.

    Ignorer/Ignorer tout/ Recommencer/ Annuler "

    Lorsque j'ignore aucune modification n'est effectué. Si quelqu'un a une solution je suis preneur.

    Merci, bonne journée.

    lundi 20 mai 2013 08:38
  • J'avais mal interprété le message  de Papy Normand et il est impossible de modifié les propriétés d"un fichier gravé sur un DVD.

    Du coup j'ai une base de données mais je ne peux pas l'utiliser sur un DVD. Si quelqu'un passe par hasard ici (ce que je n'espère plus trop :p ) et qui saurait comment faire pour utiliser une base de données SQL Server Compact sur un DVD je suis preneur.

    Merci, bonne journée.

    mardi 21 mai 2013 09:45
  • Une base de données SQL Server Compact nécessite une base de données temporaire qui se créer dans le fichier de la base de données existante (ici le DVD en lecture seule donc impossible d'accès). Il faut donc ajouter 2 paramètres :

    “Mode=Read Only” et “Temp Path=<path>” pour que la base temporaire se créer ailleurs.

    Voir ici pour plus de détails : http://www.developpez.net/forums/d1345106/adonet/base-donnees-dvd/#post7298380

    • Proposé comme réponse Stuckly mercredi 22 mai 2013 08:13
    mercredi 22 mai 2013 08:13