none
Sharepoint 2007 - Erreur Script (Appel du débogeur en boucle) dans le navigateur Outlook - Pas dans IE RRS feed

  • Question

  • Bonsoir,
    A l'aide d'un petit script, nous avons développé un prévisualisateur sommaire de document dans nos bibliothèques sharepoint (Via un iframe).
    Lorsque que celui-ci est utilisé dans Internet Explorer, il n'y a aucun problème, le tout fonctionne partout sur notre réseau.
    Certains de nos utilisateurs utilise directement un raccourci dans Outlook, ce qui a pour résultat de charger la page directement dans Outlook.
    Lorsque l'on clique sur le liens du prévisualisateur nous avons à ce moment une fenêtre qui fait appel au débogeur pour un problème et si l'on clique sur non cela boucle.

    <html><head><script src="res://mshtml.dll/objectembed_neutral.js"></script></head><body 
    
    objectSource="http://servintra1:4447/cabinets/ged/CABINET%20RIJ/106RIJ_WG%20Consulting%20S%C3%A0rl/2-DOSSIER_ANNUEL_2007-1
    
    2/DA01_DOCS_CLIENT_ACHATS/006_2007_Bouygues.pdf" onload="ObjectLoad();" leftmargin=0 topmargin=0 scroll=no> <form 
    
    id="objectDestination"></form> </body></html>
    

    Il met le ObjectLoad() en Jaune sans plus d'indication.
    Le plus étrange c'est que ce message d'erreur ne s'affiche que sur deux postes de notre réseau avec IE8 (les autres ont également cette version)

    Pour expliquer un peu le fonctionnement, on a transformer la vue de la bibliothèque de document en doc Xsl (A l'aide de SharePoint Designer), on a implémenté une colonne de liens  pointant vers chaque document dans l'iframe en question (Myframe de son nom) on a enregistré notre modèle. Dans la page on a rajouté un conteneur de code pour insérer le html de l'iframe et cela a fonctionné directement sauf dans 2 Outlook de notre réseau.

    Pourriez-vous m'éclairer sur l'origine de ce problème ? (il est possible que cela vienne de la configuration d'IE mais je ne sais pas par où commencer)

    Merci.

    Cordialement.

    mardi 2 novembre 2010 16:24

Réponses

  • Bonjour,

    Dans les options de Internet Explorer vous allez sur les liens entourés en rouge 

    il faut décocher  -Afficher une notification de chaque erreur

    -Cocher les deux désactiver le débogage des script

    • Marqué comme réponse Alex Petrescu lundi 8 novembre 2010 10:08
    mercredi 3 novembre 2010 14:58

Toutes les réponses