locked
Compatibilité VFP6 / VFP9 / Windows 2008 RRS feed

  • Question

  • Bonjour,

    J'ai installé windows 2008 et je dispose de programmes écrits en VFP6.

    Depuis l'installation de windows 2008, toutes les commandes FOXRUN se plantent. Manifestement le fichier FOXPRO.pif ne serait plus compatible !!!

    Avant de migrer mes programmes sur VFP9, je souhaiterai savoir :

    1°) comment faire fonctionner mes programmes VFP6 contenant des commandes FOXRUN sous Windows 2008 (faut il changer qq chose dans les programmes).

    2°) est-ce que FOXRUN fonctionnerai avec VFP9 sous Windows 2008

     

    Merci pour votre aide

    mercredi 3 novembre 2010 14:16

Toutes les réponses

  • Bonjour Eros,

    J'ai testé VFP6 sur un serveur 2008 : pas de probleme,
    le foxrun.pif n'est qu'un raccourcis evrs l'interpréteur de commandes.

    Ceci du l'utilisation des commandes RUN est un peu obsolete: le mieux est d'utiliser un appel api a shellexecute.
    (c'est une ligne, des exemples sur www.atoutfox.org)

    Quel est le type de programmes que tu veux lancer ?
    programme windows ?
    fichier BAT ou CMD contenant des lignes de commandes ?

    Cordialement

    Francis


    VFP MVP
    mercredi 10 novembre 2010 16:54