locked
webbrowser et signe € RRS feed

  • Question

  • Bonjour,

    je suis en train d'importer un flux json, et dans ce flux, j'ai le symbole € qui apparait (il n'a pas le format "&euro ;"). Je veux afficher ma chaine dans un webbrowser, Après avoir construit mon document html comme je veux, les à é è s'affichent bien, par contre le € s'affiche comme une moitié de rectangle coupé en diagonal. Si qqun a une idée, je suis preneur

    Merci d'avance,

    Fabrice

    PS : j'emploie actuellement un Replace("€", "€"), mais ce n'est pas très "joli"



    samedi 15 septembre 2012 10:21

Réponses

  • En fait ton flux en est Windows-1252 et le browser essaie de lire du  ISO-8859-1(ou inversement)

    voir ici, à toi de faire les replace

    http://fr.wikipedia.org/wiki/Windows-1252


    S'il vous plaît n'oublier pas de marquer la ou les réponses qui aident à résoudre votre problème. Pour que la discussion puisse être marquée comme résolue


    lundi 17 septembre 2012 13:13
    Modérateur

Toutes les réponses

  • Hello, j'ai jamais codé dans ce domaine mais tu as regardé la piste du Encoding ? (... encoding = Encoding.UTF8, Soit récupérer celui du flux et à défaut l'imposer avec d'éventuel traitement de string..) ? (et je présume que c'est pas toi qui contrôle le coté service ?)

    Toss.net

    lundi 17 septembre 2012 06:28
  • En fait ton flux en est Windows-1252 et le browser essaie de lire du  ISO-8859-1(ou inversement)

    voir ici, à toi de faire les replace

    http://fr.wikipedia.org/wiki/Windows-1252


    S'il vous plaît n'oublier pas de marquer la ou les réponses qui aident à résoudre votre problème. Pour que la discussion puisse être marquée comme résolue


    lundi 17 septembre 2012 13:13
    Modérateur