locked
Network Adapter & Windows XP Embedded RRS feed

  • Question

  • Bonjour,

     

    Je viens juste d'arriver dans le monde de XPe.

     

    J'arrive bien a generer une image sur ma clef USB, et a booter dessus.

     

    Seulement, la carte reseau n'est pas reconnue. pourtant j'ai bien ajouté le component correspondant. Les fichiers Drivers sont bien au bon endroit (a la meme place que sur mon poste). Et je n'arrive pas a créer le lien entre la carte reseau et le Driver.

     

    J'ai bien essayé d'ajouter le device manager, la du coup, je vois mes peripheriques. Et effectivement la carte reseau est avec un gros point d'interrogation Jaune.

     

    Que faut-il que je fasse ?

     

    Merci pour vos reponses.

     

    A+,

    Sebastien

    jeudi 19 juillet 2007 14:53

Réponses

  • Bonjour,

     

    OK,  je note.

     

    Ca y est, c'est bon, ma carte reseau est operationelle.

     

    Merci en tout cas !! :-)

     

    A bientot.

     

    Sebastien PELLE

    lundi 23 juillet 2007 07:34

Toutes les réponses

  • Bonjour,

     

    La résolution de ce type de problème passe par plusieurs étapes de vérification :

    0/ récupérer l'identifiant de la carte dans le device manager (PCI_VIDxxxx...)

    1/ est-ce-que l'identifiant de la carte réseau est bien dans le fichier PMQ généré par TAP ?

    2/ Est-ce-que l'identifiant de la carte réseau est bien dans le .INF du pilote ?

    3/ Avez-vous fait un composant SLD avec le pilote ou bien c'est un pilote du catalogue de base ?

    4/ Avez-vous testé l'installation du pilote sur votre cible XPe via le device manager (ou bien le setup.exe s'il exise)?

     

    Cette procédure permet de vérifier que le pilote que vous avez mis sous TDesigner est bien le bon, sinon il faut en faire un avec CDesigner ou bien faire une installation post-FBA avant de cloner l'image.

     

    Cordialement,

     

    Thierry Joubert - THEORIS

    vendredi 20 juillet 2007 08:11
  • Hello, Hello,

     

    Je viens de voir votre post. Merci pour la reponse.

     

    La résolution de ce type de problème passe par plusieurs étapes de vérification :

    0/ récupérer l'identifiant de la carte dans le device manager (PCI_VIDxxxx...)

    >> OK

    1/ est-ce-que l'identifiant de la carte réseau est bien dans le fichier PMQ généré par TAP ?

    >> Oui, Il y est

    2/ Est-ce-que l'identifiant de la carte réseau est bien dans le .INF du pilote ?

    >> A priori oui.

    3/ Avez-vous fait un composant SLD avec le pilote ou bien c'est un pilote du catalogue de base ?

    >> J'ai pris un composant du catalog.

    4/ Avez-vous testé l'installation du pilote sur votre cible XPe via le device manager (ou bien le setup.exe s'il exise)?

    >> Oui, mais il ne faisait rien du tout. J'avais bien un bout d'interface graphique, mais il s'arretait en cour de route sans message d'erreur, rien.

     

    Depuis hier, j'ai browsé un peu internet et en recoupant qqs infos, je em suis penché effectivement sur les fichiers INF et l'import ds Component Designer.

     

    J'ai donc importé mon fichier Pilote dans Component Designer. de là, il m'a créé un fichier SLD avec moult devices portant pour beaucoup le meme nom. J'ai ouvert le fichier et cherché la DeivceID de mon fichier PMD, et renommé mon component de maniere a pouvoir le reconnaitre. J'ai ensuite modifié le SrcPath de mes fichiers pilote au sein de mon Component (il etait vide).

     

    Bon, là l'OS est en train de builder. On verra bien si ca change qqch.

     

    N'y a t'il aucun endroit sur internet ou ailleurs ou tout ceci est expliqué clairement ?

     

    Merci en tout cas.

    Cordialement,

    Sebastien PELLE

    vendredi 20 juillet 2007 10:43
  • Bonjour,

     

    La documentation de référence reste le MSDN, http://msdn2.microsoft.com/en-us/library/ms950428.aspx (la pédagogique s'est améliorée avec les tutoriaux).

     

    Il existe une bonne référence sur le web: www.seanliming.com Sean Liming est un des spécialistes de la technologie XPe et c'est lui qui a écrit les meilleurs ouvrages sur le sujet.

     

    Bonne lecture!

     

    Thierry Joubert - THEORIS

    samedi 21 juillet 2007 09:35
  • Bonjour,

     

    OK,  je note.

     

    Ca y est, c'est bon, ma carte reseau est operationelle.

     

    Merci en tout cas !! :-)

     

    A bientot.

     

    Sebastien PELLE

    lundi 23 juillet 2007 07:34