none
L'assembly n'est pas spécifié correctement comme fichier RRS feed

  • Discussion générale

  • Bonjour,

    Dans mon appli WinForm, sous VS 2017 Community, j'utilise 2 DLL placées dans un répertoire DLL de ma solution.

    Elles sont référencées dans la solution et fonctionnent apparemment correctement. Cependant, VS signale deux Warnings, un pour chacune des DLL : "L'assembly xyz n'est pas spécifié correctement comme fichier."

    Sans fournir la moindre explication ni solution mais renvoyant au Chanel 9 MS Build qui n'apporte pas lui non plus de solution...

    Quelqu'un de mieux informé que lui en aurait-il une ?

    Merci d'avance


    Alain


    samedi 7 octobre 2017 20:21

Toutes les réponses

  • Bonjour,

    Désolé pour la réponse tardive, mais ayant eu le même soucis et étant tombée sur votre post sans réponse... je partage donc la solution que j'ai trouvé ^^ Mieux vaut tard que jamais, cela servira peut etre à d'autres

    Solution testée :

    - Cliquer sur la DLL en question

    - En bas à droite dans "Propriété" (Ou clique droit sur la DLL, puis cliquer sur "Propriété") et mettre

    Action de génération : Aucune

    Copier dans le répertoire de sortie : Toujours copier

    Régénérer le projet,et normalement le warning disparaît.


    lundi 20 août 2018 14:13
  • Bonjour Aurélie G,

    Merci de votre réponse. En effet une réponse, même tardive, vaut toujours mieux que pas de réponse.

    Mais aujourd'hui, sous VS 15.8.1, et même sur des mises à jour précédentes, le problème a disparu. En fait je ne sais plus, maintenant, si j'avais trouvé une solution ou si VS a été corrigé.

    Mais je note votre solution, au cas où !

    Bien cordialement


    Alain

    lundi 20 août 2018 16:26