none
[MOSS 2007] Outlook WebPart ??? RRS feed

  • Question

  •  

    Bonjour !

     

    J'utilise les outlook web part et mon problème est qu'il faut entrer l'adresse e-mail dans les paramètres de la webpart. Donc si quelqu'un d'autre se connecte sur le portail, il accès en fait à ma boite e-mail !!

     

    Comment remédiez à ca ?

     

    Existe-t-il des variables d'environnement (comme le ME ou le TODAY) pour l'adresse e-mail et peut-on l'utiliser dans les web part outlook ??

     

    Merci

     

    mardi 8 mai 2007 12:07

Toutes les réponses

  • Bonjour

     

    Si ce sont les webparts fournies en standard avec MOSS, il ne faut renseigner que l'adresse de votre serveur de messagerie (https://exchange par exemple) et le nom de la boîte au lettre (Inbox par exemple).

     

    mardi 8 mai 2007 15:03
  •  

    Merci pour votre réponse.

     

    Oui ce sont les webpart de base fournit avec MOSS.

     

    Je vous montre une capture d'écran : http://users.skynet.be/fa842892/Screen.JPG

     

    La webPart calendrier ici fonctionne car j'ai mis mon adresse Nom.Prenom@societe.be

     

    Le problème est que de cette façon, tous les utilisateurs se connecteront sur ma boite et non sur la leur car les webPart sont ici partagée (je ne veux pas demander à chacun de mes users d'ajouter une webpart personnelle et de la configurer).

     

    Y a-t-il un moyen pour que ce champs "Boite" varie en fonction de la personne ? Existe-t-il des variables d'environnements pour l'e-mail ?

    mercredi 9 mai 2007 06:42
  • Personne ne saurait si cela est possible ???
    lundi 14 mai 2007 06:52
  • Apparement je pense que ce n'est pas possible directement par l'interface web de MOSS mais via l'api ( que je maitrise pas lol )sûrement !; la seule chose qu'on peut faire c'est activé l'Audiences ciblées pour la Webpart, mais ce là va seuelment empecher les autres à acceder à ta boite à lettre.

    Donc, il faut chq fois parametrer pour chq utilisateur sa propre messagerie !!

    lundi 14 mai 2007 09:02
  • N'avez vous pas également des problèmes d'authentification ?

    Tout comme vous, Lady Najla, j'aimerais pouvoir utiliser une web part OWA qui soit réellement "user-friendly". Les 2 solutions actuelles que je vois sont :
    1) les web part "OWA" : comme vous l'avez dit, il semblerait qu'il faille renseigner en plus du serveur, le nom de l'utilisateur (ce qui peut poser des soucis pour la personnalisation)
    2) la web part de "Visionneuse de pages" : en indiquant l'adresse d'OWA (on se retrouve avec un environnement trop riche)
    => Dans les 2 cas néanmoins, il faut constamment que je fournisse utilisateur & mot de passe. Et cela pose réellement des problèmes d'ergonomie !

    S'il n'est pas possible d'avoir une web part "spéciale" qui puisse automatiquement récupérer les courriers de l'utilisateur courant ; il aurait au moins été préférable d'avoir une Web Part personnalisable que chaque utilisateur peut/doit configurer (et 1 fois seulement) pour ne pas avoir à entrer constamment un login/mdp...
    Websphere Portal d'IBM le fait avec ses portlets PIM, pourquoi pas SharePoint ?

    Une dernière chose, pourquoi n'ai-je pas droit à tous les Web Part en fonction des sites ??
    Le seul endroit pour le moment où je peux rajouter les web parts OWA est lorsque je suis dans MySite ! Et une fois dans MySite, je n'accède plus à la web parts de Visionneuse de pages !
    A n'y rien comprendre...
    lundi 14 mai 2007 18:44
  • Je n'ai toujours rien trouvé pour utiliser les outlook webpart partagées !

    Alors j'ai abandonné et j'ai seulement créé un lien vers mon serveur exchange pour ne pas devoir demander à chaque utilisateur (+- 200) d'aller éditer les paramètres des webpart !!

    Voila Wink
    vendredi 18 mai 2007 12:06
  • Je reviens à la charge ! Stick out tongue

     

    Cette histoire m'a travaillé, je trouve la webpart telle quelle complètement inutile. Et je suis finalement tombé sur ce post : http://spsfactory.blogspot.com/2005/12/how-to-configure-your-myinbox-webpart.html

     

    Le problème, c'est qu'on est bon pour créer une webpart qui elle même appellera la webpart avec les bons paramètres. Il semblerait que ce soit la seule utilisation possible, hors spécification de la boîte aux lettres.

     

    En espérant que ca vous aide.

     

    PS: on sent bien que ces webparts ont été réalisées pour les MySites qd même...

    vendredi 18 mai 2007 14:45
  • Un lien tès intéressant Gat, merci !

    Cela dit, j'ai tout de même l'impression que ceci ne résoud pas le problème d'authentification, n'est-ce pas ?
    Vu que SharePoint est un portail, et que l''utilisateur doit déjà s'y authentifier, ne pourrait-on pas le dispenser de le faire lors de la connexion à un Web Part OWA ?

    A vrai dire, je serais même plus intéressé par une méthode qui puisse conserver les mots de passe sur chaque Web Part OWA, quitte à avoir à demander à chaque utilisateur de les configurer 1 (seule) fois... Oui, un peu comme le client Outlook.
    Auriez vous des pistes ?
    vendredi 18 mai 2007 18:44
  • Vous utilisez l'authentification  intégrée non ?

     

    Vous ne devriez pas avoir à vous identifier sur le portail ni sur la WP OWA. Au besoin, testez en mettant les 2 sites en "Local Intranet" si ce n'est pas déjà le cas.

    dimanche 20 mai 2007 09:32
  • En fait j'utilise de l'FBA (sur AD) ; mais vous aviez raison... il semblerait que sur une des plateformes de tests, j'ai omis d'ajouter le serveur OWA dans la liste des sites intranet !

    D'où une autre question soulevée :
    => Existe t-il un moyen qui m'éviterait de configurer manuellement chacun des postes de mon entreprise pour que cette liste soit à jour ?
    lundi 21 mai 2007 19:22