none
Développeur .NET (c#,vb,ASP,Silverlight,Service WCF) RRS feed

  • Question

  • je veux déployer mon application silverlight

    j'ai installé SERVEUR IIS

    j'ai créer un site au niveau gestionnaire des services internet IIS

    j'ai coriger les avertissemnt aprés le test

    j'ai ajouter pools application ,et jai changé la version du .NET FRAMWORK EN version 4

    j'ai activé l'éxloration du répertoire

    Au niveau de mon application , j'ai accédé au fichier ServiceReferences.ClientConfig et j'ai changé l'url du service en http://192.168.1.108:70/Service1.svc

    j'ai publier mon site en formats : Systéme de fichier

    j'ai accédé a mon site par le navigateur FIRFOX (ci-joint)

    le service wcf est bien configur

    j'ai un problème avec le fichier web.config  , et je ne sais pas ce que  dois je faire :


    quand je click sur web.config

     j trouve k'erreur suivant

    <fieldset><legend>Résumé de l'erreur</legend>

    Erreur HTTP 404.8 - Not Found

    Le module de filtrage des demandes est configuré de manière à refuser un chemin d'accès dans l'URL contenant une section hiddenSegment.

    </fieldset>
    <fieldset><legend>Informations supplémentaires sur l'erreur</legend>
    Module RequestFilteringModule
    Notification BeginRequest
    Gestionnaire StaticFile
    Code d'erreur 0x00000000
    URL demandée http://192.168.1.108:70/Web.config
    Chemin d'accès physique C:\Site1\Web.config
    Méthode d'ouverture de session Pas encore déterminé
    Session utilisateur Pas encore déterminé
    </fieldset>
    <fieldset><legend>Causes les plus probables :</legend>
    • Le filtrage des demandes est configuré pour le serveur Web et contient une section hiddenSegments qui permet à l'administrateur du serveur de refuser l'accès à des répertoires spécifiques.
    </fieldset>
    <fieldset><legend>Essayez les choses suivantes :</legend>
    • Vérifiez les paramètres configuration/system.webServer/security/requestFiltering/hiddenSegments dans les fichiers applicationhost.config ou web.config.
    </fieldset>


    samedi 28 mars 2015 12:34

Réponses

  • Bonjour,

    Dans les options "Filtrage des demandes" de votre site dans IIS Manager, avez-vous vérifié la liste des segments masqués ?

    Dans même dans votre fichier web.config, vérifiez que vous n'avez pas de balise "configuration/system.webServer/security/requestFiltering/hiddenSegments" pouvant bloquer vos URLs.

    Cordialement,


    Yan Grenier

    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont répondues à votre question, et de noter les réponses que vous avez trouvé utiles.


    samedi 28 mars 2015 13:18