none
Remote Debugger sous VS 2008 RRS feed

  • Question

  • Bonjour,

    J'ai un petit soucis avec le Remote Debugger.
    Je développe un soft sous VS 2008 sur une machine 32bits. L'architecture générale se compose d'une IHM, d'un site IIS pour accéder aux services WCF et d'une base SQL Server 2008.
    Le problème c'est que mes services et ma base SQL se trouvent sur un windows server 2008.
    Tout se passe bien en exécution mais si je veux débugger avec le remote debugger de VS 2008 (32 bits) sur mon poste (la ou j'exécute l'IHM), celui qui se trouve sur la machine serveur ne répond pas.
    Sur le serveur, le remote debugger est bien configuré en "No Authentifcation" avec "Allow any user to debug". Remote affiche bien que je me suis connecté mais sur VS sur mon poste j'ai une erreur. Il me dit que soit remote debugger n'est pas lancé, soit il est lancé avec un utilisateur différent.

    Précisions :
    - je ne peux pas créer d'utilisateur sur le serveur distant sinon les 200 développeurs devront avoir chacun un compte sur cette machine
    - cette configuration fonctionne parfaitement avec un serveur sous windows serveur 2003

    Je pense à un soucis de débogage mixte 32-64 bits mais évidemment je ne peux pas en être sur et je ne trouve pas de solution...

    En éspérant avoir été clair, merci de votre réponse!
    lundi 5 octobre 2009 09:33

Toutes les réponses

  • Bonjour,

    j'ai eu plusieurs fois des soucis d'authentication avec le Remote Debug... et assez souvent, ça a été parce que le Serveur n'arrivait pas à rappeler le Client alors que j'avais passé pas mal de temps à vérifier le chemin inverse.
    Essaie donc de créer sur le poste client un compte correspondant à celui sur lequel s'exécute la partie serveur.

    Bonne chance,
    Alain
    vendredi 9 octobre 2009 09:06
  • Bonjour,

    Merci de ta réponse mais en fait je ne peux pas faire comme ça. En fait si je crée un compte sur le poste client, ie le poste de dev, les autres developpeurs devront faire pareil. De plus, étant donné que notre serveur TFS est en activedirectory, cela signifierai que nous ferions des extractions/archivage avec ce compte communs à tous les développeurs.

    Ce n'est donc pas envisageable...

    Merci quand meme de ta réponse,
    David.
    vendredi 9 octobre 2009 09:27