none
Encodage de caractères avec fichier include.inc RRS feed

  • Question

  • Bonjour,

    dans un sous site web "admin" (ex: http://site/admin), si j'utilise un fichier include dans ce site pour ouvrir une connexion à une BDD Access, ex :

    <!--#INCLUDE VIRTUAL="/admin/include/connexion.inc"-->

    Les caratères accentués de ma base sont déformés

    ex : Compte générique

    Si j'utilise le include "identique" à celui du site racine (http://web)

    <!--#INCLUDE VIRTUAL="/include/connexion.inc"-->

    les caractères sont OK

    ex : Compte générique

    Avez-vous une idée ?

    Merci

    Nicolas


    jeudi 2 février 2012 09:47

Réponses

  • [RESOLU]

    Assez difficile à trouver.

    En ouvrant chaque fichier include.inc avec Notepad++, certains étaient en ANSI, et ceux qui plantaient en UTF8.

    Le serveur Web en les lisant devait automatiquement basculler en UTF8 en parcourant la base Access et perdait ses petits avec l'encodage réel de la page .asp (que ce soit en windows-1252 ou UTF8)

    La convertion avec Notepad++ en ANSI (encodage -> convertir en ANSI) des fichiers inclus a résolu le problème

    (Merci à Aurélien, mon ancien collègue, pour la trouvaille)

    Nicolas

    vendredi 3 février 2012 16:53

Toutes les réponses

  • Bonjour,

    Quelle technologie utilisez vous ? ASP .NET ? ASP ? PHP ?

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte .NET/Consultant/Formateur chez Winwise
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5
    jeudi 2 février 2012 12:47
    Modérateur
  • Bonjour,

     

    Vous pouvez regarder du coté de l'encodage indiqué dans votre html rendu au navigateur.

    Si c'est la cas, ajouter ou modifier la balise <meta> dans la balise <header> de votre fichier pour indiquer un encodage UTF-8 :

     

     <head>
          <meta content=\"text/html; charset=utf-8\" http-equiv=\"Content-Type\" />
    </head>
    


     

    Cordialement.


    jeudi 2 février 2012 14:36
    Auteur de réponse
  • Bonjour,

     

    Avez vous pu résoudre votre problème ?

     

    Si ce n'est pas le cas, merci de répondre à la question de Gilles afin que l'on puisse vous donner d'autres orientations.

     

    Cordialement.

    vendredi 3 février 2012 09:29
    Auteur de réponse
  • Bonjour,

    Je fais une réponse commune

    Pour Gilles Tourreau :

    Je suis en ASP / IIS7 64bits avec option "activer les applications 32 bits" pour utiliser le provider

    "Microsoft.Jet.OLEDB.4.0"

    Pour Ould Mourad

    J'utilise sur mes 2 pages principales (celle qui fonctionne et l'autre) l'encodage :

    <meta http-equiv="Content-Language" content="fr">
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

    J'ai aussi testé en UTF8 sans succès

    Nicolas

    vendredi 3 février 2012 10:08
  • [RESOLU]

    Assez difficile à trouver.

    En ouvrant chaque fichier include.inc avec Notepad++, certains étaient en ANSI, et ceux qui plantaient en UTF8.

    Le serveur Web en les lisant devait automatiquement basculler en UTF8 en parcourant la base Access et perdait ses petits avec l'encodage réel de la page .asp (que ce soit en windows-1252 ou UTF8)

    La convertion avec Notepad++ en ANSI (encodage -> convertir en ANSI) des fichiers inclus a résolu le problème

    (Merci à Aurélien, mon ancien collègue, pour la trouvaille)

    Nicolas

    vendredi 3 février 2012 16:53