none
Autoriser les champs vides dans les champs d'un formulaire sharepoint designer 2010 RRS feed

  • Discussion générale

  • Bonjour,

    J'ai créé un flux de travail dans SharePoint Designer 2010 dans lequel j'ai ajouté l'action:

    Assigner un formulaire à des utilisateurs.

    Le formulaires contient un champ que je veux que son utilisateur le remplisse et ne le laisse pas vide. Pour cela, pour ce champ j'ai décoché la case autoriser les champs vides.

    Quand l'utilisateur reçois le formulaire, il voit une étoile rouge devant le titre de ce champ, mais il réussi à marquer cette tâche comme achevée malgrès qu'il laisse la case de ce champ vide.

    Ma question est: quand on décoche la case Autoriser les champs vides pour un champ dans SharePoint Designer cela veut dire que l'utilisateur va voir qu'il doit remplir ce champ sans que cela l'empêche de marquer la tâche comme achevée? quel est alors l'utilité d'autoriser ou non les champs vides?

    Merci.

    mardi 11 septembre 2012 16:35

Toutes les réponses

  • Bonjour naima,

    En toute logique, l'option "autoriser les champs vide" quand elle est décochée au submit vérifiera que les champs ne sont pas vide sinon le formulaire n'est pas submit.

    Etrange donc que cela ne marche pas chez toi.

    Peux tu nous donner plus de détail sur ton formulaire? As tu fait le formulaire uniquement via le designer?

    As tu mis du code perso dedans?

    Sinon l'autre solution est le JS qui te permettra d'activer ou désactivé le bouton envoyer suivant si les champs sont remplit...


    Site du Groupe AFG
    viadeotwitter

    vendredi 21 septembre 2012 12:38
  • Bonjour Valentin,

    J'ai fait le formulaire juste avec designer. Ça va me remdre malada cette histoire.

    Ce qui m'étonne plus c'est qu'il marque le champs pour le quel j'ai décoché la case autoriser les champs vides d'une étoile rouge mais si je laisse le champ vide il enregistre le document comme même.

    vendredi 21 septembre 2012 13:04
  • Autre chose Valentin, si j'essaie de rendre les champs obligatoires directement dans les colonnes de la liste des tâches, quand j'essai d'enregistrer, SPD me renvoie le message

    Impossible d'enregistrer les modifications du champ sur le serveur. Impossible de modifier l'attribut

    ‟Hidden”  pour ce champ.

    Merci Valentin

    vendredi 21 septembre 2012 13:15