locked
Attention requise après téléchargement de MON application RRS feed

  • Question

  • Bonjour à tous

    Ouf, j'ai terminé le développement de mon application pour Windows Phone. L'application a passé le test de certification avec succès et elle a été publiée mais cachée du store pour que je puisse faire des essais et finaliser le code.

    Malheureusement après le téléchargement depuis le store j'ai un message "Attention requise" et le code erreur 80073cf6. Je pensais que cela venait de mon téléphone mais même après un reset total de ce dernier le problème perdure. J'ai également essayé avec un autre téléphone même soucis.

    J'ai peut-être raté quelque chose dans l'écriture du code mais vu qu'elle fonctionne sur mon téléphone lorsque je l'a charge avec VS2015, je suis perplexe et une petite aide serait appréciée.

    Bien cordialement
    lundi 29 février 2016 11:14

Réponses

  • C'est fait mon application se télécharge à présent.

    Le problème venait de l'absence du splashscreen du dossier Assets. Comme je ne m'en sers pas je l'ai supprimé du dossier mais pas l'accès à partir du appxmanifest. En supprimant les deux plus de problèmes avec le store.

    Par la même occasion j'ai résolu l'erreur" Une ressource de communication spécifiée (port) est déjà utilisée par une autre application".

    Là aussi cela venait de l'absence du splashscreen de mon dossier Assets mais pas seulement. J'ai modifié l'Identity Name de appxmanifest par celle fournit par le store (application silverlight oblige) du coup à chaque après chaque compile en mode Release l'erreur apparaissait. Pour l'éviter j'ai remis l'Identity Name créée par défaut lors de la création du projets, que je remplace uniquement lors de la publication.

    Merci à tous de votre aide.

    • Marqué comme réponse AF1962 mardi 1 mars 2016 16:59
    mardi 1 mars 2016 16:59

Toutes les réponses

  • Bonjour,

    Depuis combien de temps votre application a passé la certification ?

    Est-elle visible depuis le store ?

    Il s'agit peut être d'un problème temporaire entre le moment de la validation et le moment où l'application est effectivement disponible sur le store (j'ai déjà eu des petits soucis similaire, il fallait juste attendre la mise à jour du store).

    Avez vous essayer de télécharger votre application en passant par le store de l'emulateur Windows Phone ?

    Cordialement,

    Mathieu


    Mathieu Notin

    lundi 29 février 2016 13:23
  • C'est quelle appli pour que l'on teste ?

    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    lundi 29 février 2016 14:13
  • Bonjour.

    Alors dans l'ordre :

    Elle est validée depuis 24 h environ et peut être téléchargée apparemment sans problème.

    L'application n'est pas visible directement dans le store mais depuis une URL. Il s'agit d'étudier son comportement en condition réel avant de la rendre public et d'avoir des retours de beta testeurs.

    L'adresse est

    http://windowsphone.com/s?appid=e26b1609-3cd0-405f-ae03-b3e4fe022f25

    Cordialement

    lundi 29 février 2016 14:24
  • J'ai aussi la même erreur.

    Vous avez compilé pour Any CPU ?


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    lundi 29 février 2016 14:30
  • J'ai un doute à ce sujet, je crois que c'est compilé en Release-Arm.

    D'ailleurs au sujet de la compilation, chaque fois que je compile en mode Release pour tester la certification, il n'est plus possible de déployer l'application sur mon téléphone. J'ai toujours le même message d'erreur

    " Une ressource de communication spécifiée (port) est déjà utilisée par une autre application" je bute sur ce problème depuis des mois.

    Toutes les astuces trouvées sur internet sont restées vaines. J'avais envisagé de passer en windows 10 pro pour développer directement sur émulateur sans passer à chaque fois par mon téléphone, mais si j'ai toujours ce problème cela n'a aucun intérêt.

    Cordialement.

    PS : je vais recompiler en mode AnyCpu et relancer une soumission pour publication.

    lundi 29 février 2016 14:54
  • Si il ne marche pas sur votre téléphone (ce qui est la bonne approche), il ne risque pas de marcher via le store.

    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    lundi 29 février 2016 14:58
  • C'est fait mon application se télécharge à présent.

    Le problème venait de l'absence du splashscreen du dossier Assets. Comme je ne m'en sers pas je l'ai supprimé du dossier mais pas l'accès à partir du appxmanifest. En supprimant les deux plus de problèmes avec le store.

    Par la même occasion j'ai résolu l'erreur" Une ressource de communication spécifiée (port) est déjà utilisée par une autre application".

    Là aussi cela venait de l'absence du splashscreen de mon dossier Assets mais pas seulement. J'ai modifié l'Identity Name de appxmanifest par celle fournit par le store (application silverlight oblige) du coup à chaque après chaque compile en mode Release l'erreur apparaissait. Pour l'éviter j'ai remis l'Identity Name créée par défaut lors de la création du projets, que je remplace uniquement lors de la publication.

    Merci à tous de votre aide.

    • Marqué comme réponse AF1962 mardi 1 mars 2016 16:59
    mardi 1 mars 2016 16:59