none
TF400813 lors du lancement d'un agent de Build sur TFS 2015 RRS feed

  • Discussion générale

  • Bonjour,

    Tout d'abord, je tiens à m'excuser si je n'ai pas écrit dans la bonne catégorie. J'ai cherché et je n'ai pas trouvé TFS donc je mets cette question sur Development Web.

    J'ai Visual Studio 2015 et TFS 2015 installés en local sur ma machine (à des fins de tests et de playground). Et ça marche bien. Avec mon compte local (lié à mon Live ID), je peux me connecter sans problème à la interface web. J'ai bien pu lié mon VS à mon TFS, je navigue dans mes branches/commits. Tout marche bien et Visual Studio est bien relié à TFS. 

    Maintenant, j'ai voulu installé un agent de build. J'ai suivi la démarche présentée ici : https://www.visualstudio.com/en-us/docs/build/actions/agents/v1-windows . Je lance ma console en admin, je lance le ConfigureAgent.cmd. Il me demande mes infos d'authentification, je les lui donne. C'est le même que lorsque j'ai lié mon VS à mon TFS et les mêmes lorsque j'essaie de me connecter aux sites web TFS. C'est le compte admin du TFS donc il a bien le droit de gérer les pools d'agents et autre. Je continue mon install, je le crée en interactif ou en service (j'ai essayé les deux plusieurs fois). La configuration est finie avec succès. Je vais sur mon pool d'agent, je le vois bien, il est juste inactif (si je vais sur les services, si je l'ai installé comme tel, je le vois bien en cours d'exécution). Je veux alors lancer le RunAgent.cmd pour qu'il ne soit plus inactif et là malheur:

    Agent: Démarrage en cours
    Authentification auprès du serveur http://{mon server}:8080/tfs
    TF400813: ressource non disponible pour l'accès anonyme. L'authentification client est requise.

    Pourtant, je lui ai fourni tous ce qu'il faut pour se connecter lors de la configuration. Je ne comprends pas. J'ai cherché sur le net et il semble que je ne sois pas le seul à avoir le problème. J'ai vu cette page du support : https://support.microsoft.com/fr-ma/help/2892152/client-authentication-required-error-message-after-you-upgrade-from-p j'ai essayé mais non, mon compte est bien lié à mon VS, je n'ai pas de problème avec ça. Donc je ne sais pas d'où ça peut venir. 

    Peut-être vos avis éclairés seront me guider.

    samedi 8 juillet 2017 16:08