locked
SharePoint 2010 : Actions du site: Nouvelle Page RRS feed

  • Question

  • Je détecte un effet indésirable sur les sites & features de SharePoint 2010, l'option Nouvelle Page (vers la bibliothèque Pages de site) disparait selon les sites ou sous-sites versus le modèle utilisé à la base pour créer le site. Même si par apprès nous activons les mêmes features sur ces différents sites, le résultats n'est pas identique....

    Cet effet arrive seulement pour les sites créés à partir d'un modèle différent de "Site d'équipe".

    Exemple:

    [Site1]

    Créer un nouveau site à partir du modèle site d'équipe. Activé la "Publication SharePoint Server". Résultat : vous aurez accès au à l'option "nouvelle page" dans le menu des actions de site (en haut à gauche).

    [Sous site de Site1]

    Enfin, créer un nouveau sous site à ce site avec un modèle de base "Site Vide" , activé le "Publication SharePoint Server" et la feature Wiki (Page d’accueil Wiki) afin de pouvoir utiliser l'option "Nouvelle Page" qui vous permet de créer rapidement du contenu Wiki, vous perdez systhématiquement cette option dans le menu actions et devez passer par créer "Autres options".

    Pourtant, sur le site supérieur qui , à la base a été créé sur le modèle "Site d'équipe", possèdent les mêmes features actives...

    Le but est de rester pointé sur la bibliothèque de pages "Pages du site" et non pas "Pages", et surtout que le lien "Nouvelle page" s'affiche en tout temps dans les options d'actions du site!

    J'ai mis une verrue dans la masterpage utilisé sur l'ensemble de l'intranet en traficant du CSS et le control SharePoint:FeatureMenuTemplate

    afin de gérer l'apparition de l'option "Nouvelle page" en tout temps mais ce n'est pas propre comme solution.

    Officieusement il s'agit d'un bug chez Microsoft, mais je n'ai pas les cartes internes pour l'officialiser... ;o)

    Si vous avez des explications complètes, je suis preneur!

    cheers!


    Maxime Ouellet MCTS WSS Development




    jeudi 21 février 2013 15:03

Réponses

  • A priori vous n'utiliser pas les mêmes modèles de site et donc par définition, ils n'ont pas le même comportement ce qui me semble logique.



    kevin.trelohan@gmail.com http://kevintrelohan.blogspot.com/ http://ww.sharepoint4ever.fr/Pages/aboutus.aspx http://fr.viadeo.com/fr/profile/kevin.trelohan http://fr.linkedin.com/in/kevintrelohan http://twitter.com/ktrelohan/

    mardi 17 décembre 2013 13:06
  • Aussi, si vous voulez rapporter un bug.. Connectez-vous vers SharePoint Connect ou ouvrez un call chez Microsoft selon votre partenariat.

    Cordialement,

    Gokan - Modérateur. 


    My Technical Blog on Wordpress

    vendredi 20 décembre 2013 07:28

Toutes les réponses

  • A priori vous n'utiliser pas les mêmes modèles de site et donc par définition, ils n'ont pas le même comportement ce qui me semble logique.



    kevin.trelohan@gmail.com http://kevintrelohan.blogspot.com/ http://ww.sharepoint4ever.fr/Pages/aboutus.aspx http://fr.viadeo.com/fr/profile/kevin.trelohan http://fr.linkedin.com/in/kevintrelohan http://twitter.com/ktrelohan/

    mardi 17 décembre 2013 13:06
  • Aussi, si vous voulez rapporter un bug.. Connectez-vous vers SharePoint Connect ou ouvrez un call chez Microsoft selon votre partenariat.

    Cordialement,

    Gokan - Modérateur. 


    My Technical Blog on Wordpress

    vendredi 20 décembre 2013 07:28