none
Application crash with AppVerifier RRS feed

  • Discussion générale

  • Hi.

    In the application we currently build, we got crash when we try to run the application when the AppVerifier is active.  The only test that makes the application crash is the Heaps test.

    When we run WinDBG during the test, the last few lines displayed in the application log are those one :

    combase!RoFailFastWithErrorContextInternal+0x112:
    75712716 6a03            push    3

    After a few search on the web, we find this question on Windows Metro Applications Questions website : answers.flyppdevportal.com/categories/metro/csharpvb.aspx?ID=0dcffd79-3848-4cc3-839d-ab7d3544f80a

    We don't know if the problem is the same, but we think it's a related problem.  And we don't know if the problem is still on the current version of Windows 8.

    After other few search, we found this application that can show the StackTrace with a crash : blogs.msdn.com/b/lagdas/archive/2008/06/24/debugging-heap-corruption-with-application-verifier-and-debugdiag.aspx

    When we run the application during a crash, the application return this log :

    combase!RoFailFastWithErrorContextInternal+112-
    Windows_UI_Xaml!CCoreServices::NWDrawTree+746ba5
    Windows_UI_Xaml!CCoreServices::NWDrawMainTree+2aa
    Windows_UI_Xaml!CWindowRenderTarget::Draw+75
    Windows_UI_Xaml!CXcpBrowserHost::OnTick+19c
    Windows_UI_Xaml!CXcpDispatcher::Tick+c3
    Windows_UI_Xaml!CXcpDispatcher::OnReentrancyProtectedWindowMessage+32
    Windows_UI_Xaml!CXcpDispatcher::WindowProc+6a
    user32!InternalCallWinProc+23
    user32!UserCallWinProcCheckWow+100
    user32!DispatchMessageWorker+3ef
    user32!DispatchMessageW+10
    windows_ui!Windows::UI::Core::CDispatcher::ProcessMessage+c9
    windows_ui!Windows::UI::Core::CDispatcher::ProcessEvents+7a
    Windows_UI_Xaml!CJupiterWindow::RunCoreWindowMessageLoop+33
    Windows_UI_Xaml!CJupiterControl::RunMessageLoop+28
    Windows_UI_Xaml!DirectUI::DXamlCore::RunMessageLoop+29
    Windows_UI_Xaml!DirectUI::FrameworkView::Run+c
    twinapi!Windows::ApplicationModel::Core::CoreApplicationView::Run+27
    twinapi!`Windows::ApplicationModel::Core::CoreApplicationViewAgileContainer::RuntimeClassInitialize'::`55'::<lambda_A2234BA2CCD64E2C>::operator()+b2
    twinapi!`Windows::ApplicationModel::Core::CoreApplicationViewAgileContainer::RuntimeClassInitialize'::`55'::<lambda_A2234BA2CCD64E2C>::<helper_func>+e
    SHCore!SHWaitForThreadWithWakeMask+13b
    kernel32!BaseThreadInitThunk+e
    ntdll!__RtlUserThreadStart+72
    ntdll!_RtlUserThreadStart+1b

    We don't know if the problem is on our side or not.  So if someone can just take a look at it. It would be really appreciated.

    Thanks!

    • Type modifié Aurel Bera mardi 18 décembre 2012 11:50 Send to English Forums
    jeudi 13 décembre 2012 15:04

Toutes les réponses