none
Access 2010 .adp ADO délai expiré RRS feed

  • Question

  • Bonjour,

    Avec un fichier .adp d'Access 2010, j'essai de modifier une table, mais en sauvegardant les changements, Access retourne une erreur de délai expiré sur ADO!

    J'ai essayé l'option dans préférences client, mais le délai expire toujours après 30 secondes!  Ce délai semble venir du serveur, et non d'Access...  Comment faire pour résoudre ce problème?

    L'option dans la table que je modifie n'est pas accessible depuis SSMS.

    Merci.


    Thanks, Dominic

    mardi 17 juillet 2012 18:28

Toutes les réponses

  • Bonjour,

    Qu'y a t-i eut entre le moment où vous avez migré vers 2010 et où cela fonctionnait (coté serveur) ?

    Essayez de nouveau en définssant un TimeOut à 0 (~= infini).

    Voyez le temps que met le processus de sauvegarde et s'il est acceptable, laissez tel que.

    S'il ne l'est pas, c'est qu'il y a un problème annexe que je ne sais déterminer dans l'état actuel des choses.


    Argy

    mercredi 18 juillet 2012 06:46
    Modérateur
  • Bonjour,

    Aucun lien avec la migration vers 2010!  D'ailleurs, ça souvent été un problème de modifier des tables SQL depuis Access.

    Comment mentionné, j'ai essayé en modifiant le timeout dans Access, mais après 30 secondes, l'erreur du délai revient, donc il ignore cette configuration de timeout dans Access.


    Thanks, Dominic

    mercredi 18 juillet 2012 15:01
  • Question : Combien y a t-il d'enregistrements dans la table ?

    Quand vous dîtes avoir modifié le TimeOut, à quelle valeur l'avez-vous fixé...?

    Avez-vous essayer d'affecter une élevée de l'ordre de 300 à 600 secondes ?


    Argy

    jeudi 19 juillet 2012 08:04
    Modérateur
  • Il y a peu d'enregistrements.  Ce qui est long, c'est la mise à jour des liens avec les autres tables!  Et certaines ont beaucoup d'enregistrements.

    Pour le timeout, j'ai essayé 0, 60 et 300 (le maximum), mais toujours avec un résultat de 30 secondes!  Donc j'en ai conclu que c'est le serveur qui met une limite de 30 secondes, mais comment lui indiquer d'attendre plus longtemps (que ce soit en général, ou pour cette transaction)?


    Thanks, Dominic

    jeudi 19 juillet 2012 13:35
  • Un cas similaire est abordé à cette page...

    Est-ce que vous êtes dans ce contexte ?


    Argy

    jeudi 19 juillet 2012 13:52
    Modérateur
  • Je fais le changement depuis Access, et non SSMS!  Cette option affecte les transactions depuis SSMS seulement.

    J'ai tout de même pris cette option en note, ça peut être pratique :)


    Thanks, Dominic

    jeudi 19 juillet 2012 15:17