none
Impossible d'utiliser une dll sous express 2010 RRS feed

  • Question

  • Bonjour, 

    J'ai fais ma petite dll, cependant, lorsque j'essai de l'importer par using, elle n'apparait pas, pourtant elle est bel et bien dans mes références. J'ai transféré le projet sur ce pc (puisque je l'utilisais auparavant sur mon ancien pc, sans problèmes) et je l'ai générée, re-générée, déboguer, sauvegarde, et ce plusieurs fois sans résultats... Si quelqu'un aurait une solution, cela me serait utile puisque je reste bloqué pour le moment ! Bonne soirée à tous.

    mardi 30 septembre 2014 19:04

Toutes les réponses

  • Bonjour,

    Pouvez-vous nous montrer le message d'erreur que vous obtenez ? Pouvez-vous nous confirmer que votre DLL contient bien des classes qui sont public (et non internal) ?

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance - P.O.S Informatique
    Blog : http://gilles.tourreau.fr - Suivez-moi sur Twitter
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCSA : SQL Server 2012
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0 / TFS 2010 / Windows Azure

    mardi 30 septembre 2014 23:31
    Modérateur
  • je n'obtiens aucun message d'erreur, la librairie est belle et bien listée dans mes references, mais lorsque je souhaite appeler une fonction/methode, rien n'apparait dans l'ide et me dit simplement qu'une reference d'assembly doit être manquante. mes fonctions/methodes sont bien en public.
    lundi 6 octobre 2014 20:15