none
[Problème] Contrôle publicité Microsoft Advertising RRS feed

  • Question

  • Bonjour,

    Souhaitant mettre de la pub dans mon application, je me suis enregistré sur PubCenter.

    J'ai donc enregistré une application, créé un bloc d'annonce, ajouté mon AdControl et renseigné les propriétés AdUnitId et ApplicationId comme il le faut.

    Mais lorsque je lance mon application, le contrôle s'affiche une demi-seconde et disparaît.

    J'aimerai savoir si quelqu'un a déjà rencontré ce problème et si quelqu'un sait le résoudre.

    Merci de votre aide.

    Benjamin.

    jeudi 17 mai 2012 17:21

Réponses

  • Fait un clic droit sur tes références, s'il n'y a pas de chemin d'accès c'est que tu dois les re-référencer.

    S'il y a un chemin, tu dois aller les chercher, faire un clic droit dessus, propriété et en bas à droite tu as un bouton Unlock (ça doit etre débloquer en francais).

    • Marqué comme réponse Shunzey vendredi 18 mai 2012 15:38
    vendredi 18 mai 2012 12:04

Toutes les réponses

  • Bonjour,

    Je connais 2 choses qui peuvent provoquer cela, le mauvais renseignement des champs AdUnitId et ApplicationId, ou le fait de ne pas avoir de réseau.

    vendredi 18 mai 2012 10:30
  • J'ai pourtant testé avec l'émulateur.

    Je ne vois pas d'où cela peut venir.

    vendredi 18 mai 2012 10:55
  • pourrais-tu vérifier que tu as ces capabilities dans ton fichier WMAppManifest :

    <Capability Name="ID_CAP_IDENTITY_DEVICE" />
    <Capability Name="ID_CAP_LOCATION" />
    <Capability Name="ID_CAP_NETWORKING" />
    <Capability Name="ID_CAP_PHONEDIALER" />
    <Capability Name="ID_CAP_WEBBROWSERCOMPONENT" />
    <Capability Name="ID_CAP_IDENTITY_USER"/>
    <Capability Name="ID_CAP_MEDIALIB"/>

    vendredi 18 mai 2012 11:28
  • Elles y sont toutes.

    J'ai rouvert la solution tout à l'heure et j'ai 2 nouveaux messages d'erreur que je n'avais pas la veille :

    - Erreur    2    Impossible de charger les métadonnées pour l'assembly 'Microsoft.Advertising.Mobile.UI'. Cet assembly peut avoir été téléchargé du Web. Consultez http://go.microsoft.com/fwlink/?LinkId=179545.  L'erreur suivante s'est produite lors du chargement : Impossible de charger le fichier ou l'assembly 'Microsoft.Advertising.Mobile.UI, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' ou une de ses dépendances. Le fichier spécifié est introuvable.

    - Erreur    3    Le type 'my:AdControl' est introuvable. Assurez-vous qu'il ne manque aucune référence d'assembly et que tous les assemblys référencés ont été générés.

    Du coup, mes références Microsoft.Advertising.Mobile ont un point d'exclamation.

    vendredi 18 mai 2012 11:58
  • Fait un clic droit sur tes références, s'il n'y a pas de chemin d'accès c'est que tu dois les re-référencer.

    S'il y a un chemin, tu dois aller les chercher, faire un clic droit dessus, propriété et en bas à droite tu as un bouton Unlock (ça doit etre débloquer en francais).

    • Marqué comme réponse Shunzey vendredi 18 mai 2012 15:38
    vendredi 18 mai 2012 12:04
  • Merci.

    Je les ai re-référencé et ça fonctionne.

    vendredi 18 mai 2012 15:39